Announcement

Collapse
No announcement yet.

No connection after replacing the router.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No connection after replacing the router.

    I'm using Pi24 image. On Thursday I changed the router to Mikrotik hap ac3. Since then, I have no communication with FR24. In the logs bellow, I can see that the problem lies in the lack of time synchronisation:





    Code:
    pi@raspberrypi:~ $ cat /etc/fr24feed.ini
    bs=no
    raw=no
    mlat="yes"
    mlat-without-gps="yes"
    logmode="1"
    receiver="beast-tcp"
    fr24key=xxxxxxxxxxxxxxx
    host="127.0.0.1:30005"
    Code:
    country=pl
    update_config=1
    ctrl_interface=/var/run/wpa_supplicant
    
    network={
    ssid="_2,4"
    psk="txxxx2"
    }
    Code:
    pi@raspberrypi:~ $ apt-cache policy dump1090-mutability | grep Installed
    Installed: (none)
    Code:
    pi@raspberrypi:~ $ apt-cache policy dump1090-fa | grep Installed
    Installed: 5.0
    Code:
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2021-03-30 17:25:51.
    [FAIL] FR24 Link: unknown ... failed!
    [ ok ] Receiver: connected (1985958 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    Code:
    pi@raspberrypi:~ $ sudo fr24feed
    
    2021-03-30 18:26:35 | [main][i]FR24 Feeder/Decoder
    2021-03-30 18:26:35 | [main][i]Version: 1.0.26-9/generic
    2021-03-30 18:26:35 | [main][i]Built on Oct 14 2020 07:35:30 (HEAD-de0814c.git/Linux/static_armel)
    2021-03-30 18:26:35 | [main][i]Running on: pi24-raspbian10
    2021-03-30 18:26:35 | [main][i]Local IP(s): 192.168.1.108
    2021-03-30 18:26:35 | [main][i]Copyright 2012-2020 Flightradar24 AB
    2021-03-30 18:26:35 | [main][i]https://www.flightradar24.com
    2021-03-30 18:26:35 | [main][i]DNS mode: PING
    2021-03-30 18:26:35 | [main][i]Automatic updates are ENABLED
    2021-03-30 18:26:35 | [httpd][w]bind function failed, errno: 98, waiting 1 seconds
    2021-03-30 18:26:35 | [e]PacketSenderConfiguration::fetch_config(): Unable to fetch configuration for yoda receiver
    2021-03-30 18:26:35 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
    2021-03-30 18:26:35 | [main][i]Reader thread started
    2021-03-30 18:26:35 | [master][i]Starting processing thread
    2021-03-30 18:26:35 | [main][i]MLAT data feed started
    2021-03-30 18:26:35 | [reader][i]Initializing reader
    2021-03-30 18:26:35 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2021-03-30 18:26:35 | [mlat][i]Waiting for MLAT configuration
    2021-03-30 18:26:35 | [reader][i]Connected to the receiver, configuring
    2021-03-30 18:26:35 | [reader][i]Configured, processing messages
    2021-03-30 18:26:35 | [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
    2021-03-30 18:26:36 | [httpd][w]bind function failed, errno: 98, waiting 6 seconds
    2021-03-30 18:26:42 | [httpd][w]bind function failed, errno: 98, waiting 11 seconds
    2021-03-30 18:26:53 | [httpd][w]bind function failed, errno: 98, waiting 16 seconds
    2021-03-30 18:27:09 | [httpd][w]bind function failed, errno: 98, waiting 21 seconds
    2021-03-30 18:27:16 | [time][i]Synchronizing time via NTP
    2021-03-30 18:27:30 | [httpd][w]bind function failed, errno: 98, waiting 26 seconds
    2021-03-30 18:27:56 | [httpd][w]bind function failed, errno: 98, waiting 31 seconds
    2021-03-30 18:27:56 | [time][e]Failed to synchronize time
    2021-03-30 18:27:56 | [main][w]Failed to synchronize time, waiting 6 seconds
    I tried to use this guide. Unfortunately, it didn't work.

    https://www.linuxuprising.com/2019/0...e-network.html

    Code:
    pi@raspberrypi:~ $ timedatectl
                   Local time: Tue 2021-03-30 18:29:30 BST
               Universal time: Tue 2021-03-30 17:29:30 UTC
                     RTC time: n/a
                    Time zone: Europe/London (BST, +0100)
    System clock synchronized: no
                  NTP service: inactive
              RTC in local TZ: no
    Is it a router settings problem? All devices connected to it are working properly.
    Everything works fine on the internal network.

    Last edited by chemitox; 2021-03-30, 20:16.

  • #2

    2021-03-30 18:26:35 | [httpd][w]bind function failed, errno: 98, waiting 1 seconds = port blocked

    Bind err = already in use/open and cannot get exclusive control. :8754 (the web config) portion of the app cannot start.

    Have you rebooted it since change? Or killed the fr24feed processes.

    If so, the smart firewall may also be too strict for outbound traffic
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      In file wpa_supplicant.conf, you have

      country=pl

      Try capital letters for country code like this:

      country=PL

      Save file, then reboot Pi, and check again.

      .

      Comment


      • #4
        Thank you for your interest.

        abcd567 I changed how you write, but it didn't help.

        Code:
        pi@raspberrypi:~ $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
        country=PL
        update_config=1
        ctrl_interface=/var/run/wpa_supplicant
        
        network={
        ssid="_2,4"
        psk="txxxx2"
        }
        Code:
        pi@raspberrypi:~ $ sudo fr24feed-status
        [ ok ] FR24 Feeder/Decoder Process: running.
        [ ok ] FR24 Stats Timestamp:.
        [FAIL] FR24 Link: unknown ... failed!
        [FAIL] Receiver: down ... failed!
        [FAIL] FR24 MLAT: not running ... failed!
        Code:
        pi@raspberrypi:~ $ sudo fr24feed
        2021-03-30 22:46:21 | [main][i]FR24 Feeder/Decoder
        2021-03-30 22:46:21 | [main][i]Version: 1.0.26-9/generic
        2021-03-30 22:46:21 | [main][i]Built on Oct 14 2020 07:35:30 (HEAD-de0814c.git/Linux/static_armel)
        2021-03-30 22:46:21 | [main][i]Running on: pi24-raspbian10
        2021-03-30 22:46:21 | [main][i]Local IP(s): 192.168.1.108
        2021-03-30 22:46:21 | [main][i]Copyright 2012-2020 Flightradar24 AB
        2021-03-30 22:46:21 | [main][i]https://www.flightradar24.com
        2021-03-30 22:46:21 | [main][i]DNS mode: PING
        2021-03-30 22:46:21 | [main][i]Automatic updates are ENABLED
        2021-03-30 22:46:21 | [httpd][w]bind function failed, errno: 98, waiting 1 seconds
        2021-03-30 22:46:22 | [httpd][w]bind function failed, errno: 98, waiting 6 seconds
        2021-03-30 22:46:28 | [httpd][w]bind function failed, errno: 98, waiting 11 seconds
        2021-03-30 22:46:31 | [e]PacketSenderConfiguration::fetch_config(): Unable to fetch configuration for yoda receiver
        2021-03-30 22:46:31 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
        2021-03-30 22:46:31 | [main][i]Reader thread started
        2021-03-30 22:46:31 | [master][i]Starting processing thread
        2021-03-30 22:46:31 | [main][i]MLAT data feed started
        2021-03-30 22:46:31 | [reader][i]Initializing reader
        2021-03-30 22:46:31 | [mlat][i]Waiting for MLAT configuration
        2021-03-30 22:46:31 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
        2021-03-30 22:46:31 | [reader][i]Connected to the receiver, configuring
        2021-03-30 22:46:31 | [reader][i]Configured, processing messages
        2021-03-30 22:46:31 | [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
        2021-03-30 22:46:39 | [httpd][w]bind function failed, errno: 98, waiting 16 seconds
        2021-03-30 22:46:52 | [time][i]Synchronizing time via NTP
        2021-03-30 22:46:55 | [httpd][w]bind function failed, errno: 98, waiting 21 seconds
        2021-03-30 22:47:12 | [time][e]Failed to synchronize time
        2021-03-30 22:47:12 | [main][w]Failed to synchronize time, waiting 6 seconds
        2021-03-30 22:47:16 | [httpd][w]bind function failed, errno: 98, waiting 26 seconds
        2021-03-30 22:47:38 | [time][i]Synchronizing time via NTP
        2021-03-30 22:47:42 | [httpd][w]bind function failed, errno: 98, waiting 31 seconds
        2021-03-30 22:47:48 | [time][e]Failed to synchronize time
        2021-03-30 22:47:48 | [main][w]Failed to synchronize time, waiting 8 seconds
        2021-03-30 22:48:13 | [httpd][e]bind function failed, errno: 98
        ^C2021-03-30 22:48:15 | [main][i]Terminating on user request
        2021-03-30 22:48:15 | [time][i]Synchronizing time via NTP
        2021-03-30 22:48:15 | [reader][i]Connection terminated
        2021-03-30 22:48:15 | [reader][i]Terminating on request
        You can still see the time difference between the log and the FR status screen.



        Oblivian maybe I don't really have internet on it. If let go of the ping, it passes, but I can't download the update.

        Code:
        pi@raspberrypi:~ $ ping 93.93.128.193
        PING 93.93.128.193 (93.93.128.193) 56(84) bytes of data.
        64 bytes from 93.93.128.193: icmp_seq=1 ttl=51 time=37.6 ms
        64 bytes from 93.93.128.193: icmp_seq=2 ttl=51 time=37.6 ms
        64 bytes from 93.93.128.193: icmp_seq=3 ttl=51 time=37.6 ms
        64 bytes from 93.93.128.193: icmp_seq=4 ttl=51 time=37.4 ms
        64 bytes from 93.93.128.193: icmp_seq=5 ttl=51 time=37.6 ms
        64 bytes from 93.93.128.193: icmp_seq=6 ttl=51 time=37.4 ms
        64 bytes from 93.93.128.193: icmp_seq=7 ttl=51 time=37.3 ms
        ^C
        --- 93.93.128.193 ping statistics ---
        7 packets transmitted, 7 received, 0% packet loss, time 16ms
        rtt min/avg/max/mdev = 37.331/37.500/37.621/0.277 ms
        Code:
        pi@raspberrypi:~ $ ping 70.42.6.250
        PING 70.42.6.250 (70.42.6.250) 56(84) bytes of data.
        64 bytes from 70.42.6.250: icmp_seq=1 ttl=44 time=137 ms
        64 bytes from 70.42.6.250: icmp_seq=2 ttl=44 time=137 ms
        64 bytes from 70.42.6.250: icmp_seq=3 ttl=44 time=146 ms
        64 bytes from 70.42.6.250: icmp_seq=4 ttl=44 time=137 ms
        64 bytes from 70.42.6.250: icmp_seq=5 ttl=44 time=136 ms
        64 bytes from 70.42.6.250: icmp_seq=6 ttl=44 time=137 ms
        64 bytes from 70.42.6.250: icmp_seq=7 ttl=44 time=137 ms
        64 bytes from 70.42.6.250: icmp_seq=8 ttl=44 time=137 ms
        ^C
        --- 70.42.6.250 ping statistics ---
        8 packets transmitted, 8 received, 0% packet loss, time 10ms
        rtt min/avg/max/mdev = 136.482/137.987/145.820/3.002 ms
        Code:
        pi@raspberrypi:~ $ sudo apt-get update
        Err:1 http://archive.raspberrypi.org/debian buster InRelease
        Temporary failure resolving 'archive.raspberrypi.org'
        Err:2 http://repo.feed.flightradar24.com flightradar24 InRelease
        Temporary failure resolving 'repo.feed.flightradar24.com'
        Err:3 http://raspbian.raspberrypi.org/raspbian buster InRelease
        Temporary failure resolving 'raspbian.raspberrypi.org'
        Err:4 http://flightaware.com/adsb/piaware/files/packages buster InRelease
        Temporary failure resolving 'flightaware.com'
        Err:5 https://apt.rb24.com buster InRelease
        Temporary failure resolving 'apt.rb24.com'
        Reading package lists... Done
        W: Failed to fetch http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease Temporary failure resolving 'raspbian.raspberrypi.org'
        W: Failed to fetch http://repo.feed.flightradar24.com/dists/flightradar24/InRelease Temporary failure resolving 'repo.feed.flightradar24.com'
        W: Failed to fetch http://flightaware.com/adsb/piaware/files/packages/dists/buster/InRelease Temporary failure resolving 'flightaware.com'
        W: Failed to fetch http://archive.raspberrypi.org/debian/dists/buster/InRelease Temporary failure resolving 'archive.raspberrypi.org'
        W: Failed to fetch https://apt.rb24.com/dists/buster/InRelease Temporary failure resolving 'apt.rb24.com'
        W: Some index files failed to download. They have been ignored, or old ones used instead.

        Comment


        • #5
          Note, by restarting 'sudo fr24feed' you are opening a 2nd copy. That is where the Bind err is coming from

          If you want to see the real startup using that, you need to STOP the one hidden in the background first.
          sudo systemctl stop fr24feed

          But yes. You have no internet connection. It cannot resolve internet addresses
          Manually edited the DNS previously? Or lookups being blocked, or needs new DHCP/DNS GW from new router if the IP range is different.

          All of which should refresh on a restart

          This may break if you are not using a local screen/keyboard input. But you can also force it
          1st one releases. 2nd one asks for another

          sudo dhclient -r
          sudo dhclient
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            On Rpi I have got set static IP adress, and config looks this way:

            Code:
            pi@raspberrypi:~ $ sudo nano /etc/dhcpcd.conf
            
            interface wlan0
            static ip_address=192.168.1.108/24
            static routers=192.168.1.1
            static domain_name_servers=192.168.1.1
            Code:
            pi@raspberrypi:~ $ sudo dhclient -r
            pi@raspberrypi:~ $ sudo dhclient
            Too few arguments.
            Too few arguments.
            Warning: The unit file, source configuration file or drop-ins of systemd-timesyncd.service changed on disk. Run 'systemctl daemon-reload' to reload units.
            Code:
            pi@raspberrypi:~ $ sudo systemctl daemon-reload
            pi@raspberrypi:~ $
            I download DNS in the router from the internet provider. At the moment it's:

            Code:
            pi@raspberrypi:~ $ sudo cat /etc/resolv.conf
            # Generated by resolvconf
            nameserver 192.168.1.1
            nameserver 83.175.144.9
            nameserver 83.175.144.14
            I'll try to change it for Cloudflare and Google now.

            I don't know if it is DNS's fault, as many different devices (WLAN and LAN as well) works properly.

            I have looked through some other commands that I can check in at this topic: https://forum.flightradar24.com/foru...ld-not-connect

            Code:
            pi@raspberrypi:~ $ sudo traceroute 185.218.24.23 -T -p 8099
            traceroute to 185.218.24.23 (185.218.24.23), 30 hops max, 60 byte packets
            1 192.168.1.1 (192.168.1.1) 2.028 ms 2.251 ms 2.250 ms
            2 10.0.127.254 (10.0.127.254) 2.328 ms 2.748 ms 2.824 ms
            3 109.231.34.196.koba.pl (109.231.34.196) 2.717 ms 2.936 ms 2.925 ms
            4 be6078.rcr21.b016833-0.waw01.atlas.cogentco.com (149.6.71.153) 8.170 ms 7.514 ms 7.680 ms
            5 cloudflare.demarc.cogentco.com (149.6.71.18) 8.035 ms 7.969 ms 7.870 ms
            6 162.158.101.47 (162.158.101.47) 7.005 ms 162.158.101.62 (162.158.101.62) 7.597 ms 162.158.101.49 (162.158.101.49) 6.939 ms
            7 162.158.101.23 (162.158.101.23) 7.140 ms 6.979 ms 162.158.101.47 (162.158.101.47) 7.260 ms
            8 * * *
            9 185.218.24.23 (185.218.24.23) 32.687 ms 32.828 ms 32.717 ms
            Code:
            pi@raspberrypi:~ $ sudo traceroute -n 185.218.24.22 -m20
            traceroute to 185.218.24.22 (185.218.24.22), 20 hops max, 60 byte packets
            1 192.168.1.1 1.300 ms 1.203 ms 1.966 ms
            2 10.0.127.254 3.059 ms 2.703 ms 2.852 ms
            3 109.231.34.196 2.775 ms 3.262 ms 3.284 ms
            4 149.6.71.153 7.759 ms 7.109 ms 7.247 ms
            5 149.6.71.18 9.610 ms 9.758 ms 9.881 ms
            6 162.158.101.31 9.727 ms 162.158.101.35 8.803 ms 162.158.101.10 8.740 ms
            7 162.158.101.42 8.700 ms 162.158.101.18 9.042 ms 162.158.101.78 9.065 ms
            8 * * *
            9 * * *
            10 * * *
            11 * * *
            12 * * *
            13 * * *
            14 * * *
            15 * * *
            16 * * *
            17 * * *
            18 * * *
            19 * * *
            20 * * *
            Last edited by chemitox; 2021-04-01, 17:55.

            Comment


            • #7
              pi@raspberrypi:~ $ sudo dhclient -r

              dhclient and dhcpcd are two things and i don't think they mix.
              try removing dhclient?

              Anyhow for proper testing you need to stop the service

              sudo systemctl stop fr24feed
              sudo fr24feed

              Once you are done with testing you can restart the service
              sudo systemctl restart fr24feed

              Comment


              • #8
                Unfortunately, your advice didn't work.

                Code:
                pi@raspberrypi:~ $ sudo systemctl stop fr24feed
                pi@raspberrypi:~ $ sudo systemctl restart fr24feed
                pi@raspberrypi:~ $ sudo fr24feed
                2021-04-02 15:33:15 | [main][i]FR24 Feeder/Decoder
                2021-04-02 15:33:15 | [main][i]Version: 1.0.26-9/generic
                2021-04-02 15:33:15 | [main][i]Built on Oct 14 2020 07:35:30 (HEAD-de0814c.git/Linux/static_armel)
                2021-04-02 15:33:15 | [main][i]Running on: pi24-raspbian10
                2021-04-02 15:33:15 | [main][i]Local IP(s): 192.168.1.108
                2021-04-02 15:33:15 | [main][i]Copyright 2012-2020 Flightradar24 AB
                2021-04-02 15:33:15 | [main][i]https://www.flightradar24.com
                2021-04-02 15:33:15 | [main][i]DNS mode: PING
                2021-04-02 15:33:15 | [main][i]Automatic updates are ENABLED
                2021-04-02 15:33:15 | [httpd][w]bind function failed, errno: 98, waiting 1 seconds
                2021-04-02 15:33:15 | [e]PacketSenderConfiguration::fetch_config(): Unable to fetch configuration for yoda receiver
                2021-04-02 15:33:15 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
                2021-04-02 15:33:15 | [main][i]Reader thread started
                2021-04-02 15:33:15 | [master][i]Starting processing thread
                2021-04-02 15:33:15 | [main][i]MLAT data feed started
                2021-04-02 15:33:15 | [reader][i]Initializing reader
                2021-04-02 15:33:15 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
                2021-04-02 15:33:15 | [mlat][i]Waiting for MLAT configuration
                2021-04-02 15:33:15 | [reader][i]Connected to the receiver, configuring
                2021-04-02 15:33:15 | [reader][i]Configured, processing messages
                2021-04-02 15:33:16 | [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
                2021-04-02 15:33:16 | [httpd][w]bind function failed, errno: 98, waiting 6 seconds
                2021-04-02 15:33:22 | [httpd][w]bind function failed, errno: 98, waiting 11 seconds
                2021-04-02 15:33:33 | [httpd][w]bind function failed, errno: 98, waiting 16 seconds
                2021-04-02 15:33:36 | [time][i]Synchronizing time via NTP
                2021-04-02 15:33:36 | [time][e]Failed to synchronize time
                2021-04-02 15:33:36 | [main][w]Failed to synchronize time, waiting 6 seconds
                2021-04-02 15:33:49 | [httpd][w]bind function failed, errno: 98, waiting 21 seconds
                2021-04-02 15:34:02 | [time][i]Synchronizing time via NTP
                2021-04-02 15:34:10 | [httpd][w]bind function failed, errno: 98, waiting 26 seconds
                2021-04-02 15:34:22 | [time][e]Failed to synchronize time
                2021-04-02 15:34:22 | [main][w]Failed to synchronize time, waiting 8 seconds
                2021-04-02 15:34:36 | [httpd][w]bind function failed, errno: 98, waiting 31 seconds
                As can be seen from the logs above, it was working for a moment yesterday: https://www.radarbox.com/stations/EXTRPI015003
                At that time I was observing the connection on two IPs:

                And because of that i'm sure that the problem lies in Rpi configuration WiFi.

                I'm a beginner in Linux systems, so please tell me what I should do next to diagnose the problem?

                I want to have a static IP (192.168.1.108). I definitely DO NOT want it to work in DHCP.

                Comment


                • #9
                  You just did the exact same thing

                  Leave out the systemctl restart

                  Sudo fr24feed will ALWAYS launch a front and centre execution on screen and should only be used for diagnosis.

                  Systemctl, launches it as a system service in the background. Ala 2 copies conflict.



                  If you want static. Set it in the router dhcp table as a reserve. Much easier to ensure the thing updates with changes made to local network.
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    https://github.com/wiedehopf/adsb-wiki/wiki/Static-IP

                    Did you install dhclient.
                    I'd recommend as i said before removing dhclient:

                    sudo apt remove dhclient

                    That way you can configure dhcpcd as described in the link and dhclient shouldn't interfere.

                    Comment


                    • #11
                      @wiedehopf,of course it looked like in the link you sent.

                      Old settings:

                      Code:
                      pi@raspberrypi:~ $ sudo nano /etc/dhcpcd.conf
                      interface wlan0
                      static ip_address=192.168.1.108/24
                      static routers=192.168.1.1
                      static domain_name_servers=192.168.1.1
                      Current settings:

                      Code:
                      pi@raspberrypi:~ $ sudo nano /etc/dhcpcd.conf
                      
                      GNU nano 3.2 /etc/dhcpcd.conf
                      
                      # A sample configuration for dhcpcd.
                      # See dhcpcd.conf(5) for details.
                      
                      # Allow users of this group to interact with dhcpcd via the control socket.
                      #controlgroup wheel
                      
                      # Inform the DHCP server of our hostname for DDNS.
                      hostname
                      
                      # Use the hardware address of the interface for the Client ID.
                      clientid
                      # or
                      # Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
                      # Some non-RFC compliant DHCP servers do not reply with this set.
                      # In this case, comment out duid and enable clientid above.
                      #duid
                      
                      # Persist interface configuration when dhcpcd exits.
                      persistent

                      I removed the static IP config some time ago and it started working. Router set it a dynamic IP 192.168.1.21, but it still has something from that static IP, as it opens a website, but it's empty.






                      Comment


                      • #12
                        When on that page at static IP, do this:
                        Clear Browser Cache: Ctrl+Shift+Delete
                        Reload Browser: Ctrl+F5

                        Comment

                        Working...
                        X