Announcement

Collapse
No announcement yet.

New here - Help please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New here - Help please

    Hi, I bought everything from the fr24 site where is written build your own... Because of my first post I can not put any link in this post...

    ( I have this in my raspberry
    Nooelec NESDR SMArTee v2 Bundle - Premium RTL-SDR w/ Aluminum Enclosure, Bias Tee, 0.5PPM TCXO, SMA Input & 3 Antennas. RTL2832U & R820T2-Based)



    Then I installed everything as written on the flightradar page, I startet the raspberry with antena on the roof of my house, I;m online since today 09:40AM CET, but I saw only 8 aircrafts and now I see nothing - no airplanes. I see planes from my window, I see planes in the app on my phone whitch are flying very close from my location...

    And I dont sent any data - look at the picture... Can anybody tell me please what I have to do ?
    Thanx





  • #2
    You could be using bad coax that eliminates too much of the signal.
    Could be that you got some coax with an RP-SMA connector instead of SMA (RP-SMA misses the pin)

    Could be that you're using an unsuitable antenna, this should give you some idea on the dimensions:
    https://forum.flightradar24.com/foru...-for-beginners
    https://forum.flightradar24.com/foru...-whip-antennas


    It also looks like the connection to fr24 might be intermittent and that can have all kinds of reasons.
    I'd recommend using this guide to set up your RPi ... you can use your current image, use the automatic readsb install, the tar1090 install and graphs1090 install:
    https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

    That way you have good logs and can more easily distinguish between issues with FR24 and issues with your reception.
    The graphs will also show a signal graph which can others help give you hints in regards to what is the issue with the antenna.


    Could also be that you're power supply for the pi is insufficient that can cause bad SDR performance / SDR issues.
    Check this command:

    sudo dmesg --ctime | grep voltage

    No output means that the power is fine.
    Then there could be independent voltage issues if you're using an USB extension.
    Last edited by wiedehopf; 2021-03-14, 18:44.

    Comment


    • #3
      I have used only original parts also coax only this cable whitch was delivered.

      omg

      I have reinstalled the SW on the SD card and now Im offline .... on the fr24 page where i shoud activate my raspberry is that im active and online... but im offline... what i have to change after a new instalation. I formated the SD card from raspberry and installed it new...

      Comment


      • #4
        Well you need to install fr24feed either you just use their script and it should automatically detect the existing decoder.
        Or you use the method outlined on the page i linked to install fr24feed: https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

        During the install on the console it will ask you for your mail address, that will add the receiver to your fr24 account so use the same mail address you used for that.

        Did you manage to get SSH access and install readsb?
        Is the local webinterface working?

        Comment


        • #5
          Im now online again I have used sudo fr24feed --signup etc... and Im now online again after reinstalled the SD card..
          but i still no sending data...

          Comment


          • #6
            Where is the problem anybody has an idea ? why i dont sent data ?

            Comment


            • #7
              pi@raspberrypi:~ $ sudo fr24feed-status
              [ ok ] FR24 Feeder/Decoder Process: running.
              [ ok ] FR24 Stats Timestamp:.
              [ ok ] FR24 Link: connected [UDP].
              [ ok ] FR24 Radar: T-LZIB133.
              [ ok ] FR24 Tracked AC: 0.
              [ ok ] Receiver: connected ( MSGS/ SYNC).
              [FAIL] FR24 MLAT: not running ... failed!


              why I dont send Data ? receiver connected, everything ok.... im online...

              Comment


              • #8
                Nothing received is why.

                Wrong DVBT tuner type
                Crashed/restarting (auto start dump1090-mutability they include not working)
                No 'real' antenna connection

                Someone else will know better, but if it has Bias-T, doesn't that need a particular connection flow or command to enable..

                Also. Please don't keep using the activation page when reinstalling. It will keep dishing out new IDs that falsely give an indicator of the number of receivers in the region.
                Always try re-associate your existing one

                Forget the FR24 instructions. Follow the step by steps re-written by users, or install scrips which 'fix' fr24s ones.
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  So ... to check the SDR if it's genuine you can run this script:

                  sudo bash -c "$(wget -nv -O - https://raw.githubusercontent.com/wiedehopf/adsb-scripts/master/rtl_test.sh)"

                  If it says FC0012 or FC0013 as a tuner your SDR isn't genuine and you can't receive ADS-B with it.

                  Did you install graphs1090 and can share the signal graph?

                  The antenna should be in a window.
                  Don't put it in the same room as HDMI TVs or monitors if possible.

                  If you have magnet base antennas place a can under them, the whip should be around 6.8 cm long.
                  Try the smallest of the antennas with a metal can under it.

                  Have you checked for undervoltage as instructed?

                  Comment


                  • #10
                    Originally posted by Oblivian View Post
                    Someone else will know better, but if it has Bias-T, doesn't that need a particular connection flow or command to enable..
                    A Bias-T normally needs a DC power supply.

                    Can you provide a link to the "bundle" you purchased?

                    Mike


                    www.radarspotting.com

                    Radarspotting since 2005

                    Comment


                    • #11

                      pi@raspberrypi:~ $ sudo bash -c "$(wget -nv -O - https://raw.githubusercontent.com/wiedehopf/adsb-scripts/master/rtl_test.sh)"
                      2021-03-15 18:08:59 URL:https://raw.githubusercontent.com/wi...er/rtl_test.sh [2387/2387] -> "-" [1]
                      Reading package lists... Done
                      Building dependency tree
                      Reading state information... Done
                      The following NEW packages will be installed:
                      rtl-sdr
                      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
                      Need to get 52.4 kB of archives.
                      After this operation, 178 kB of additional disk space will be used.
                      Get:1 http://archive.raspberrypi.org/debian buster/main armhf rtl-sdr armhf 0.6-1+rpt1 [52.4 kB]
                      Fetched 52.4 kB in 0s (222 kB/s)
                      Selecting previously unselected package rtl-sdr.
                      (Reading database ... 99496 files and directories currently installed.)
                      Preparing to unpack .../rtl-sdr_0.6-1+rpt1_armhf.deb ...
                      Unpacking rtl-sdr (0.6-1+rpt1) ...
                      Setting up rtl-sdr (0.6-1+rpt1) ...
                      Processing triggers for man-db (2.8.5-2) ...
                      -----
                      Lost samples in the first 2 seconds after starting the test are common and not a problem!
                      Starting 30 second rtl_test, standby!
                      -----
                      Found 1 device(s):
                      0: Realtek, RTL2838UHIDIR, SN: 00000000

                      Using device 0: Generic RTL2832U OEM
                      No supported tuner found
                      Enabled direct sampling mode, input 1
                      Supported gain values (1): 0.0
                      Sampling at 2400000 S/s.

                      Info: This tool will continuously read from the device, and report if
                      samples get lost. If you observe no further output, everything is fine.

                      Reading samples in async mode...
                      Allocating 15 zero-copy buffers
                      lost at least 128 bytes
                      Signal caught, exiting!

                      User cancel, exiting...
                      Samples per million lost (minimum): 0
                      -------
                      Test finished!
                      More than 2 lost samples per million or other errors probably mean the receiver isn't working correctly.
                      Try another power supply before condemning the receiver though!
                      -------
                      -------
                      No undervoltage detected, looking fine!
                      If the dongle is not directly plugged into the Raspberry Pi, lack of power/voltage could still be an issue.
                      Even without detected undervoltage a better power supply can often improve reception!
                      For optimum performance i would recommend the Official Raspberry Pi power supply.
                      ---

                      Comment


                      • #12
                        I purchased everything as on this link
                        https://www.flightradar24.com/build-your-own

                        Comment


                        • #13
                          So a small review what I did since last night.

                          I instaled a new raspbian image then i followed this instructions here
                          https://forum.flightradar24.com/foru...ability-on-rpi
                          until point 10 fr24 data feeder

                          my setting looks now like you can see on the image attacheed

                          on this page http://192.168.1.137/dump1090/gmap.html i have down a message

                          Problem fetching data from dump1090.
                          AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
                          The displayed map data will be out of date.

                          i;m a total beginner i found out how to "comunicate" with raspbery with putty but i dont know the right steps..


                          and i still have no data, nothing to send because i dont see anything - or my antena is blind

                          Comment


                          • #14
                            Originally posted by Anmer View Post

                            A Bias-T normally needs a DC power supply.

                            Can you provide a link to the "bundle" you purchased?
                            He purchased an SDR that provides bias-t voltage but he didn't buy an LNA.
                            It's all good no need to be worried about that.


                            Please check the thread on antennas: https://forum.flightradar24.com/foru...-whip-antennas

                            Where do you have the antenna, it's best in a room without any computer monitors especially HDMI cables are problematic.
                            Then you should put it on a metal can.
                            The antenna should have a good view of the landscape ... that improves reception a lot.
                            Imagine the antenna needs to "see" the aircraft. (but it can see through fog and clouds)

                            Try
                            sudo reboot
                            see if the local webinterface starts working again.

                            Otherwise ... i'm not a fan of debugging peoples installs that's why i made quite a few scripts.
                            This one should provide you with a working setup if you run it:
                            https://github.com/wiedehopf/adsb-sc...ion-for-readsb

                            If you want to stay with dump1090-mutability you'll have to wait for someone else to guide you through the troubleshooting.
                            Last edited by wiedehopf; 2021-03-15, 19:47.

                            Comment


                            • #15
                              I have the antena outside on the roof.

                              now I followed everything here https://github.com/wiedehopf/adsb-sc...ion-for-readsb

                              but no change... on the ip/tar1090 adress i see that what is on the picture attached... the black point is my possition... but nothing else

                              How can I check if the USB dongle with the antena is working - connected to the raspberry and if the raspberry can use it ? I have this feeling that the usb dongle is not recognized by the raspberry...

                              Comment

                              Working...
                              X