Announcement

Collapse
No announcement yet.

Why is this not working at all?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why is this not working at all?

    I'm at my wits' end with this.

    I have a pi3, an RTL-SDR DVB-T stick, a 1090 LNA and a Radarbox antenna which will next week be mounted to the chimney of my house.

    I am attempting to set it up indoors to get it working before I go to the trouble of mounting it. I cannot get it to work AT ALL.

    I have so far rewritten the pi24 image to the card about ten times and gone through the setup process following the forum's how-to to the absolute letter. I haven't installed any other feeders or software or devices.

    Firstly, it will no longer connect to the wifi. At all. Not by running the CLI config nor by manually editing the wpa_supplicant file. I can get it to join the network via ethernet but that's not practical for where I want to permanently locate it.

    Secondly, I live in a moderate air traffic area getting a lot of planes coming directly overhead to/from the States and into and out of LPL and MAN. If I look on FR24 there are over twenty aircraft right now. If I pull up Dump1090 there are... none.

    Code:
    pi@raspberrypi:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2021-03-05 19:20:29.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EGGP193.
    [ ok ] FR24 Tracked AC: 0.
    [ ok ] Receiver: connected ( MSGS/ SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    Cannot get it to see any aircraft at all. I am about to bin the whole lot unless someone can possibly advise where I might be going wrong.

  • #2
    At a hazard say it's not got an appropriate tuner so deaf

    https://forum.flightradar24.com/foru...dongle-healthy
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      How is the LNA powered?
      You can always try without the LNA to pinpoint the issue.

      Maybe some RP-SMA connectors without pin instead of the correct SMA connector?

      In regards to the wifi ... does the RPi 3 model you have even have builtin wifi?
      Is the wifi you're trying to join 2.4 GHz?

      Post your wpa_supplicant.conf you're trying to use.

      Comment


      • #4
        Originally posted by Oblivian View Post
        At a hazard say it's not got an appropriate tuner so deaf

        https://forum.flightradar24.com/foru...dongle-healthy
        Thanks for that. I installed and tested as per the link, all tested fine.

        Comment


        • #5
          Originally posted by wiedehopf View Post
          How is the LNA powered?
          You can always try without the LNA to pinpoint the issue.

          Maybe some RP-SMA connectors without pin instead of the correct SMA connector?

          In regards to the wifi ... does the RPi 3 model you have even have builtin wifi?
          Is the wifi you're trying to join 2.4 GHz?

          Post your wpa_supplicant.conf you're trying to use.
          It goes pi -> dvb stick -> lna -> antenna. There are no inputs or outputs on the LNA other than the SMA connectors. I presume the LNA derives its power from the USB DVBT stick?

          The pi3 does have wifi. This setup (with a small indoor antenna) used to work perfectly well until I moved house and then stopped. I thought re-imaging would work but it has not solved it. The wifi is dual 2.4 and 5GHz
          Last edited by colinLPL; 2021-03-05, 20:43.

          Comment


          • #6
            I removed the LNA and it now sees one aircraft. As for the wpa_supplicant conf:

            Code:
            ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
            network={
            ssid="ColinWifi"
            psk="mypasswordhere"
            key_mgmt=WPA-PSK
            }

            Comment


            • #7
              If your SDR supports powering the LNA (most SDRs don't) then it needs to be enabled.

              the wifi config needs something like this at the very top:

              country=DE

              or as you're called colin probably
              country=GB
              (https://www.arubanetworks.com/techdo...Codes_List.htm)


              Now to get back to the SDR.
              If it's an rtl-sdr v3 from rtl-sdr blog then it can power the LNA.

              Install this:
              https://github.com/wiedehopf/adsb-sc...ion-for-readsb
              Then install this:
              https://github.com/wiedehopf/adsb-wi...i/RTL-Bias-Tee

              This should make it work without requiring you to understand the programming details
              Other stuff from this page will then also work: https://github.com/wiedehopf/adsb-wi...ADS-B-receiver
              No need to re-do the fr24 feed if it's working though. (that page changes the fr24feed install to not auto-update and stuff like that so it can't intefere with the system as it apparently occasionally does)

              Comment


              • #8
                OK firstly thanks for your help. With your scripts I now have it working with the LNA. I had been starting to get very lost in troubleshooting and you saved me a lot of annoyance.

                It definitely will not join the wifi. I can't understand this at all. Maybe I will try splitting the 2.4/5 and see if that helps.

                Comment


                • #9
                  Did you add the country=GB line to /etc/wpa_supplicant/wpa_supplicant.conf ?
                  Just reboot after making the change.

                  Comment


                  • #10
                    Yes I did. I also:

                    1. Split the wifi into 2.4 and 5ghz networks and tried to join each individually, without success.

                    2. Tested that I can see local SSIDs from the pi. I can.

                    3. Checked that wpa conf was pointing to wpa_supplicant in the correct folder. It is.

                    I'm all out of options.

                    Comment


                    • #11
                      It works!

                      I had to add update_config=1 to the wpa_supplicant.conf and rebooted and now it all works. I am seeing aircraft up to 200nm away just from propping the antenna inside my upstairs window. When I put it on the chimney a further 6m in the air next week I imagine the results will be even better.

                      Screen Shot 2021-03-06 at 7.34.13 AM.png

                      Comment


                      • #12
                        Type the following lines on your pi (or paste them line by line, not all at once):

                        sudo su -l
                        wpa_cli -i wlan0
                        reconfigure

                        Share the output.


                        Edit: nevermind.
                        Didn't know the update_config was important ...
                        And i can't see why it would be necessary ... oh well.
                        Last edited by wiedehopf; 2021-03-06, 07:42.

                        Comment


                        • #13
                          Originally posted by colinLPL View Post
                          I had to add update_config=1 to the wpa_supplicant.conf and rebooted and now it all works.

                          Originally posted by wiedehopf View Post
                          Didn't know the update_config was important ...
                          And i can't see why it would be necessary ... oh well.
                          The file /boot/wpa_supplicant.conf is provided with the image, and on first boot is moved to /etc/wpa_supplicant/wpa_supplicant.conf. This file already has a line update_config=1. I dont understand why you had to add it again.

                          Please see item 4 of this post:

                          https://forum.flightradar24.com/foru...509#post153509


                          .

                          Comment


                          • #14
                            I also don't understand why I had to add it again as all I had changed was the SSID and password, but I realised that the line was missing after I'd read about a similar problem on the pi forums and that was the suggested fix. I'm just glad it worked.

                            Would anyone be able to tell me why, in graphs1090, the ADS-B range graph is the only one which is not being populated? Perhaps I have installed it incorrectly.
                            dump1090-localhost-range-24h.png

                            Comment


                            • #15
                              https://github.com/wiedehopf/adsb-sc...ion-for-readsb

                              You installed this right?
                              It mentions setting the location, do that

                              Comment

                              Working...
                              X