Announcement

Collapse
No announcement yet.

No data is collected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No data is collected

    My decoder and feeder (running on a Raspberry Pi) have worked for months. A few days ago, I discovered that I am no longer submitting any data.

    fr24feed-status reports:
    Code:
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2021-02-22 21:33:50.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-ENSK2.
    [ ok ] FR24 Tracked AC: 0.
    [ ok ] Receiver: connected (0 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 0.
    I have tried rebooting the unit, changing the antenna, antenna cable and the USB dongle with my spare units. Nothing seems to help.

    The dump1090 map server is not showing any planes, either - nor is local data available to the radar view on FR24.

    The unit is also running a webcam server that seems to work without any issues.

    I'm not aware that I have done any changes to the setup, apart from running sudo apt upgrade at irregular intervals.

    Which steps should I take to troubleshoot this before I reconfigure the unit anew?
    Last edited by T-ENSK1; 2021-02-22, 21:59.

  • #2
    May be dongle is gone bad. To check, give following commands and post output of last command.
    Code:
    sudo apt-get install rtl-sdr  
    
    rtl_test -t

    Comment


    • #3
      It still says receiver connected so rtl_test won't work without first doing sudo systemctl stop fr24feeed

      Well you can always check the configuration, share the output of this command:
      cat /etc/fr24feed.ini

      Remove the share key line.

      Comment


      • #4
        Originally posted by abcd567 View Post
        May be dongle is gone bad. To check, give following commands and post output of last command.
        Code:
        sudo apt-get install rtl-sdr
        
        rtl_test -t
        After stopping the fr24feed service:

        Code:
        Found 1 device(s):
        0: Realtek, RTL2838UHIDIR, SN: 00000001
        
        Using device 0: Generic RTL2832U OEM
        usb_claim_interface error -6
        Failed to open rtlsdr device #0.

        Comment


        • #5
          Originally posted by wiedehopf View Post
          It still says receiver connected so rtl_test won't work without first doing sudo systemctl stop fr24feeed

          Well you can always check the configuration, share the output of this command:
          cat /etc/fr24feed.ini

          Remove the share key line.
          Code:
          receiver="dvbt"
          fr24key=[redacted]
          path="/usr/lib/fr24/dump1090"
          bs="no"
          raw="no"
          logmode="1"
          procargs="1"
          logpath="/var/log/fr24feed"
          mlat="yes"
          mlat-without-gps="yes"
          The funny thing now is that planes have started showing up on the dump1090 map, while fr24feed-status now reports:
          Code:
          [ ok ] FR24 Feeder/Decoder Process: running.
          [ ok ] FR24 Stats Timestamp: 2021-02-23 07:39:16.
          [ ok ] FR24 Link: connected [UDP].
          [ ok ] FR24 Radar: T-ENSK2.
          [ ok ] FR24 Tracked AC: 0.
          [FAIL] Receiver: down ... failed!
          [FAIL] FR24 MLAT: not running ... failed!

          Comment


          • #6
            Then you have likely installed a script/separate change to make Dump1090 run full time outside of fr24 starting/stopping it.


            usb_claim_interface error -6 = "I'm un use by something else"

            So if you did infact stop the FR24 service. Then the one that locked it has been able to take over fully.

            MLAT won't go until it receives 3+ aircraft.

            Modify the config to beast-tcp:30005 and see if it gets data. If so, work out what you installed that has taken it over.
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Aha, I now remember that I set things up with the beast-tcp method described at https://forum.flightradar24.com/foru...6128#post96128.

              I assume something has been messed up somewhere. I reconfigured fr24feed now, choosing the 4 - ModeS Beast (USB/Network) receiver option (with options 1, hostname 127.0.0.1 and port 30005 further down.

              fr24feed-status now reports
              Code:
              [ ok ] FR24 Feeder/Decoder Process: running.
              [ ok ] FR24 Stats Timestamp: 2021-02-23 07:55:32.
              [ ok ] FR24 Link: connected [UDP].
              [ ok ] FR24 Radar: T-ENSK2.
              [ ok ] FR24 Tracked AC: 1.
              [ ok ] Receiver: connected (971 MSGS/0 SYNC).
              [ ok ] FR24 MLAT: ok [UDP].
              [ ok ] FR24 MLAT AC seen: 0.
              so I assume things are running normally again. My fr24feed.ini is now
              Code:
              receiver="beast-tcp"
              fr24key=[redacted]
              host="127.0.0.1:30005"
              bs="no"
              raw="no"
              logmode="1"
              logpath="/var/log/fr24feed"
              mlat="yes"
              mlat-without-gps="yes"
              I'm not really sure how my setup was messed up. I'm blaming the house elves.

              Thanks for helping me out!
              Last edited by T-ENSK1; 2021-02-23, 08:10.

              Comment


              • #8
                If you like your local map, consider going to tar1090/readsb as described here: https://github.com/wiedehopf/adsb-wi...ADS-B-receiver
                The graphs are also pretty neat if you like such stuff.
                If you change the fr24feed setup to the one described on that page it won't run auto-updates and have proper system logs integrated with journalctl.

                Comment


                • #9
                  Originally posted by T-ENSK1 View Post
                  Aha, I now remember that I set things up with the beast-tcp method....

                  .....I'm not really sure how my setup was messed up. I'm blaming the house elves.
                  Send an email to Prof. Dumbledore of Hogwarts, complining that he has sent you very naughty elves.

                  Comment

                  Working...
                  X