Announcement

Collapse
No announcement yet.

Using rbfeeder but want to also feed data to FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GlynH
    replied
    Yeah I’ve done just that and call me cynical but for some reason I’m not expecting a happy ending!

    Thanks & kind regards,
    -=Glyn=-
    Last edited by GlynH; 2020-11-10, 02:02.

    Leave a comment:


  • abcd567
    replied
    I am not aware of any web interface for RadarBox24's RPi feeder Settings/Status. However if it exists, it is undocumented. Please send an email to AirNav Support and ask them.

    Leave a comment:


  • GlynH
    replied
    Just so you guys know (and anybody who might follow the same path at a later date) earlier today I plucked up the courage and installed the FR24 feeder on top of my existing RB24 feeder using the info here and they co-exist perfectly!

    I'm now feeding both sites and can also access the data across my network using the original RadarBox 6.02.003 legacy software and see the interface that I used all those years ago and when used this way its Multi-Client as well so a happy camper.

    I have one last question though if I may please; I can access the FR24 web interface status page across the LAN by going to RaspberryPi_IP_Address:8754 to see a summary page of settings etc. but is a similar thing possible with RBFeeder?

    I believe with the XRange devices that there is a status page that can be reached locally by typing http://anrbXXXXXX where XXXXXX is the serial number of the XRange and I'm guessing that they can't be too far apart in how they work but I don't know what the port number might be to access the web interface if indeed there is one?

    Thanks & kind regards,
    -=Glyn=-

    Leave a comment:


  • GlynH
    replied
    Yup. Got it. I hope...

    Thanks again Ingo...much appreciated.

    Thanks & kind regards,
    -=Glyn=-

    Leave a comment:


  • abcd567
    replied
    Originally posted by GlynH View Post
    Just a question about the Beast port - in rbfeeder.ini it shows the following lines;

    [network]
    mode=beast
    external_port=30005
    external_host=127.0.0.1

    The full content of file /etc/rbfeeder.ini are given below.

    Under [client] the very first line is:

    network_mode=true

    With this setting, rbfeeder reads the content under [network].

    However when setting is changed to:

    network_mode=false

    Then the rbfeeder ignores the details under [network] and gets data from integral dump1090 at port 32457

    Code:
    [client]
    network_mode=true
    log_file=/var/log/rbfeeder.log
    key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    sn=EXTRPIxxxxxx
    
    [network]
    mode=beast
    external_port=30005
    external_host=127.0.0.1
    
    [mlat]
    autostart_mlat=true
    #mlat_cmd=/usr/bin/python3.5 /usr/bin/mlat-client
    
    [dump978]
    #dump978_enabled=true


    Originally posted by GlynH View Post
    And in the RadarBox software that I use to view locally it gives port 32088 after the IP Address of the Pi but of course doesn't say if this is Beast or not.
    The rbfeeder outputs data on many ports, each one a different format. In my last post I have posted the output of netstat command which lists all ports on which apps are outputing (LISTEN) their data.

    The output shows that port number 32088 is ssigned to rbfeeder.


    ​​​​​​The data firmat at 30288 is NOT beast
    (Cannot copy-paste output. This stupid forum is blocking me, so I have taken a screenshot)


    Screenshot_20201105-171443_Samsung Internet.jpg





    Leave a comment:


  • GlynH
    replied
    Originally posted by Oblivian View Post
    Guess after the wars with their first products should have known they wont follow everyone else..
    Yeah that sounds about right...I bought into the system in 2008 so have a long & chequered history!

    -=Glyn=-

    Leave a comment:


  • GlynH
    replied
    Many thanks for the full & detailed explanation as always Ingo. Much appreciated.

    I feel more confident about tackling this now.

    Just a question about the Beast port - in rbfeeder.ini it shows the following lines;

    [network]
    mode=beast
    external_port=30005
    external_host=127.0.0.1

    And in the RadarBox software that I use to view locally it gives port 32088 after the IP Address of the Pi but of course doesn't say if this is Beast or not.

    Just wanted to be clear on port numbers...

    Thanks & kind regards,
    -=Glyn=-

    Leave a comment:


  • Oblivian
    replied
    Guess after the wars with their first products should have known they wont follow everyone else..

    Leave a comment:


  • abcd567
    replied
    Originally posted by Oblivian View Post
    You still need to install it. But when it comes to asking for a configuration your data source is NOT DVBT. But beast-tcp from source 127.0.0.1 on port 30005
    Radarbox24's integral dump1090 does NOT output beast format data at port 30005. It outputs data as follows:

    Beast format at port 32457
    AVR format at port 32459



    Following commands were issued under these conditions:

    1. No dump1090 (fa or mutab) was installed.

    2. Thefr24feed and rb24feeder were installed.

    3. The fr24feed setting were "receiver=beast-tcp", host="127.0.0.1:32457"

    4. The rbfeeder's default setting "network_mode= true" was changed to "network_mode=false" in file /etc/rb24feeder.ini. This triggered the start of integral dump1090, which was there as part of RB24 feeder, but was inactive.

    Code:
    pi@raspberrypi:~ $ sudo netstat -anp | grep -w LISTEN
    tcp    0    0    0.0.0.0:22        0.0.0.0:*    LISTEN    554/sshd
    tcp    0    0    0.0.0.0:32088   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp    0    0    0.0.0.0:32004   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp    0    0    0.0.0.0:32008   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp    0    0    0.0.0.0:32457   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp    0    0    0.0.0.0:32458   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp    0    0    0.0.0.0:32459   0.0.0.0:*    LISTEN    2786/rbfeeder
    tcp6  0    0    :::8754             :::*            LISTEN    1825/fr24feed
    tcp6  0    0    :::22                 :::*            LISTEN    554/sshd
    tcp6  0    0    :::32004            :::*           LISTEN     2786/rbfeeder
    tcp6  0    0    :::32008            :::*           LISTEN     2786/rbfeeder
    tcp6  0    0    :::32457            :::*           LISTEN     2786/rbfeeder
    tcp6  0    0    :::32458            :::*           LISTEN     2786/rbfeeder
    tcp6  0    0    :::32459            :::*           LISTEN     2786/rbfeeder

    Code:
    pi@raspberrypi:~ $ nc localhost 32457
    
    2▒▒a<]L▒▒▒▒3▒▒
    ]B▒▒FT▒▒D,▒3▒▒▒▒ ▒▒gX
    ▒'▒
    ]▒ ▒7▒m2▒ؼ@▒▒E▒▒2▒▒*▒
    ▒▒
    ▒2▒▒*▒; ▒▒ٱ3▒▒+▒L▒▒▒▒▒▒▒▒!▒]▒FT_#3▒▒J▒▒▒▒▒@▒XP%3▒▒t,7▒▒▒▒▒#I▒▒▒]2▒▒S=▒ ▒▒3▒▒▒=▒▒=▒X▒щ▒?
    0D?▒2▒▒jL▒0▒▒▒3Ul/▒▒~Q▒Fhg/]0▒3▒▒▒▒▒HXeE@▒_PuTTY2▒m3▒▒-▒/▒▒~QX▒▒A▒▒-2▒▒s▒8▒▒pPuTTY3▒▒▒=▒▒=▒▒▒
    _]▒E▒3▒
    ▒▒-▒▒tfY▒▒▒3▒
    ▒*,▒▒tf▒ ▒H
    ▒▒▒▒▒Tљ: L▒P3▒ ▒+%3▒
    ~X e▒PuTTY3▒▒ǟ▒▒Kܙ ▒▒▒▒3▒k▒▒▒|e▒▒ +3▒▒F▒▒▒▒X▒A]▒▒S▒▒3▒b!▒▒Y%4J▒x@&з3▒!▒▒▒YʿD2▒$BF▒0▒▒I2▒5▒G▒0▒▒I2 ▒▒M▒0▒▒▒2▒J;Q]▒Tm]▒|2▒W▒Ra▒▒▒X▒2▒l▒Pa▒▒▒X▒3▒!7yL▒▒▒▒X▒%▒L▒^Z▒2▒ $4▒▒ 0▒▒k2▒)▒▒D▒▒▒mC?2▒,3▒K▒0▒▒▒2▒.▒4]▒~Q▒W▒2▒0zJ▒0▒▒▒3▒0▒&-▒▒tf▒ Z▒2▒2^▒Aᐱ_▒3▒3▒▒J▒▒▒▒▒ ُ▒▒m3▒5$▒▒L▒▒N8X▒F3▒5▒▒B▒▒=▒▒Hh`_▒1▒2▒7▒t:▒▒▒mC?2▒ 7▒E&▒>▒3▒:Ȥ%▒▒g▒K▒▒$▒:▒3▒<4▒ ▒▒▒ ▒8 +▒Z3▒@Q9▒▒▒▒▒ ▒!▒ #2▒B-87]▒▒▒▒"▒3▒G▒SB▒▒TmXqʸV#3▒G▒A▒▒Tm▒
    c▒P:▒2▒M▒]@oy3▒K▒▒:▒▒=▒X▒N▒S+.i▒3▒L▒▒L▒▒

    Code:
    pi@raspberrypi:~ $ nc localhost 32459
    
    MSG,4,1,1,C04FE4,1,2020/11/05,19:47:55.428,2020/11/05,19:47:55.507,,,513,65,,,1472,,,,,0
    MSG,8,1,1,A560FC,1,2020/11/05,19:47:55.439,2020/11/05,19:47:55.508,,,,,,,,,,,,0
    MSG,8,1,1,A560FC,1,2020/11/05,19:47:55.472,2020/11/05,19:47:55.511,,,,,,,,,,,,0
    MSG,3,1,1,AAFC2C,1,2020/11/05,19:47:55.482,2020/11/05,19:47:55.562,,43000,,,42.77764,-77.35601,,,0,,0,0
    MSG,3,1,1,A81000,1,2020/11/05,19:47:55.516,2020/11/05,19:47:55.565,,37000,,,42.59115,-76.02941,,,0,,0,0
    MSG,5,1,1,A2FA4E,1,2020/11/05,19:47:55.527,2020/11/05,19:47:55.565,,4850,,,,,,,0,,0,
    MSG,7,1,1,06A1EB,1,2020/11/05,19:47:55.536,2020/11/05,19:47:55.627,,36000,,,,,,,,,,
    MSG,5,1,1,A560FC,1,2020/11/05,19:47:55.540,2020/11/05,19:47:55.628,,3025,,,,,,,0,,0,
    MSG,8,1,1,C01AB4,1,2020/11/05,19:47:55.541,2020/11/05,19:47:55.628,,,,,,,,,,,,0
    MSG,8,1,1,C05D3C,1,2020/11/05,19:47:55.544,2020/11/05,19:47:55.628,,,,,,,,,,,,0
    MSG,3,1,1,A495B4,1,2020/11/05,19:47:55.567,2020/11/05,19:47:55.631,,41000,,,43.15448,-75.56795,,,0,,0,0
    MSG,4,1,1,A560FC,1,2020/11/05,19:47:55.599,2020/11/05,19:47:55.682,,,184,224,,,3136,,,,,0
    MSG,3,1,1,06A1EB,1,2020/11/05,19:47:55.620,2020/11/05,19:47:55.684,,36000,,,43.11378,-77.81450,,,0,,0,0
    MSG,7,1,1,06A1EB,1,2020/11/05,19:47:55.627,2020/11/05,19:47:55.684,,36000,,,,,,,,,,
    MSG,7,1,1,A560FC,1,2020/11/05,19:47:55.633,2020/11/05,19:47:55.685,,3025,,,,,,,,,,
    MSG,7,1,1,A2FA4E,1,2020/11/05,19:47:55.638,2020/11/05,19:47:55.685,,4850,,,,,,,,,,
    MSG,3,1,1,A560FC,1,2020/11/05,19:47:55.639,2020/11/05,19:47:55.685,,3025,,,43.64731,-79.70274,,,0,,0,0
    MSG,3,1,1,C01AB4,1,2020/11/05,19:47:55.654,2020/11/05,19:47:55.726,,3000,,,43.86268,-78.64681,,,0,,0,0
    MSG,4,1,1,C01AB4,1,2020/11/05,19:47:55.654,2020/11/05,19:47:55.726,,,92,200,,,-64,,,,,0
    MSG,3,1,1,A2FA4E,1,2020/11/05,19:47:55.656,2020/11/05,19:47:55.727,,4850,,,43.22832,-80.03706,,,0,,0,0
    MSG,4,1,1,A2FA4E,1,2020/11/05,19:47:55.656,2020/11/05,19:47:55.727,,,143,100,,,64,,,,,0
    MSG,3,1,1,A3534A,1,2020/11/05,19:47:55.673,2020/11/05,19:47:55.728,,37000,,,42.71297,-76.48326,,,0,,0,0
    MSG,8,1,1,A2FA4E,1,2020/11/05,19:47:55.679,2020/11/05,19:47:55.729,,,,,,,,,,,,0

    Last edited by abcd567; 2020-11-05, 20:31.

    Leave a comment:


  • abcd567
    replied
    If you install FR24 Feeder this way, it will NOT install dump1090-mutability. It will grab data from the Radarbox24 feeder
    Code:
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    After running for a while, the script will automatically start SIGNUP process.
    The signup process will ask you to enter email address, sharing key (leave it blank, you will get it by email), latitude, longitude, height etc etc.
    Enter all these details.

    After signup is complete, CONFIGURATION will start as follows:
    Make sure you enter values shown in RED

    SCROLL DOWN TO SEE IN FULL
    Code:
    Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):
    [html]
    Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):
    
    1 - DVBT Stick (USB)
    -----------------------------------------------------
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)
    4 - ModeS Beast (USB/Network)
    5 - AVR Compatible (DVBT over network, etc)
    6 - microADSB (USB/Network)
    7 - SBSx via Basestation (localhost:30006)
    
    Enter your receiver type (1-7)$: [SIZE=18px][COLOR=#ff0000][B]4[/B][/COLOR][/SIZE]
    
    Step 4.2 - Please select connection type:
    
    1 - Network connection
    2 - USB directly to this computer
    
    Enter your connection type (1-2)$: [SIZE=18px][COLOR=#ff0000][B]1[/B][/COLOR][/SIZE]
    
    Step 4.3A - Please enter your receiver's IP address/hostname
    $:[SIZE=18px][COLOR=#ff0000][B]127.0.0.1[/B][/COLOR][/SIZE]
    
    Step 4.3B - Please enter your receiver's data port number
    $:[SIZE=18px][COLOR=#ff0000][B]32457[/B][/COLOR][/SIZE]
    
    Step 5.1 - Would you like to enable RAW data feed on port 30334 (yes/no)$:[SIZE=18px][COLOR=#ff0000][B]no[/B][/COLOR][/SIZE]
    
    Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$:[SIZE=18px][COLOR=#ff0000][B]no[/B][/COLOR][/SIZE]
    
    Step 6 - Please select desired logfile mode:
    0 - Disabled
    1 - 48 hour, 24h rotation
    2 - 72 hour, 24h rotation
    Select logfile mode (0-2)$:[SIZE=18px][COLOR=#ff0000][B]1[/B][/COLOR][/SIZE]
    
    Saving settings to /etc/fr24feed.ini...OK
    Settings saved, please run "sudo systemctl restart fr24feed" to use new configuration.
    Installation and configuration completed!
    Now restart fr24feed, wait few minutes, then check status

    Code:
    sudo systemctl restart fr24feed
    
    fr24feed-status
    Last edited by abcd567; 2020-11-05, 19:35.

    Leave a comment:


  • GlynH
    replied
    Well my holding fire didn't seem to last long and I'm probably going to regret this but I want to be clear about the steps required to install the FR24 feeder on a Pi4 running Buster that already has the the RBFeeder working correctly with MLAT.

    I don't want any fancy graphs etc. just a base install of the FR24 feeder to send data to them in addition to my existing RBFeeder.

    I get the part where I make sure it is NOT DVBT but instead is set to beast-tcp from source 127.0.0.1 on port 30005 during the configuration but what is the installation command to run please?

    And apart from the configuration settings already mentioned is there anything else I might have to do when installing such as edit any config files to get it to auto-run at startup for example?

    Incidentally what is the name & configuration of the file that auto-starts rbfeeder on boot up and is there a correct order to run these apps?

    Thanks & kind regards,
    -=Glyn=-

    Leave a comment:


  • GlynH
    replied
    I did find it useful...thanks for the link but as is usual with me the more I read about RPi related stuff the more confused I get and the more I back off!

    Also it was late the other night so I didn't jump straight in and to be honest as everything is running really nicely at the moment I'm going to hold fire on adding anything else to it for the short term.

    No doubt I'll be back for moral support sometime in the future!

    Thanks both for your time, trouble & advice.

    Kind regards,
    -=Glyn=-

    Leave a comment:


  • wiedehopf
    replied
    You might find this helpful:
    https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

    I believe if you run the readsb install it will automatically reconfigure rbfeeder to work with the new decoder.

    Leave a comment:


  • GlynH
    replied
    Fantastic! Thanks Oblivian.

    Wish me luck...I'm going in...

    Thanks & kind regards,
    -=Glyn=-

    Leave a comment:


  • Oblivian
    replied
    It only blind installs dump1090-mutability, straight over top of anything else you have - IF you chose your feeder as 'dvbt'.
    Cause it's dumb and thinks you need it. Rather than look for it.

    So if you don't at any time in the settings/setup go 'DVBT' and only stick to beast-tcp. It will be fine.

    Fine with buster.

    Leave a comment:

Working...
X