Announcement

Collapse
No announcement yet.

MLAT enabled but not running on restart of Pi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MLAT enabled but not running on restart of Pi

    Hi guys,

    I've got MLAT enabled but when I restart my RPi 3+B it doesn't turn on properly. If I restart the fr24feed service manually after a restart, it starts working without any issues. The log is showing MLAT failing to start because of "Receiver not compatible with MLAT, timestamps in wrong format"

    Any ideas?

    Here's a log of the startup error:

    Code:
    2020-10-21 14:11:18 | [main][i]FR24 Feeder/Decoder
    2020-10-21 14:11:18 | [main][i]Version: 1.0.26-9/generic
    2020-10-21 14:11:18 | [main][i]Built on Oct 14 2020 07:35:30 (HEAD-de0814c.git/Linux/static_armel)
    2020-10-21 14:11:18 | [main][i]Running on: raspbian10
    2020-10-21 14:11:18 | [main][i]Local IP(s): 10.11.12.81,fe80::bdc6:4bfe:9f33:db76
    2020-10-21 14:11:18 | [main][i]Copyright 2012-2020 Flightradar24 AB
    2020-10-21 14:11:18 | [main][i]https://www.flightradar24.com
    2020-10-21 14:11:18 | [main][i]DNS mode: PING
    2020-10-21 14:11:18 | [main][i]Automatic updates are ENABLED
    2020-10-21 14:11:18 | info | [httpd]Server started, listening on :::8754
    2020-10-21 14:11:20 | [i]PacketSenderConfiguration::fetch_config(): Yoda configuration for this receiver is disabled
    2020-10-21 14:11:20 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
    2020-10-21 14:11:20 | [main][i]Reader thread started
    2020-10-21 14:11:20 | [master][i]Starting processing thread
    2020-10-21 14:11:20 | [reader][i]Initializing reader
    2020-10-21 14:11:20 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://127.0.0.1:30002)
    2020-10-21 14:11:20 | [main][i]MLAT data feed started
    2020-10-21 14:11:20 | [mlat][i]Waiting for MLAT configuration
    2020-10-21 14:11:20 | [reader][i]Connected to the receiver, configuring
    2020-10-21 14:11:20 | [reader][i]Configured, processing messages
    2020-10-21 14:11:20 | [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
    2020-10-21 14:11:21 | [mlat][e]Receiver not compatible with MLAT, timestamps in wrong format![time][i]Synchronizing time via NTP
    2020-10-21 14:11:22 | [time][i]Time synchronized correctly, offset +0.003 seconds
    2020-10-21 14:11:22 | [feed][i]Downloading configuration
    2020-10-21 14:11:22 | [main][i]Feed Network client started
    2020-10-21 14:11:22 | [feed][d]fetching configuration
    2020-10-21 14:11:22 | [reader][i]Timestamp source changed from SYSTEM-UNCERTAIN to SYSTEM-VALIDATED
    2020-10-21 14:11:24 | [feed][i]configuring decoder
    2020-10-21 14:11:24 | [feed][c]Max range AIR: 350.0nm
    2020-10-21 14:11:24 | [feed][c]Max range GND: 100.0nm
    2020-10-21 14:11:24 | [feed][i]configuration changed

  • #2

    avr-tcp://127.0.0.1:30002

    Is why

    Beast format has the timestamps required.

    Beast-tcp
    127.0.0.1:30005

    Assuming you have a DVBT/Dump1090.

    Other receivers may need different config.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Originally posted by Oblivian View Post
      avr-tcp://127.0.0.1:30002

      Is why

      Beast format has the timestamps required.

      Beast-tcp
      127.0.0.1:30005

      Assuming you have a DVBT/Dump1090.

      Other receivers may need different config.
      Thanks mate. Swapped over to Beast-tcp on port 30005 and it's working perfectly now!

      Comment

      Working...
      X