Announcement

Collapse
No announcement yet.

FR24+Piaware feeding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24+Piaware feeding

    hi,

    first post here newly feeding to FR24.

    I have a raspberry3+ with Piaware installed and feeding for months, I wanted to add FR24 following the instructions found here in the forum: https://forum.flightradar24.com/foru...ware-pro-stick

    The install was fine, the services are up and running and connected BUT no feed.
    When I try
    "fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2020-10-15 12:35:12.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-VTBS87.
    [ ok ] FR24 Tracked AC: 0.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!"

    I use a rtl-sdr RTL2832u.

    Why the web preference page shows:
    Receiver: beast, Connected
    and in SSH:
    [FAIL] Receiver: down ... failed!


    What would be the choice in the preference for RTL2832u?

    Any help would be appreciated.

    UPDATE: Fixed thanks to wiedehopf see details bellow.
    Last edited by netwalker; 2020-10-15, 16:22.

  • #2
    beast, network needs to be selected, not beast, USB.
    127.0.0.1:30005

    Or follow these instructions (for installing FR24): https://github.com/wiedehopf/adsb-wi...ADS-B-receiver
    If you're running piaware already, you have a decoder and that is thus not needed.

    Comment


    • #3
      I switched to
      beast-tcp
      and now it works fine!

      THANK YOU, made my day!

      Originally posted by wiedehopf View Post
      beast, network needs to be selected, not beast, USB.
      127.0.0.1:30005

      Or follow these instructions (for installing FR24): https://github.com/wiedehopf/adsb-wi...ADS-B-receiver
      If you're running piaware already, you have a decoder and that is thus not needed.

      Comment


      • #4
        I have no idea if it's related but now new PiAware issue: cannot connect to Web Interface: PiAware SkyAware htttp://localipaddress:8080
        running piaware-status:PiAware master process (piaware) is running with pid 1436.
        PiAware ADS-B client (faup1090) is running with pid 1469.
        PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
        PiAware mlat client (fa-mlat-client) is running with pid 1479.
        Local ADS-B receiver (dump1090-fa) is running with pid 1435.

        dump1090-fa (pid 1435) is listening for ES connections on port 30005.
        faup1090 is connected to the ADS-B receiver.
        piaware is connected to FlightAware.

        dump1090 is NOT producing data on localhost:30005.

        Your feeder ID is 7e49b5f8-9b56-4852-838e-7bebad97924e (from /var/cache/piaware/feeder_id)

        PiAware master process (piaware) is running with pid 1436.
        PiAware ADS-B client (faup1090) is running with pid 1469.
        PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
        PiAware mlat client (fa-mlat-client) is running with pid 1479.
        Local ADS-B receiver (dump1090-fa) is running with pid 1435.

        dump1090-fa (pid 1435) is listening for ES connections on port 30005.
        faup1090 is connected to the ADS-B receiver.
        piaware is connected to FlightAware.

        dump1090 is NOT producing data on localhost:30005.

        Your feeder ID is xxxxxxxxxxxxxxxxxxxxxxxxxxxxx (from /var/cache/piaware/feeder_id)



        seeing listening on port 30005, so I tried http://mylanaddress:30005 or 8080nothing either: connection denied.
        Last edited by netwalker; 2020-10-15, 15:36. Reason: add details

        Comment


        • #5
          You installed dump1090 in addition to dump1090-fa, sure looks like it.


          sudo apt remove -y dump1090-mutability
          sudo apt remove -y dump1090
          sudo rm /etc/lighttpd/conf-enabled/89-dump1090.conf
          sudo reboot

          That will likely fix it.

          Comment


          • #6
            You rock! Both feed working now, and I can connect again.

            HUGE thank you for your time, much appreciated!

            Originally posted by wiedehopf View Post
            You installed dump1090 in addition to dump1090-fa, sure looks like it.


            sudo apt remove -y dump1090-mutability
            sudo apt remove -y dump1090
            sudo rm /etc/lighttpd/conf-enabled/89-dump1090.conf
            sudo reboot

            That will likely fix it.

            Comment

            Working...
            X