Announcement

Collapse
No announcement yet.

dump1090-mutability process arguements not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dump1090-mutability process arguements not working

    I can't seem to convince the /etc/fr24feed.ini file to pass additional process arguments to dump1090-mutability. In FlightAware, all I needed to do is add a "procargs" record. Something like this.
    # /etc/fr24feed.ini
    Code:
    receiver="beast-tcp"
    fr24key="xxxxxxxxxxxxx"
    host="127.0.0.1:30005"
    path="/usr/lib/fr24/dump1090"
    bs="no"
    raw="no"
    logmode="1"
    procargs="--gain 40"
    windowmode="0"
    logpath="/var/log/fr24feed"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"
    This should have added "--gain 40" to the dump1090-mutability command line. After restarting, when I run:
    $ ps -ef | grep "/usr/bin/dump1090-mutability"
    Code:
    dump1090 516 1 28 Oct11 ? 01:37:10 /usr/bin/dump1090-mutability --net --ppm 0 --fix --lat 37.08097 --lon -122.09467 --max-range 300 --net-ri-port 30001 --net-ro-port 30002 --net-bi-port 30004,30104 --net-bo-port 30005 --net-sbs-port 30003 --net-heartbeat 60 --net-ro-size 500 --net-ro-interval 1 --net-buffer 2 --stats-every 3600 --write-json /run/dump1090-mutability --write-json-every 1 --json-location-accuracy 2 --quiet
    the "--gain 40" that I added does not appear at the end of the line as I would expect. I tried entering the procargs line both by editing /etc/fr24feed.ini directly and by using the menu at
    http://192.168.11.60:8754 (192.168.11.60 is the IP address of my RPi3+).
    The results were the same with the R820T gain remaining unchanged.

    I can verify that the gain hasn't changed with:
    $ cat /var/log/dump1090-mutability.log | head -10
    Code:
    Sun Oct 11 23:20:40 2020 BST EB_SOURCE EB_VERSION starting up.
    Using sample converter: UC8, integer/table path
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000 (currently selected)
    Found Rafael Micro R820T tuner
    Max available gain is: 49.60 dB
    Setting gain to: 49.60 dB
    Gain reported by device: 49.60 dB
    Allocating 15 zero-copy buffers
    $ fr24feed --version
    1.0.26-5

    $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2020-10-12 04:27:11.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-KWVI31.
    [ ok ] FR24 Tracked AC: 6.
    [ ok ] Receiver: connected (15821 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 3.

    I am currently testing with a FlightAware Pro Stick Plus (blue). I'm not sure whether to blame fr24feed or dump1090-mutability. Whichever is at fault, there appears to be something wrong with the way these are passing parameter values, as well the previously discovered signal level data to each other.
    Last edited by Jeff Liebermann; 2020-10-12, 04:41.

  • #2
    You won't change anything with beast-tcp. There's nothing to pass to dump1090

    FR24feed arguments only work when you are in 'DVBT' (and some other non standard decoders chosen) and it launches it with a new command each time it runs.

    If you install it outside, which feeding 2 sites and configuring to tcp suggests. You treat it like everything else and configure the individual apps.

    sudo dpkg-reconfigure dump1090-mutability
    aka

    sudo nano /etc/default/dump1090-mutability

    per https://forum.flightradar24.com/foru...-15~dev-on-rpi

    That's how it got your initial long/lat - you would followed a guide and entered it to the dump1090 configuration separately
    Last edited by Oblivian; 2020-10-12, 05:03.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      CONFIGUTATION -1:
      dump1090-mutability is fully controlled by fr24feed, and does NOT behave as stand-alone app


      FR24-DVBT.png



      .


      CONFIGUTATION -2:
      dump1090-mutability is stand-alone app


      FR24-BEAST-TCP.png

      .
      .
      Last edited by abcd567; 2020-10-12, 06:48.

      Comment


      • #4
        If setting is receiver=dvbt
        Unlike other apps, the dump1090-mutability does NOT automatically start at boot. Instead fr24feed starts/stops dump1090-mutability.
        The dump1090-mutability does NOT use settings in its config file. It uses settings passed to it by fr24feed. These are the settings in file /etc/fr24feed in line procargs="--lat xxx --lon yyy --gain nn". or in process arguments field in IP-of-Pi:8754/settings.html.

        Setting gain, lat, lon is done by following two methods
        (a) sudo nano /etc/fr24feed.ini
        add required prameters in line starting with procargs=
        (b) In browser go to IP-of-Pi:8754/settings.html
        add settings in field Process arguments


        If setting is receiver=beast-tcp or avr-tcp
        The dump1090-mutability is NOT controlled by fr24feed.
        The dump1090-mutability automatically starts at boot, and the fr24feed does NOT start/stop/restart it.
        The dump1090-mutability reads its configuration from its own configuration file. The fr24feed does NOT pass any parameters in its file /etc/fr24feed.ini or IP-of-Pi:8754/settings.html. Hence the line procargs="--gain nn --lat xx --lon yy" does NOT do anything.

        Setting gain, lat, lon is done by following two methods
        (a) sudo nano /etc/default/dump1090-mutability
        add required parameters in line starting with RECEIVER_OPTIONS=
        (b) sudo dpkg-reconfigure dump1090-mutability
        enter settings when asked for.

        Comment

        Working...
        X