Announcement

Collapse
No announcement yet.

pi24 image – not sending data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pi24 image – not sending data

    Hi chaps

    For about a year now I've been using a Pi with a RTL-SDR USB stick and a filtered pre-amp. It hasn't got the best range due to being indoors; nevertheless, it has been 100% reliable.

    I replaced the memory card in the Pi for a newer, faster one, and re-imaged with pi24 and had everything set up exactly how it was before. Now, my feeder shows as online but is not sending data, nor are any aircraft shown on dump1090.

    Looking for any possible tips for things to look at.

    Many thanks

    Colin

  • #2
    Did I need a new sharing key?

    Comment


    • #3
      No, you dont need a new sharing key. Use old one.

      What is output of following command?

      fr24feed-status

      Comment


      • #4
        Code:
        [ ok ] FR24 Feeder/Decoder Process: running.
        [ ok ] FR24 Stats Timestamp: 2020-10-07 16:00:21.
        [ ok ] FR24 Link: connected [UDP].
        [ ok ] FR24 Radar: T-EGGP193.
        [ ok ] FR24 Tracked AC: 0.
        [FAIL] Receiver: down ... failed!
        [FAIL] FR24 MLAT: not running ... failed!

        Comment


        • #5

          Give both commands below, and post output of the last command.

          sudo apt install rtl-sdr

          sudo systemctl stop fr24feed dump1090-mutability

          rtl_test -t

          Last edited by abcd567; 2020-10-07, 20:16.

          Comment


          • #6
            Code:
            pi@raspberrypi:~ $ rtl_test -t
            Found 1 device(s):
            0: Realtek, RTL2838UHIDIR, SN: 00000001
            
            Using device 0: Generic RTL2832U OEM
            usb_claim_interface error -6
            Failed to open rtlsdr device #0.

            Comment


            • #7
              Keep in mind that is the same outcome being seeing if started too fast. And knowing the image it auto updates to the 'broken' one as soon as it can.

              In Which case a service restart manually seems to fix

              It could of course be a false error and have deeper issues
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • #8
                I've restarted it multiple times and everything seems to look OK, except it sends no data nor does it see any planes. I can't understand it...

                Comment


                • #9
                  Sorry, was more a headsup for where ABCD was going.

                  I don't mean restarting the device. That is the apparent issue.

                  But rather a restart of the feeder to see if it is actually be OK with the order of running

                  sudo systemctl restart fr24feed

                  When you have a 'DVBT' stick. 2 things (appear to) happen on reboot of PI and FR24feed start (still not admitting anything since last 'update' and noones been able to narrow down what is in common)

                  FR24feed starts.
                  Calls for Dump1090 to start on demand

                  (possibly only 'DVBT' set feeder type users - can't tell yet, UNLESS you have installed a separate Dump1090 instance and configured it for beast-tcp )

                  One of these things seems to be stuffing the other. And FR24feed ends up not finding dump1090, so gives up.
                  = No data, so no receiver activation or MLAT capabilities + message 'online - no data' often

                  I can see from your error above running test_rtl
                  usb_claim_interface error -6

                  The stop command that he gave didn't execute, or wasn't run. That means, the stick is in-use. It's entirely possible the issue is DUmp1090 hanging, so it thinks all is good when it is not.

                  Need to do them one by one, and if it's anything other than a blank new line. Advise us of the output

                  sudo systemctl stop fr24feed
                  sudo systemctl stop dump1090-mutability

                  If no errors, you can run rtl_test again.

                  Or

                  sudo fr24feed

                  And that will show full output of the feeder starting up to see what is going on
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    Okay, I did those commands and they gave no errors. Then:

                    Code:
                    pi@raspberrypi:~ $ rtl_test -t
                    Found 1 device(s):
                    0: Realtek, RTL2838UHIDIR, SN: 00000001
                    And then the output of sudo fr24feed...

                    Code:
                    2020-10-08 08:15:15 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@3000000)
                    2020-10-08 08:15:15 | [reader][e]Could not connect to /dev/ttyUSB0@3000000
                    Kept on doing that over and over.

                    So looks like the issue is with pi24 not recognising the DVBT stick? Do you think a reinstall is the correct course of action?

                    Comment


                    • #11
                      You've populated the serial details. Or not chosen 'dvbt' aa feeder type but something else usb/serial...

                      ​​​​​​
                      https://forum.flightradar24.com/foru...002#post104002
                      Last edited by Oblivian; 2020-10-08, 07:30.
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • #12
                        I rebooted it and made sure DVBT was selected, ran the above commands and got this (but still no data sending to FR24)

                        Code:
                        2020-10-08 09:36:08 | [reader][i]Connecting to DVBT receiver via (exe:///usr/lib/fr24/dump1090 --raw --mlat)
                        2020-10-08 09:36:08 | [reader][i]Connected to the receiver, configuring
                        2020-10-08 09:36:08 | [reader][i]Configured, processing messages
                        bash: /usr/lib/fr24/dump1090: No such file or directory
                        2020-10-08 09:36:08 | [reader][i]Connection terminated
                        2020-10-08 09:36:08 | [main][i]Terminating child process 4119 with SIGTERM

                        Comment


                        • #13
                          So was it dvbt all along, or something else? As only when you do dvbt does it tend to install dump1090 during install. Which now appears missing according to that.

                          with any luck they stopped it force auto installing a 2nd time like it use to which may be why

                          You either need to install dump1090 via apt (abcd shows this in another thread)

                          Or swap it for dump1090-fa and some extra features, and sort out the feeder in 1

                          https://github.com/wiedehopf/adsb-sc...or-dump1090-fa
                          Last edited by Oblivian; 2020-10-08, 10:51.
                          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                          Comment

                          Working...
                          X