Announcement

Collapse
No announcement yet.

How do I install a file?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • If I recall you already were out for a fix and applied that (-7 was a fix per the changelog) manually with ABCD help

    It likely wont change a lot of your particular case. But would have eliminated any auto restart issues it initiates itself.
    To go to -9:

    sudo systemctl stop fr24feed
    sudo apt-get update
    sudo apt-get install fr24feed
    sudo systemctl restart fr24feed

    And then re-run policy above to confirm

    Will prompt to upgrade. And tell you it needs configuring (DON'T!! - it lies not expecting a config file already)

    Just make sure you have a note of ID etc as backup.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • Originally posted by verdi View Post
      When I run this.......... Sudo apt policy fr24feed
      I get..... -bash: Sudo: command not found
      Linux does not have command Sudo (starting with capital S). The command Linux understands is sudo (starting with small s)

      Comment


      • Mobile phone auto capitalisation :/

        Bring back tapatalk!
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • Good morning gents (and ladies) So I get up this morning and FR24 is offline and the FA map has stopped getting updates and has the dump 1090 Ajax error. However FA has been receiving data the whole time bcz there is no errors with the hourly report graph. I went to the pi console and I am able to log in and get this... 20201019_072002.jpg So this confirms that the pi is running, the receiver is running, WIFi is working, FA is receiving data. FR24 is bonked and so is the FA map...
          Last edited by verdi; 2020-10-19, 11:41.

          Comment


          • Alt-F2

            Will drop to console where you can run actually run things and diagnose.

            https://cplusprogrammer.wordpress.co...ning-on-linux/

            df -h

            sudo systemctl status lighttpd

            sudo systemctl status fr24feed

            sudo systemctl status dump1090-fa




            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • When I tried to do update.....

              pi@piaware:~ $ sudo apt-cache policy fr24feed
              fr24feed:
              Installed: 1.0.26-7
              Candidate: 1.0.26-7
              Version table:
              *** 1.0.26-7 100
              100 /var/lib/dpkg/status
              pi@piaware:~ $ sudo systemctl stop fr24feed
              pi@piaware:~ $ sudo apt-get update
              Hit:1 http://flightaware.com/mirror/raspbian/raspbian buster InRelease
              Hit:2 http://flightaware.com/adsb/piaware/files/packages buster InRelease
              Hit:3 http://flightaware.com/mirror/raspberrypi/debian buster InRelease
              Reading package lists... Done
              pi@piaware:~ $ sudo apt-get install fr24feed
              Reading package lists... Done
              Building dependency tree
              Reading state information... Done
              fr24feed is already the newest version (1.0.26-7).
              0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
              pi@piaware:~ $ sudo systemctl restart fr24feed
              pi@piaware:~ $ sudo apt-cache policy fr24feed
              fr24feed:
              Installed: 1.0.26-7
              Candidate: 1.0.26-7
              Version table:
              *** 1.0.26-7 100
              100 /var/lib/dpkg/status
              pi@piaware:~ $

              Comment


              • Originally posted by verdi View Post
                When I tried to do update.....

                pi@piaware:~ $ sudo apt-get update

                pi@piaware:~ $ sudo apt-get install fr24feed

                pi@piaware:~ $ sudo apt-cache policy fr24feed
                fr24feed:
                Installed: 1.0.26-7
                Candidate: 1.0.26-7

                Do this:

                Code:
                wget http://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.26-9_armhf.deb  
                
                sudo dpkg -i fr24feed_1.0.26-9_armhf.deb


                After installation is complete, check version:

                Code:
                sudo apt policy fr24feed
                Last edited by abcd567; 2020-10-19, 18:33.

                Comment


                • Still need to know why ssh unavailable remotely.

                  Why disk updates from dump1090 stop

                  And look at fr24 logs to why that stopped before it's reset and logs recycle again like reboots/restarting can do

                  Neither of which seem to be related in anyone elses installs.
                  Especially when it's an FA image with their dump1090 that is used to upload/display. and fr24 is loaded last as a capture utility only (not controlling any of it)
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • Originally posted by abcd567 View Post
                    Just noticed from above. The installer script has been missed somewhere?. Its not actually added their repo source to update by looks

                    Almost like it's always been a .deb install and possibly even no user/group changes as a result?..

                    It should have reported the REMOTE source no? (I disabled auto update to avoid issues)

                    Or like other stuff it's currently unreachable..

                    pi@raspberrypi:~ $ sudo apt-cache policy fr24feed

                    fr24feed:
                    Installed: 1.0.26-5
                    Candidate: 1.0.26-9
                    Version table:
                    1.0.26-9 500
                    500 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages
                    *** 1.0.26-5 100
                    100 /var/lib/dpkg/status
                    pi@raspberrypi:~ $
                    pi@raspberrypi:~ $
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • Originally posted by abcd567 View Post

                      Code:
                      wget http://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.26-9_armhf.deb
                      
                      sudo dpkg -i fr24feed_1.0.26-9_armhf.deb
                      Code:
                      sudo apt policy fr24feed

                      When I did that I get .......
                      pi@piaware:~ $ sudo dpkg -i fr24feed_1.0.26-9_armhf.deb
                      (Reading database ... 45176 files and directories currently installed.)
                      Preparing to unpack fr24feed_1.0.26-9_armhf.deb ...
                      Unpacking fr24feed (1.0.26-9) over (1.0.26-7) ...
                      Setting up fr24feed (1.0.26-9) ...
                      You don't seem to have any dump1090 installed. On the fr24feed start it will automatically install dump1090-mutability.
                      useradd: user 'fr24' already exists
                      pi@piaware:~ $ sudo apt policy fr24feed
                      fr24feed:
                      Installed: 1.0.26-9
                      Candidate: 1.0.26-9
                      Version table:
                      *** 1.0.26-9 100
                      100 /var/lib/dpkg/status
                      pi@piaware:~ $

                      Comment


                      • So it's done, and remember I said ignore the message about no configuration

                        but you still have to work out why the other stuff is stopping. Fr24 is not controlling dump1090 in beast TCP configuration. let alone ssh

                        I don't recall seeing a full fr24 config but . make sure raw and bs out are set as NO. Your separate dump1090-fa handles that
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • Originally posted by Oblivian View Post

                          Just noticed from above. The installer script has been missed somewhere?. Its not actually added their repo source to update by looks
                          Seems they updated mine specifically manually. Khan /support sent me 26-7 by email. After installing, I informed them my station numbers which had beta 26-7.

                          After few days I sent them my fr24 stats screenshot, and they were happy to see un broken stats on all three stations.

                          It seems when the 26-9 was ready, they remotely upgraded mine as trial before general release. (I did not upgrade it, neither was aware of 26-9. I found it accidentally when ran command apt policy fr24feed)
                          Last edited by abcd567; 2020-10-19, 21:25.

                          Comment


                          • Originally posted by abcd567 View Post

                            Seems they updated mine specifically manually. Khan /support sent me 26-7 by email. After installing, I informed them my station numbers which had beta 26-7.

                            After few days I sent them my fr24 stats screenshot, and they were happy to see un broken stats on all three stations.

                            It seems when the 26-9 was ready, they remotely upgraded mine as trial before general release. (I did not upgrade it, neither was aware of 26-9. I found it accidentally when ran command apt policy fr24feed)
                            I mean verdis...

                            It doesn't show the repo like my results so didn't know there is an upgrade available. I thought that is added as part of the .sh... So if that's missing. What else hasn't setup right.

                            .sh step
                            # Add APT repository to the config file, removing older entries if exist mv /etc/apt/sources.list /etc/apt/sources.list.bak grep -v flightradar24 /etc/apt/sources.list.bak > /etc/apt/sources.list || echo OK echo 'deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable' >> /etc/apt/sources.list

                            And resulting repo reference
                            <Contents>
                            <Key>pool/raspberrypi-stable/f/fr24feed/fr24feed_1.0.26-9_armhf.deb</Key>
                            <LastModified>2020-10-14T08:08:43.000Z</LastModified>
                            <ETag>"8e760fbea5ffdebc4446e166a2b26b92"</ETag>
                            <Size>3399346</Size>
                            <StorageClass>STANDARD</StorageClass>
                            </Contents>
                            Last edited by Oblivian; 2020-10-19, 21:35.
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • You guys have lost me. Would you translate into words that I can understand lol

                              Comment


                              • All of verdi's problem point to one common factor : problem with files/data loaded in ram. Rebooting reloads these files/data but maybe in some healthy part of ram.

                                The Pi's ram is failing !!

                                Comment

                                Working...
                                X