Announcement

Collapse
No announcement yet.

How do I install a file?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Well i linked how to do set a static IP .... and offered to help you find the correct lines.
    See the link here: https://www.raspberrypi.org/document...uration/tcpip/

    That is for a Raspbian image.
    If it's a piaware sd-card image, their configuration needs to be changed instead.

    Comment


    • #62
      Does this show that the Pi is booted with the correct info? Clipboard01.jpg
      I used the.... sudo piaware-config command
      Last edited by verdi; 2020-10-15, 20:13.

      Comment


      • #63
        That looks correct.

        But it only works if you started with the piaware sd-card image.

        Also you could try something like .222 instead of .12 to make sure there is no conflict with the DHCP range or another device.

        Comment


        • #64
          I tried editing the the dhcpcd.conf configuration file and saving it but although it seems to do that after a reboot it is still the old static IP. I am not sure what to do in the router. I tried deleting the old piaware IP entry in the router but can't seem to eliminate it. I have never worked with a router that is this difficult to modify settings and assign IP's. I am not sure what the process should be to get and new IP reassigned and everything reconnected...

          Comment


          • #65
            If you're using a piaware sd-card image .... you have to modify the piaware configuration, not dhpcd because piaware controls that dhcpcd config file.

            sudo piaware-config wireless-address 192.168.0.222
            sudo reboot

            This should change the ip address in your case (i'm assuming at this point you're using the piaware sd-card image, you haven't answered that question yet).

            Comment


            • #66
              Thank you. Yes, I am using the piaware image. Do I have to turn the pi off and then delete the piaware IP reservation/entry in the router before I can reboot pi with the new 222 IP assignment?

              Comment


              • #67
                Can I install GUI in my pi such that I can configure things in an easier format than having to know and input commands via putty?

                Comment


                • #68
                  If you configure a static IP, the RPi will ignore the router.

                  Not sure what the router does, but it would be programmed really badly if it would be an issue.

                  If you installed a gui any settings would clash with the piaware settings, so no i wouldn't recommend that.
                  If you want to start with a gui, don't start with the piaware sd-card image but rather the image that has the gui.

                  Also you configured the IP once already in the piaware-config.txt in /boot, you could have taken out the sd-card or edited the file via command line.
                  The command is just the most handy thing to do it with and it's really simple .....
                  Last edited by wiedehopf; 2020-10-16, 13:23.

                  Comment


                  • #69
                    Originally posted by wiedehopf View Post
                    If you configure a static IP, the RPi will ignore the router.

                    Not sure what the router does, but it would be programmed really badly if it would be an issue.

                    If you installed a gui any settings would clash with the piaware settings, so no i wouldn't recommend that.
                    If you want to start with a gui, don't start with the piaware sd-card image but rather the image that has the gui.

                    Also you configured the IP once already in the piaware-config.txt in /boot, you could have taken out the sd-card or edited the file via command line.
                    The command is just the most handy thing to do it with and it's really simple .....

                    Thank you for this info. It clears up a few things. I realized now that I could have removed the sd card and edited the config file.
                    Bcz of this new info and realizing that i have probably bunged up a few things I did a new reinstall with the FA 4.0 image. So I am at the point where I have FA and the config file is using the .222 IP. How do I get the web part of FA configured with the new .222 IP? Also I now need to install FR24 and get that configured and feeding with the new IP. Sorry for being so lame but things are starting to come together in my understanding.....

                    Comment


                    • #70
                      huh?
                      http://192.168.0.222/dump1090-fa

                      Are you asking for this URL??

                      Oh you mean probably this: https://discussions.flightaware.com/...install/30981/
                      Last edited by wiedehopf; 2020-10-16, 17:47.

                      Comment


                      • #71
                        You can use this advice to install FR24: https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

                        No, don't install a decoder or Raspbian, just follow the FR24 instructions ;P

                        Comment


                        • #72
                          I attempt to install FR24 feed but get error when I run the wget command. Error is...... trying to resolve.... https://repo-feed.flightradar24.com

                          Comment


                          • #73
                            Then you screwed up your network settings.

                            sudo piaware-config wireless-nameservers "8.8.8.8 4.4.4.4"
                            sudo reboot

                            This should help.

                            Comment


                            • #74
                              Yes that did it. I didn't think the second nameserver number looked correct when I copied it.
                              So now I was able to go thru the FR24 feed install but I receive the following error....
                              pi@piaware:~ $ sudo systemctl restart fr24feed
                              Job for fr24feed.service failed because the control process exited with error code.
                              See "systemctl status fr24feed.service" and "journalctl -xe" for details.

                              Comment


                              • #75
                                Well check the log as described on my howto page that has the instructions.
                                Post the log here.

                                Or better.
                                Start from the beginning and copy paste each line by itself.
                                If there are errors check that you haven't screwed up the copy paste.

                                Comment

                                Working...
                                X