Announcement

Collapse
No announcement yet.

VRS, when fed data from FR24, fails to display Signal Level data.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • VRS, when fed data from FR24, fails to display Signal Level data.

    Problem: In Virtual Radar Server (VRS), as viewed in a web browser, no numbers appear for Signal Level when VRS is fed from FR24. The Signal Level appears correctly when VRS is fed from Flightaware PiAware. In both cases, I tried Dump1090 feeding AVR on port 30002 or Beast on 30005. Neither works with FR24. Both work just fine with PiAware. See example output screen grabs below.

    Setup: Two identical Raspberry Pi 3 (not +) boards. One with FlightAware PiAware and the other with Flightradar24 FR24. To view the map and flight data, I'm using mostly Firefox on Windoze 10. I'm currently using NooElec Nano SDR receivers. I've tried other SDR receivers with identical results.

    Speculation: It's not the SDR receivers or Raspberry Pi 3 boards. It might be the VRS software, if it fails to properly decode the AVR or Beast data. I rather doubt this because VRS has successfully decoded Signal Level (RSSI) data from several other dump1090 forks. FR24 uses dump1090-mutability, which seems to the most reliable. I'm sure it's not the browser, but I tested several others (Firefox, Chrome, and Edge) on Windoze. It might be a setting somewhere, but after 4 hrs of tweak and test, I'm not seeing any changes. So, by process of elimination, methinks there might be a bug in FR24 or dump1090-mutability that is either failing to send the Signal Level data, or is mangling it to where VRS can't decode it.
    Last edited by Jeff Liebermann; 2020-10-05, 23:06.

  • #2
    Issues using the outputs of FR24feed myself. From ports closing to missing data types. Or miss-matched decoded 30003 formats

    Easier recommendation for your scenario is drop the auto-start/dvbt setting and separately install/start dump1090-fa on both - Replicate the FA setup (if you do indeed need 2 Pis both separated)
    This is what/why piaware will be working. The output comes raw from the decoding.

    Whereas depending on how you have fr24 configured now is either dump1090-mutability (may be missing those features as old now) or the fr24feed version of the output.

    In graphical form
    Piaware USB -> Dump1090-FA -> output with additional data <- VRS

    FR24feed (2 ways)
    USB -> Dump1090-mu (with --net enabled) <- VRS
    USB -> dump1090-MU (no --net) -> FR24feed <- VRS

    This should sort it out for you on the fr24feed pi
    https://github.com/wiedehopf/adsb-sc...or-dump1090-fa
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Change setting of fr24feed
      sudo nano /etc/fr24feed.ini

      Change
      receiver ="dvbt"

      To
      receiver="beast-tcp"
      host="127.0.0.1:30005"
      bs=no
      raw=no

      The finished file will be like this

      HTML Code:
      receiver="beast-tcp"
      fr24key="xxxxxxxxxxxxxxxx"
      host="127.0.0.1:30005"
      bs="no"
      raw="no"
      logmode="0"
      logpath="/var/log/fr24feed"
      mlat="yes"
      mlat-without-gps="yes"

      Save file (Ctrl+O) and close (Ctrl+X)

      Now remove the fr24 installed dump1090 mutability, and install an independent dump1090-mutability

      HTML Code:
      sudo apt purge dump1090-mutability  
      
      sudo apt install dump1090-mutability  
      
      sudo usermod -a -G plugdev dump1090 
      
      sudo dpkg-reconfigure dump1090-mutability
      (Say Yes when it asks auto start at boot)
      
      sudo reboot  

      Comment


      • #4
        I tried the fixes as recommended by abcd567 and ran into problems. After purging and reinstalling dump1090-mutability, I could not get VRS (Virtual Radar Server) to read anything from any of the "out" IP ports (30002, 30003, and 30005). I tried to again purge and reinstall dump-1090-mutability, but no luck. I also restored the previous /etc/fr24feed.ini file, which didn't help.

        Slight tweak to the procedure. It should be:
        Code:
        sudo apt purge dump1090-mutability
        sudo apt install dump1090-mutability
        (Say Yes when it asks auto start at boot)
        sudo usermod -a -G plugdev dump1090
        sudo dpkg-reconfigure dump1090-mutability
        sudo reboot
        Also, I ran
        Code:
        sudo apt update
        to see how far behind the distribution (Buster) was in updates. 85 updates pending. I wasn't getting anywhere, so I decided to do the apt upgrade. 135MBytes download and 30 mins later, dump1090 still wasn't working right, and I had some additional minor oddities to deal with. At this point, I discovered that I didn't have any more microSD flash cards available, so I decided it was time to give up. I used Balena Etcher to restore the original FR24 image and it's now back to mostly working, but without Signal Level data. I'll continue working on the Signal Level problem when the microSD cards arrive.

        Incidentally, the supplied wpa_supplicant.conf file doesn't work with WPA2-AES-PSK. /etc/wpa_supplicant/wpa_supplicant.conf should look like:
        Code:
        ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
        country=US
        update_config=1
        network={
          ssid="myssid"
          psk="mypasskey"
          proto=RSN
          key_mgmt=WPA-PSK
          pairwise=CCMP
          auth_alg=OPEN
        }
        Thanks for the assistance with FR24 and good luck.
        Last edited by Jeff Liebermann; 2020-10-06, 16:48.

        Comment


        • #5
          Just now wrote Pi24 image to microSD card

          (1) Changed settings in file /etc/fr24feed.ini as in my last post
          HTML Code:
          receiver="beast-tcp"
          fr24key="xxxxxxxxxxxxxxxx"
          host="127.0.0.1:30005"
          bs="no"
          raw="no"
          logmode="0"
          logpath="/var/log/fr24feed"
          mlat="yes"
          mlat-without-gps="yes"

          (2) Purged fr24 dependent dump1090-mutability, and installed an independent copy from repository
          HTML Code:
          sudo apt purge dump1090-mutability
          
          sudo apt install dump1090-mutability
          
          sudo usermod -a -G plugdev dump1090
          
          sudo dpkg-reconfigure dump1090-mutability
          ## Say Yes when it asks auto start at boot
          
          ## Upon completion of dpkg-reconfiguration step, rebooted
          sudo reboot
          during dpkg-reconfigure, said YES to auto-start at boot, and when reached "Interface address to bind" (see screenshot below) deleted 127.0.0.1 to make the field blank, then pressed enter and continue to finish reconfiguration.
          (This was missing step which has caused no data reaching VRS on any port 30002,30003, 30005). Now All data, including RSSI (Signal Level) displayed in VRS

          dump-mut-interface-address-to-bind-1.png

          .


          VRS-AVR-Beast 30005.png
          .


          VRS-rssi.png




          .
          Last edited by abcd567; 2020-10-07, 18:48.

          Comment


          • #6
            I repeated the above experiment, but this time omitted the steps of purge and install dump1090-mutability.

            Instead kept existing dump1090-mutability, but freed it from control of fr24feed, and made it behave as stand alone app by following three steps:
            STEP -1: Changed in /etc/fr24feed.ini
            receiver="dvbt"
            to
            receiver="beast-tcp"
            host="127.0.0.1:30005"

            It became like this
            HTML Code:
            receiver="beast-tcp"
            fr24key="xxxxxxxxxxxxxx"
            host="127.0.0.1:30005"
            bs="no"
            raw="no"
            logmode="1"
            logpath="/var/log/fr24feed"
            mlat="yes"
            mlat-without-gps="yes"
            STEP-2: Ran command sudo dpkg-reconfigure dump1090-mutability. The answer to question "start dump1090-mutability automatically" was by default set as "NO". Changed it to YES, pressed Enter Key, continued with entering latitude & longitude, and completed configuration

            STEP-3: Rebooted Pi. Now dump1090-mutability is no more slave of fr24feed, and behaves as an stand-alone app.



            Pi24-delink-mut-2.png

            .

            Pi24-delink-mut-3.png
            Last edited by abcd567; 2020-10-07, 23:07.

            Comment


            • #7
              Your 2nd method of using the original dump1090-mutability mostly worked. My apologies for forgetting that I had to configure dump1090 and setup the IP ports. I'm now getting signal level updates in VRS (Virtual Radar Server). However, I'm not seeing any updates on https://www.flightradar24.com/accoun...tats/?id=33636 for T-KWVI31. Also, Windoze 10 Task Manager is not showing any outgoing data. I need both signal levels and want to continue sending data to Flightradar24.com.

              You mentioned that "Now dump1090-mutability is no more slave of fr24feed, and behaves as an stand-alone app". I presume that's what broke the outgoing feed. Is there an easy way to reconnect FR24 and dump1090-mutability? I suspect that replacing and updating dump1090-mutablity is required to produce both Signal Level numbers and data sent to Flightradar.com. I'll try replacing dump1090 tomorrow (it's late and I'm tired), which is somewhat of a time burn due to lack of microSD cards for experimenting.

              Incidentally, I switched from "Signal Level" to "Average Signal Level" because "Signal Level" was too erratic to be useful.

              Thanks much for the assistance.
              Last edited by Jeff Liebermann; 2020-10-08, 05:59.

              Comment


              • #8
                No, the first portion prepares fr24feed to use the configuration you make after.

                You probably didn't restart fr24feed. Or it timed out

                Sudo systemctl restart fr24feed

                Wait...

                Sudo fr24feed-status

                Nothing but vrs in windows. You wont see any feeder going out. It's on the pi
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  Oh swell. I write a long reply and get this error message when I try to post it. I'll re-write it in smaller pieces later today.

                  Update 1. Posting a smaller piece of text worked once for this message, but not again. I get the same error no matter what I do now. Argh.

                  Update 2. I put a copy of my reply on my web pile at:
                  http://www.learnbydestroying.com/jef...forum-post.txt
                  The short version is that things are mostly working now. I'll move my reply to this forum after I get a fix for the Error 500 problem from forum support.

                  error message.jpg
                  Last edited by Jeff Liebermann; 2020-10-10, 21:47.

                  Comment

                  Working...
                  X