Announcement

Collapse
No announcement yet.

Lots of Errors on FR24 Startup & Install since latest upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lots of Errors on FR24 Startup & Install since latest upgrade

    When the RPi starts, FR24 fails to pick up the IPV4 address of the RPi - localhost, 127.0.01 (or even the internal network value) until a "sudo systemctl restart fr24feed" is run about 10 mins after bootup

    This is the part of the log when it doesn't work

    2020-09-26 16:49:33 | [main][i]FR24 Feeder/Decoder
    2020-09-26 16:49:33 | [main][i]Version: 1.0.26-5/generic
    2020-09-26 16:49:33 | [main][i]Built on Sep 15 2020 08:05:17 (HEAD-3d4a88a.git/Linux/static_armel)
    2020-09-26 16:49:33 | [main][i]Running on: raspbian10
    2020-09-26 16:49:33 | [main][i]Local IP(s): fe80::7dcf:c100:1603:a97
    2020-09-26 16:49:33 | [main][i]Copyright 2012-2020 Flightradar24 AB
    2020-09-26 16:49:33 | [main][i]https://www.flightradar24.com
    2020-09-26 16:49:33 | [main][i]DNS mode: PING
    2020-09-26 16:49:33 | [main][i]Automatic updates are ENABLED
    2020-09-26 16:49:33 | info | [httpd]Server started, listening on :::8754
    2020-09-26 16:49:33 | [e]PacketSenderConfiguration::fetch_config(): Unable to fetch configuration for yoda receiver

    This is the same part of the log after the restart command

    2020-09-26 17:46:26 | [main][i]FR24 Feeder/Decoder
    2020-09-26 17:46:26 | [main][i]Version: 1.0.26-5/generic
    2020-09-26 17:46:26 | [main][i]Built on Sep 15 2020 08:05:17 (HEAD-3d4a88a.git/Linux/static_armel)
    2020-09-26 17:46:26 | [main][i]Running on: raspbian10
    2020-09-26 17:46:26 | [main][i]Local IP(s): 192.168.0.253,fe80::7dcf:c100:1603:a97
    2020-09-26 17:46:26 | [main][i]Copyright 2012-2020 Flightradar24 AB
    2020-09-26 17:46:26 | [main][i]https://www.flightradar24.com
    2020-09-26 17:46:26 | [main][i]DNS mode: PING
    2020-09-26 17:46:26 | [main][i]Automatic updates are ENABLED
    2020-09-26 17:46:26 | info | [httpd]Server started, listening on :::8754
    2020-09-26 17:46:26 | [i]PacketSenderConfiguration::fetch_config(): Yoda configuration for this receiver is disabled

    Notice that it also is unable to fetch the configuration for the receiver (even though in my case it is disabled)


    This error only happened after the auto upgrade to Version: 1.0.26-5/generic

    Also when you do an fr24feed -status the following error shows
    [httpd][w]bind function failed, errno: 98, waiting 1 seconds

    The waiting time keep adding in increments of 5 seconds


    I have rebuilt the RPi from scratch yesterday in case that was the issue and it is not. All my other feeds work perfectly well.

    On building the RPi, there is an error pulling the install files.
    Trying to run this command sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)" would not work, no matter how many time i tried it. I eventually traced it down to the order of the RPi's DNS servers.

    In every case where 8.8.4.4 was not the first DNS server in the /etc/resolv.conf file, the above bash command would fail.

    Every other pull from every other program worked with my original DNS order - router address, 8.8.8.8, 8.8.4.4

    There seems to be a lot of errors here, hopefully the above will help some people and the Dev to spot and correct them soon.

    T-EGPD7

  • #2
    Same error here....

    Comment


    • #3
      It's not too complicated to use an older version:

      https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

      As described on that page, install one of the decoders first, then follow the instructions to install the slightly older version of fr24feed.

      Comment


      • #4
        Originally posted by wiedehopf View Post
        It's not too complicated to use an older version:

        https://github.com/wiedehopf/adsb-wi...ADS-B-receiver

        As described on that page, install one of the decoders first, then follow the instructions to install the slightly older version of fr24feed.
        Its not too complicated to fix either.
        Shouldn't have to downgrade and fudge the auto updater to get software to work. And i'm certainly not re-installing my RPi yet again to fix a problem that FR24 caused when it failed its upgrade in the first place.
        T-EGPD7

        Comment


        • #5
          If you want to complain or report a bug to FR24 open a ticket, there isn't much official activity here.


          As i can't fix it and usually fixes can take a long time, i proposed an alternative solution.
          You don't need to reinstall Raspbian if you already have a Raspbian, just start with the decoder.

          Comment

          Working...
          X