Announcement

Collapse
No announcement yet.

26-4 update - security error on port 8754

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hkymre
    replied
    yes, all good here as well.

    Leave a comment:


  • ClarDold
    replied
    Originally posted by Rooster View Post
    No need to panic guys... A fix will be auto installed within a day, and the feed is still working... So no need to do anything !
    Except that it didn't auto-install.
    I ran
    sudo apt-get -y update
    Which fetched the new version, but didn't start it.
    sudo systemctl restart fr24feed
    And it looks like all is well.

    Leave a comment:


  • Erwin Sprengers
    replied
    Installed and working! Thanks for the quick support...

    Leave a comment:


  • SierraBravo73
    replied
    I installed the 26-5 update this morning and all is well again. Thank you.

    Leave a comment:


  • Rooster
    replied
    No need to panic guys... A fix will be auto installed within a day, and the feed is still working... So no need to do anything !

    Leave a comment:


  • mrkaqz@gmail.com
    replied
    To confirm the new version 1.0.26-5 is working now and fixed the issue.

    I just issue below command to upgrade the feeder.

    Code:
    sudo apt-get install --only-upgrade fr24feed

    Leave a comment:


  • Khan
    replied
    Hi,

    Sorry about 26-4 breaking the status page. We have released 26-5 just now with a fix. Your Pis should receive it within the next 24 hours. bind-interface="0.0.0.0" in /etc/fr24feed.ini will no longer be required to be present in order for the status page to be accessible.

    Apologies for the inconvenience caused.

    Leave a comment:


  • Erwin Sprengers
    replied
    Indeed very weird, also here the update has triggered this error message.
    According to the manual of FR24FEED, bind-interface="0.0.0.0" should be the default option.

    Quote:
    --bind-interface=”IP_ADDRESS” - Changes the network interface that all FR24 Feeder services listen on. By default it listens on all available interfaces (0.0.0.0). This affects BS/RAW/MPX feeds as well as the WWW interface.

    Adding the line to the ini file and restarting the RPi did not resolve the isse, so I reverted back to the previous ini setting.
    Uploading data seems to be working fine, it's just the status website that's blocked.

    Hopefully a new release will fix it...

    Leave a comment:


  • AndreasWarby
    replied
    There is now a new version out, which I installed manually using apt upgrade: 1.0.26-5 This seems to have fixed the problem of the broken local monitoring web page at port 8754.

    Leave a comment:


  • Oblivian
    replied
    (I'm at work and disabled auto update. Or I would have been in a position to try)

    Leave a comment:


  • Oblivian
    replied
    Someones boobed up and their support email will suddenly be busier that it needed to be

    do a sudo systemctl stop fr24feed
    followed by
    sudo fr24feed


    And see if anything different now complains on startup

    Ctrl-Z will kill it after it settles down

    Leave a comment:


  • SierraBravo73
    replied
    Originally posted by Oblivian View Post
    The HTTP timeout setting has no "s if someone wishes to try this without - as it isn't a field that is present in the config itself with a named field I suspect.

    It likely needs to be bind-interface=0.0.0.0

    And don't forget to start/stop or restart the service
    Thanks! I gave this a try (without the quotation marks) and rebooted the Pi. (I had also used sudo systemctl stop fr24feed and sudo systemctl start fr24feed before I rebooted, but no change).
    I'm fully willing to accept that I'm doing something wrong here as I've only been feeding data for less than two weeks, and still learning.

    Same white screen with the message:

    For security reasons the web interface is only availble from private class networks or after you have manually specified the bind-interface setting in /etc/fr24feed.ini Please set it to bind-interface="0.0.0.0" to accept traffic from all interfaces or to the IP address of your preferred network interface! For further assistance please contact support@fr24.com

    Leave a comment:


  • Oblivian
    replied
    And come to think of it, if you stop service and start normal (sudo fr24feed). It normally will show if the switches are working or causing an error on the full output

    Leave a comment:


  • Oblivian
    replied
    The HTTP timeout setting has no "s if someone wishes to try this without - as it isn't a field that is present in the config itself with a named field I suspect.

    It likely needs to be bind-interface=0.0.0.0

    And don't forget to start/stop or restart the service
    Last edited by Oblivian; 2020-09-15, 01:19.

    Leave a comment:


  • SierraBravo73
    replied
    Same issue. Feed appears to be sending data, but web interface is down - I attempted to modify the /etc/fr24feed.ini with the bind-interface="0.0.0.0" but it had no effect.

    Leave a comment:

Working...
X