Announcement

Collapse
No announcement yet.

Ubuntu Server 20.04 SetUP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu Server 20.04 SetUP

    Hello there I am new feeder,

    I have a fresh ubuntu server installation done in one x64 computer and the gear I have is a Nooelec NESDR SMArt v4 SDR - Premium RTL-SDR and one ADSB antenna.
    However I have no clue how to configure it for my stream to FR24. I already have a sharing key.
    Can please someone help me how to start streaming? Provide me with the codes to insert in the terminal would be ideal.

    I've tried to download the file at FR24 for amd64 computers but I am not sure if I ran that directly that it will recognise the RTL and if that file already included dump1090 or not.

    Thank you a lot in advance!

  • #2
    The amd64 version of fr24feed does NOT install dump1090-mutability. You have to yourself install a decoder (dump1090-mutability OR dump1090-fa OR ModeSDeco2)

    1. Install Dump1090-mutability
    Code:
    sudo apt install dump1090-mutability
    
    sudo usermod -a -G plugdev dump1090  
    
    sudo dpkg-reconfigure dump1090-mutability
    
    sudo systemctl restart dump1090-mutability

    2. Install Flightradar24 Feeder

    2.1 - Issue following two commands to download and install fr24feed’s deb package for amd64 architecture:

    Code:
    wget https://repo-feed.flightradar24.com/linux_x86_64_binaries/fr24feed_1.0.25-3_amd64.deb  
    
    sudo dpkg -i fr24feed_1.0.25-3_amd64.deb
    2.2 - CONFIGURE

    CASE (a): If you have a sharing key:
    Code:
    sudo nano /etc/fr24feed.ini
    Above command will open a file with following entries

    bs=yes
    raw=yes
    mlat="yes"
    mlat-without-gps="yes"

    Add following lines to the file fr24feed.ini (replace xxxxxxxxxxx by your actual sharing key).

    receiver="beast-tcp"
    host="127.0.0.1:30005"
    fr24key="xxxxxxxxxxxxxx"

    Save file (Ctrl+o) and close (Ctrl+x)

    Restart fr24feed
    Code:
    sudo systemctl restart fr24feed
    CASE (b): If you do NOT have a sharing key:

    Signup using following command and provide your details such as email, latitude, longitude etc

    Code:
    sudo fr24feed --signup
    
    sudo systemctl restart fr24feed
    Last edited by abcd567; 2020-08-29, 09:00.

    Comment


    • #3
      Everything appears to be working now.
      However I keep receiving this message
      HTML Code:
      error | write - missing monitor file pointer
      And should I choose
      receiver="beast-tcp"
      if I have a simple Nooelec NESDR SMArt v4 SDR. Shouldn't it be DVBT?
      Last edited by LPMA29; 2020-08-30, 07:40.

      Comment


      • #4
        Originally posted by LPMA29 View Post
        However I keep receiving this message
        HTML Code:
        error | write - missing monitor file pointer
        This message is received if you start fr24feed by following command
        HTML Code:
        fr24feed
        You must have got following message at start. This message does not repeat and that is why you missed it.
        HTML Code:
        Could not open /var/log/fr24feed/fr24feed.log for writing!
        The reason is that the log file's owner is user fr24 and only that user (or a superuser) can write to it.
        HTML Code:
        ls -l  /var/log/fr24feed/fr24feed.log
        -rw-r--r-- 1 fr24 fr24  /var/log/fr24feed/fr24feed.log
        Run it as superuser by using following command and this error will disappear
        HTML Code:
        sudo fr24feed
        WHY YOU WANT TO RUN fr24feed MANUALLY? It gets started by systemd at boot.
        If anytime you want to start/stop/restart it, use following commands
        HTML Code:
        sudo systemctl stop fr24feed
        sudo systemctl start fr24feed
        sudo systemctl restart fr24feed  
        sudo systemctl status fr24feed  



        Originally posted by LPMA29 View Post
        And should I choose if I have a simple Nooelec NESDR SMArt v4 SDR. Shouldn't it be DVBT?
        Using setting "receiver=DVBT" results in forcing fr24feed to ignore data output from any existing decoder, and install a fr24feed controlled version of dump1090-mutability. Unfortunately with amd64 version, the installation script for dump1090-mutability fails. As a result you have a non working system.

        You can use either of the following two settings. I prefer to use the first one.

        Setting-1
        receiver="beast-tcp"
        host="127.0.0.1:30005"

        Setting-2
        receiver="avr-tcp"
        host="127.0.0.1:30002"

        Comment


        • #5
          Thank you very much for your help so far!

          Comment


          • #6
            Originally posted by abcd567 View Post
            The amd64 version of fr24feed does NOT install dump1090-mutability. You have to yourself install a decoder (dump1090-mutability OR dump1090-fa OR ModeSDeco2)

            1. Install Dump1090-mutability
            Code:
            sudo apt install dump1090-mutability
            
            sudo usermod -a -G plugdev dump1090
            
            sudo dpkg-reconfigure dump1090-mutability
            
            sudo systemctl restart dump1090-mutability

            2. Install Flightradar24 Feeder

            2.1 - Issue following two commands to download and install fr24feed’s deb package for amd64 architecture:

            Code:
            wget https://repo-feed.flightradar24.com/linux_x86_64_binaries/fr24feed_1.0.25-3_amd64.deb
            
            sudo dpkg -i fr24feed_1.0.25-3_amd64.deb
            2.2 - CONFIGURE

            CASE (a): If you have a sharing key:
            Code:
            sudo nano /etc/fr24feed.ini
            Above command will open a file with following entries

            bs=yes
            raw=yes
            mlat="yes"
            mlat-without-gps="yes"

            Add following lines to the file fr24feed.ini (replace xxxxxxxxxxx by your actual sharing key).

            receiver="beast-tcp"
            host="127.0.0.1:30005"
            fr24key="xxxxxxxxxxxxxx"

            Save file (Ctrl+o) and close (Ctrl+x)

            Restart fr24feed
            Code:
            sudo systemctl restart fr24feed
            CASE (b): If you do NOT have a sharing key:

            Signup using following command and provide your details such as email, latitude, longitude etc

            Code:
            sudo fr24feed --signup
            
            sudo systemctl restart fr24feed
            My dump1090 does not start by it self I don't know why. Any help?
            When I do
            HTML Code:
            sudo systemctl status dump1090-mutability
            it shows as running however it does not show up in
            HTML Code:
            htop
            Also the web interface doesn't show any aircraft even when I start it manually.

            Any idea to fix these?
            Kind regards

            Comment


            • #7
              Please post output of following command:

              HTML Code:
              sudo systemctl status dump1090-mutability  

              Comment


              • #8
                It was very strange I did
                HTML Code:
                sudo apt-get update
                HTML Code:
                sudo apt-get upgrade
                also

                HTML Code:
                sudo systemctl status dump1090-mutability
                and finally a complete reboot and it worked out.

                Thank you!

                Comment

                Working...
                X