Announcement

Collapse
No announcement yet.

FR24 Link: failure ... failed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24 Link: failure ... failed!

    Well, today I decided to move off of a raspbian install on a 3B to one on another 3B+ I had sitting right next to it, to free up the 3B for other projects.

    The 3B is actively running a DMR piStar node, which is another story. It's using their os build. I've got the software recognizing the usb dongle. I can't for the life of me figure out why it's doing this link failure problem. I've tried reinstalling, reconfiguring. I'm really not sure what I'm doing wrong. I don't remember it being this hard to get it working before.

    Code:
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    is not working for me, various different errors there. So, I have to do the manual install method, which works, as you can see, I input my key and email, etc.

    It'd be real nice to get this all working on the one rPi, but I guess if I can't, I'll just put the other one back up there. Kinda sucks though, seems like a waste. Any ideas?

  • #2
    I've just determined that the piStar has a strict firewall, can someone please tell me which ports or IPs I need add to the file /root/ipv4.fw ?

    I've attached how I have it, currently.
    Attached Files
    Last edited by N6DTE; 2020-08-21, 08:24.

    Comment


    • #3
      Indicates network issue.

      Does it actually have an internet connection? (would explain errors running the installer)

      sudo systemctl stop fr24feed
      sudo fr24feed
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • #4
        Originally posted by Oblivian View Post
        Indicates network issue.

        Does it actually have an internet connection? (would explain errors running the installer)

        sudo systemctl stop fr24feed
        sudo fr24feed
        I actually figured it out. It was the firewall thing. I just had to reload it after I added the new rules. All is working now. I think I wanna leave my post here in case it will help someone else. But maybe delete it if it's redundant, your call!

        73
        N6DTE,
        A Happy Camper (=

        Comment


        • #5
          Still cant access the panel at :8754/settings.html though... Even after adding that to the firewall in that fashion as the others.

          By the way, I know it's online, because I'm SSH'd into it remotely :b
          Last edited by N6DTE; 2020-08-21, 08:48.

          Comment

          Working...
          X