Announcement

Collapse
No announcement yet.

Online - No Data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Online - No Data

    So I finally got everything hooked up but now receiving Online-No Data. I tried unplugging the antenna and plugging it back in with no luck. I am right under the approach and departure path to JFK so not sure why it isn’t picking up aircraft when my flightaware receiver is picking up everything

  • #2
    Going to need a bit more than that out of the blue.

    For instance here https://forum.flightradar24.com/foru...752#post187752
    You said you had the Pi24 Image. Is that still true?

    And how are you finding/confirming you are 'picking up everything'?


    Online - no data, is exactly that. You aren't sending anything to the server.

    nodata.jpg

    https://forum.flightradar24.com/foru...9018#post89018
    Try some of the status-checks.

    I'm guessing the output will look like the 'no data' example
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      I am still running the PI24 image.

      I a confirming by looking at a separate FlightAware receiver I have and it is picking up aircraft that the flightradar24 receiver isnt.

      Thanks for the link I appreciate it.


      Just ran the command sudo fr24feed-status is that the information that I got back.


      2020-05-22 14:08:11 | [main][i]FR24 Feeder/Decoder
      2020-05-22 14:08:11 | [main][i]Version: 1.0.25-3/generic
      2020-05-22 14:08:11 | [main][i]Built on Apr 8 2020 07:06:55 (HEAD-5e8ef0c.git/L inux/static_armel)
      2020-05-22 14:08:11 | [main][i]Running on: pi24-raspbian10
      2020-05-22 14:08:11 | [main][i]Local IP(s): 192.168.1.239
      2020-05-22 14:08:11 | [main][i]Copyright 2012-2020 Flightradar24 AB
      2020-05-22 14:08:11 | [main][i]https://www.flightradar24.com
      2020-05-22 14:08:11 | [main][i]DNS mode: PING
      2020-05-22 14:08:11 | [main][i]Automatic updates are ENABLED
      2020-05-22 14:08:11 | [httpd][w]bind function failed, errno: 98, waiting 1 secon ds
      2020-05-22 14:08:11 | [i]PacketSenderConfiguration::fetch_config(): Yoda configu ration for this receiver is disabled
      2020-05-22 14:08:11 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
      2020-05-22 14:08:11 | [main][i]Reader thread started
      2020-05-22 14:08:11 | [master][i]Starting processing thread
      2020-05-22 14:08:11 | [main][i]Socket server started
      2020-05-22 14:08:11 | [main][i]MLAT data feed started
      2020-05-22 14:08:11 | [bs][i]Initializing server
      2020-05-22 14:08:11 | [mlat][i]Waiting for MLAT configuration
      2020-05-22 14:08:11 | [bs][i]Starting server on 0.0.0.0:30003
      2020-05-22 14:08:11 | [bs][e]Could not bind socket to *:30003, errno=98
      2020-05-22 14:08:11 | [reader][i]Initializing reader
      2020-05-22 14:08:11 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)
      2020-05-22 14:08:11 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:12 | [httpd][w]bind function failed, errno: 98, waiting 6 secon ds
      2020-05-22 14:08:12 | [time][i]Synchronizing time via NTP
      2020-05-22 14:08:12 | [time][i]Time synchronized correctly, offset -0.000 second s
      2020-05-22 14:08:12 | [feed][i]Downloading configuration
      2020-05-22 14:08:12 | [main][i]Feed Network client started
      2020-05-22 14:08:12 | [main][i]RAW data server started
      2020-05-22 14:08:12 | [raw][i]Initializing server
      2020-05-22 14:08:12 | [raw][i]Starting server on 0.0.0.0:30334
      2020-05-22 14:08:12 | [raw][e]Could not bind socket to *:30334, errno=98
      2020-05-22 14:08:12 | [feed][d]fetching configuration
      2020-05-22 14:08:13 | [feed][i]configuring decoder
      2020-05-22 14:08:13 | [feed][c]Max range AIR: 350.0nm
      2020-05-22 14:08:13 | [feed][c]Max range GND: 100.0nm
      2020-05-22 14:08:13 | [feed][i]configuration changed
      2020-05-22 14:08:13 | [feed][i]defined 3 servers
      2020-05-22 14:08:13 | [feed][c]Timestamps: optional
      2020-05-22 14:08:13 | info | [stats]Stats thread started
      2020-05-22 14:08:13 | info | Stopping ReceiverACSender threads for feed
      2020-05-22 14:08:13 | info | Configured ReceiverACSender: 185.218.24.22:8099,185 .218.24.23:8099,185.218.24.24:8099, feed: KFRG20, send_interval: 5s, max age: 15 s, send metadata: true, mode: 1, filtering: true
      2020-05-22 14:08:13 | info | Network thread connecting to 185.218.24.22:8099 for feed KFRG20
      2020-05-22 14:08:13 | [feed][n]KFRG20@185.218.24.22:8099/UDP
      2020-05-22 14:08:13 | [feed][n]connecting
      2020-05-22 14:08:13 | [feed][n]connected via UDP (fd 29)
      2020-05-22 14:08:13 | [feed][i]Feed connected
      2020-05-22 14:08:13 | [feed][n]working
      2020-05-22 14:08:16 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)
      2020-05-22 14:08:16 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:18 | [httpd][w]bind function failed, errno: 98, waiting 11 seco nds
      2020-05-22 14:08:21 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)
      2020-05-22 14:08:21 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:26 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)
      2020-05-22 14:08:26 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:29 | [httpd][w]bind function failed, errno: 98, waiting 16 seco nds
      2020-05-22 14:08:31 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)
      2020-05-22 14:08:31 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:36 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:08:36 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:41 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:08:41 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:08:43 | [feed][n]ping 1
      2020-05-22 14:08:44 | [feed][n]syncing stream result: 1
      2020-05-22 14:08:45 | [httpd][w]bind function failed, errno: 98, waiting 21 seconds
      2020-05-22 14:08:46 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:08:46 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      ^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A2020-05-22 14:08:51 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:08:51 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80 2020-05-22 14:08:56 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:08:56 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:01 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:01 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:06 | [httpd][w]bind function failed, errno: 98, waiting 26 seconds
      2020-05-22 14:09:06 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:06 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:11 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:11 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:13 | [feed][n]ping 2
      2020-05-22 14:09:14 | [feed][n]syncing stream result: 1
      2020-05-22 14:09:16 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:16 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:21 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:21 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      2020-05-22 14:09:26 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.239:80)
      2020-05-22 14:09:26 | [reader][e]Could not connect to avr-tcp://192.168.1.239:80
      ^C2020-05-22 14:09:26 | [main][i]Terminating on user request
      2020-05-22 14:09:26 | [main][i]Terminating worker threads
      2020-05-22 14:09:31 | [reader][i]Terminating on request
      2020-05-22 14:09:32 | [httpd][w]bind function failed, errno: 98, waiting 31 seconds
      2020-05-22 14:09:35 | [master][i]Terminating on request
      2020-05-22 14:09:35 | [feed][x]Feeding thread terminated
      2020-05-22 14:09:35 | [feed][n]busy
      2020-05-22 14:09:35 | [feed][i]Feed disconnected
      2020-05-22 14:09:35 | [feed][n]disconnected
      2020-05-22 14:09:35 | info | Stopping ReceiverACSender threads for feed KFRG20
      2020-05-22 14:09:35 | warning | Exited network thread for feed KFRG20
      2020-05-22 14:09:35 | info | Joined network thread for feed KFRG20
      2020-05-22 14:10:03 | [httpd][e]bind function failed, errno: 98

      Comment


      • #4
        That's running a 2nd time instead of giving you a status page which is wrong for a start. But your issue is immediately seen.


        reader][i]Connecting to AVR-TCP receiver via (avr-tcp://1 92.168.1.239:80)


        Avr-tcp is fussy, and that ip and likely invalid/wrong port number. avr data doesn't come from port 80
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Thanks for taking a look at that. How do i resolve the port number issue?

          Comment


          • #6
            Work out your true data source. And connect to it correctly.

            It's obviously not a USB stick if you have a separate flightaware device.

            So depends on what data is produced and decoded on which output. Be it beast-tcp:30005 or avr-tcp:30002

            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              I am using the Jetvision DVB-T USB stick. This is my first time dealing with these issues so a little confused as to what to do next. Should I re-install the FR24 feed?

              Comment


              • #8
                I think I figured out where I went wrong I think when I was doing the config I chose network connection instead of USB directly to this computer. How do I get back to fix that?

                Comment


                • #9
                  No

                  But you aren't clear with your set-up so I'm equally confused.

                  "my flightaware receiver is picking up everything"

                  Tells me.you have a 2nd setup and are trying to attach to it. Which is why i asked how do you know.

                  If you have only 1 dvbt stick. 1 pi. Nothing else, you need to say so. And should never have changed any feed settings on the image avt-tcp or add an ip/port.

                  Only makes things worse

                  Pi24 is designed to write to image. Startup. Enter email and location and it just runs. Right setting for dvbt


                  Your only way out if above is true. Change the configuration setting to 'dvbt'. Remove any ip/port details and reboot it.
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    Settings help on that thread post1

                    Http://ipofpi:8754

                    Or
                    Sudo fr24feed --reconfigure
                    (Maybe --signup)
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #11
                      The flightaware receiver is on a completely separate raspberry pi device not trying to attach the two. I guess I will try re-insstalling PI24 image.

                      Comment


                      • #12
                        Reinstalling will issue another new radar ID. A waste.

                        You have ssh before. Just do again. Or use the web page
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • #13
                          I am doing the sudo fr24feed -- reconfigure command and how do I figure out the com port number / device path?

                          Comment


                          • #14
                            Your only way out if above is true. Change the configuration setting to 'dvbt'. Remove any ip/port details and reboot it.
                            Don't figure out any. Remove them
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #15
                              That is what I am trying to do is to change the setting to dvbt and this is where I got to in the configuration setup

                              [main][i]FR24 Feeder/Decoder
                              [main][i]Version: 1.0.25-3/generic
                              [main][i]Built on Apr 8 2020 07:06:55 (HEAD-5e8ef0c.git/Linux/static_armel)
                              [main][i]Running on: pi24-raspbian10
                              [main][i]Local IP(s): 192.168.1.239
                              [main][i]Copyright 2012-2020 Flightradar24 AB
                              [main][i]https://www.flightradar24.com
                              [main][i]DNS mode: PING

                              Welcome to the FR24 Decoder/Feeder sign up wizard!

                              Before you continue please make sure that:

                              1 - Your ADS-B receiver is connected to this computer or is accessible over net work
                              2 - You know your antenna's latitude/longitude up to 4 decimal points and the a ltitude in feet
                              3 - You have a working email address that will be used to contact you
                              4 - fr24feed service is stopped. If not, please run: sudo systemctl stop fr24fe ed

                              To terminate - press Ctrl+C at any point


                              Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):

                              1 - DVBT Stick (USB)
                              -----------------------------------------------------
                              2 - SBS1/SBS1er (USB/Network)
                              3 - SBS3 (USB/Network)
                              4 - ModeS Beast (USB/Network)
                              5 - AVR Compatible (DVBT over network, etc)
                              6 - microADSB (USB/Network)
                              7 - SBSx via Basestation (localhost:30006)


                              Enter your receiver type (1-7)$:5

                              Step 4.2 - Please select connection type:

                              1 - Network connection
                              2 - USB directly to this computer

                              Enter your connection type (1-2)$:2

                              Step 4.3A - Please enter your receiver's COM port number/device path
                              $:

                              Comment

                              Working...
                              X