Announcement

Collapse
No announcement yet.

I can't get more than 15nm range.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • abcd567
    replied
    Your heywhatsthat plot shows over 100 miles in two directions, while you get only 15nm.
    The cause may possibly be you have a DVB-T USB with wrong chips.

    For 1090 Mhz, the DVB-T USB Stick should have following two chips (you have mentioned only one chip)
    RTL2832U + R820T2

    Some DVB-T USB Sicks have One chip RTL, other Fitipower, like below.
    These work OK for TV, but for 1090 Mhz, these either dont work or work very poor.
    RTL2832U+FC0012
    RTL2832U+FC0013

    To check chipset in your DVB-T, run following test.
    Code:
    sudo apt-get install rtl-sdr
    
    sudo systemctl stop fr24feed dump1090-fa tar1090
    
    rtl_test -t
    The last command above will list both the chips.

    NOTE: After the test is over, reboot RPi to restore system to normal



    I get following output with a proper DVB-T
    Code:
    rtl_test -t
    
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001090
    
    Using device 0: Generic RTL2832U
    Detached kernel driver
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.
    Reattached kernel driver
    Last edited by abcd567; 2020-05-21, 18:21.

    Leave a comment:


  • wiedehopf
    replied
    Really no reason to go back to dump1090-mutability ... it's outdated.
    If you liked the old interface, you can add it back using the new data:
    https://github.com/wiedehopf/dump1090-retro-html


    I'd recommend also installing the graphs, then you can post pictures that might help in finding out what's wrong.
    Also your adapter from one coax to the other would be interesting to see.

    Leave a comment:


  • gobigorgohome
    replied
    sorry just needed to reboot raspberry for tar1090, now working

    Leave a comment:


  • gobigorgohome
    replied
    Originally posted by wiedehopf View Post
    https://github.com/wiedehopf/adsb-wi...Debug-commands

    You can check if it's the right tuner with rtl_test.

    Also if you want better reception, remove the rolled up coax.
    Or get one of the better SDRs: https://github.com/wiedehopf/adsb-wi...-shopping-list

    Might also be the adapter to the thinner coax you're using.

    In regards to the hills, try the Up in the Air feature as described here: https://github.com/wiedehopf/tar1090...-range-outline
    It should show you what range to expect for aircraft at different altitudes.

    These graphs here are useful for looking at receiver performances: https://github.com/wiedehopf/graphs1090#graphs1090
    Not sure if they will work with the builtin dump1090-mutability.
    If they don't you can always switch to dump1090-fa and then reinstall the graphs (https://github.com/wiedehopf/adsb-sc...or-dump1090-fa).
    Hey.
    Shortened that cable so it's not rolled anymore.

    Checked the possible range on that heywhatsthat webiste and it is showing me around:
    30 miles NORTH@40000feet
    35 miles SOUTH@40000feet
    119 miles WEST@40000feet
    128 miles EAST@40000feet

    Also I have installed dump1090 fa to try it and I will see, maybe i will stick with fa or change back to mutability (i have no idea how to change it back).

    Also installed tar1090 but when i go to 192.168.x.y/tar1090 there is a problem loading page (x and y replaced by my feeder ip).

    Thanks for this help and I will keep you updated if range improves.


    Leave a comment:


  • wiedehopf
    replied
    https://github.com/wiedehopf/adsb-wi...Debug-commands

    You can check if it's the right tuner with rtl_test.

    Also if you want better reception, remove the rolled up coax.
    Or get one of the better SDRs: https://github.com/wiedehopf/adsb-wi...-shopping-list

    Might also be the adapter to the thinner coax you're using.

    In regards to the hills, try the Up in the Air feature as described here: https://github.com/wiedehopf/tar1090...-range-outline
    It should show you what range to expect for aircraft at different altitudes.

    These graphs here are useful for looking at receiver performances: https://github.com/wiedehopf/graphs1090#graphs1090
    Not sure if they will work with the builtin dump1090-mutability.
    If they don't you can always switch to dump1090-fa and then reinstall the graphs (https://github.com/wiedehopf/adsb-sc...or-dump1090-fa).

    Leave a comment:


  • gobigorgohome
    started a topic I can't get more than 15nm range.

    I can't get more than 15nm range.

    Hello there.

    About a month ago I have successfully installed my receiver (T-LIPD17). It is made out of raspberry pi 3 model b, RTL2832 USB chip, and custom antenna (will include some pictures). There is 20W (5V 4A) power supply connected to the raspberry micro USB port and 1m CAT 6 cable between raspberry and router. There is a heatsink without fan on two raspberry chips. I will also attach a screenshot of settings.
    In almost one month I have uploaded a lot of planes but the maximum range is only 15nm. It is true that there are some hills around me but a lot of the times I can see a plane with my eyes way further than 15nm away and the receiver can't. Also tried to do the heatmap test but at the last step of making scan.png file shows me error in heatmap.py file around line 4 (i can send someone scan.csv file if you would like to check
    Antenna is made like the one in tutorial on flightaware forum and there is about 5m of antenna cable from usb adapter to the antenna. Mounted on roof.
    Should I get a filter anyway?
    Is there any other problem you see?


    fr24feedersettings.png
    antenna.jpgraspberry.jpg



Working...
X