Announcement

Collapse
No announcement yet.

Got no response or empty response from the server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Got no response or empty response from the server

    I have moved the location of one of my Raspberry PI FR24 trackers to a new location (new network connection)

    I am trying to run setup again (sudo fr24feed --signup) so I can enter my new location details, but after it asks for my it waits for a minute or so, and then says it cannot validate, or got an empty response?
    If I skip adding my existing key, when it gets to the end of the setup and says its validating my email and location, same response!

    The Pi is connected to my network, as I am configuring via wifi from my computer

  • #2
    Dont use fr24feed --signup if it gives trouble.

    (1) set key in file fr24feed.ini
    sudo nano /etc/fr24feed.ini

    Add following line in the file (use actual key instead of xxxxxxxx )
    fr24key="xxxxxxxx"

    Restart fr24feed
    sudo systemctl restart fr24feed

    (2) Set location on your stats page.
    First login to your account.
    Then click "My data sharing"
    On data sharing page click "show my statistics".
    On statistics page click "eye symbol" to reach location setting page.

    https://www.flightradar24.com/account/data-sharing
    Last edited by abcd567; 2020-05-16, 06:48.

    Comment


    • #3
      Originally posted by abcd567 View Post
      Dont use fr24feed --signup if it gives trouble.

      (1) set key in file fr24feed.ini
      sudo nano /etc/fr24feed.ini

      Add following line in the file (use actual key instead of xxxxxxxx )
      fr24key="xxxxxxxx"

      Restart fr24feed
      sudo systemctl restart fr24feed

      (2) Set location on your stats page.
      First login to your account.
      Then click "My data sharing"
      On data sharing page click "show my statistics".
      On statistics page click "eye symbol" to reach location setting page.

      https://www.flightradar24.com/account/data-sharing
      THanks
      I checked the settings on the web interface, and my key is now in there, and I saved my updated location on my account page on FR24... however im still not feeding:
      pi@raspberrypi:~ $ fr24feed-status

      [ ok ] FR24 Feeder/Decoder Process: running.

      [ ok ] FR24 Stats Timestamp:.

      [FAIL] FR24 Link: unknown ... failed!

      [FAIL] Receiver: down ... failed!

      [FAIL] FR24 MLAT: not running ... failed!

      Comment


      • #4
        (1) Add these two lines in file /etc/fr24feed.ini

        ​use-http=yes
        http-timeout=10

        (2) Save file.

        (3) Restart fr24feed
        sudo systemctl restart fr24feed​​​​​​

        (4) Check status
        fr24feed-status

        .

        Comment


        • #5
          Thanks for the response, tried that, but same result..

          Comment


          • #6
            ok, problem partly solved.
            My pi was set to use a static ip, and the router address for the new network is different.
            Also the new router doesnt seem to like any connected devices trying to use a static ip.
            So its connecting to the server now, but still not all the way there:

            pi@raspberrypi:~ $ fr24feed-status

            [ ok ] FR24 Feeder/Decoder Process: running.

            [ ok ] FR24 Stats Timestamp: 2020-05-16 21:55:34.

            [ ok ] FR24 Link: connected [UDP].

            [ ok ] FR24 Radar: T-NZCH105.

            [ ok ] FR24 Tracked AC: 0.

            [ ok ] Receiver: connected ( MSGS/ SYNC).

            [FAIL] FR24 MLAT: not running ... failed!


            Any thoughts on this?

            Comment


            • #7
              ok ignore my last reports MLAT working now!

              Comment

              Working...
              X