Announcement

Collapse
No announcement yet.

Unable to feed data to Flight Radar24 and Flightaware at the same time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to feed data to Flight Radar24 and Flightaware at the same time


    I'm using a Flightaware USB Pro Stick plus (Blue) and flight aware 1090MHz ads-b antenna. I have followed instructions on most of the posts on this forum regarding feeding data to multiple sites. I have tried the following,
    1.On a fresh Fresh Raspbian buster Image, by running,
    Code:
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    I get the following error,
    Code:
    pi@raspberrypi:~ $ sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/ install_fr24_rpi.sh)"
    --2020-04-22 17:01:28-- http://repo.feed.flightradar24.com/install_fr24_rpi.sh
    Resolving repo.feed.flightradar24.com (repo.feed.flightradar24.com)... 52.216.232.213
    Connecting to repo.feed.flightradar24.com (repo.feed.flightradar24.com)|52.216.232.213|:80.. . connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1284 (1.3K) [text/x-sh]
    Saving to: ‘STDOUT’
    
    - 100%[================================================== ================================================== ================================================== =============>] 1.25K --.-KB/s in 0.001s
    
    2020-04-22 17:01:33 (1.95 MB/s) - written to stdout [1284/1284]
    
    Hit:1 http://archive.raspberrypi.org/debian buster InRelease
    Hit:2 http://flightaware.com/adsb/piaware/files/packages buster InRelease
    Hit:3 http://repo.feed.flightradar24.com flightradar24 InRelease
    Hit:4 http://raspbian.raspberrypi.org/raspbian buster InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    dirmngr is already the newest version (2.2.12-1+rpi1+deb10u1).
    The following package was automatically installed and is no longer required:
    libbladerf1
    Use 'sudo apt autoremove' to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
    Executing: /tmp/apt-key-gpghome.qZI2Q66W6d/gpg.1.sh --recv-key --keyserver pool.sks-keyservers.net C969F07840C430F5
    gpg: keyserver receive failed: Server indicated a failure
    Executing: /tmp/apt-key-gpghome.wk5KGDA5zD/gpg.1.sh --recv-key --keyserver pgp.mit.edu C969F07840C430F5
    gpg: keyserver receive failed: Server indicated a failure
    It says 0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded because I had already tried it once and an older version is installed (not using the bash script though). But, this error was occuring on a fresh Raspbian image. Mainly,
    Code:
    Executing: /tmp/apt-key-gpghome.qZI2Q66W6d/gpg.1.sh --recv-key --keyserver pool.sks-keyservers.net C969F07840C430F5
    gpg: keyserver receive failed: Server indicated a failure
    Executing: /tmp/apt-key-gpghome.wk5KGDA5zD/gpg.1.sh --recv-key --keyserver pgp.mit.edu C969F07840C430F5
    gpg: keyserver receive failed: Server indicated a failure
    2. Tried installing fr24 on PiAware image. I get the same error, can't even go to the sign-up process!

    3. Tried to install PiAware on a FR24 image. With dump1090-fa and dump1090-mutability enabled flight aware gets MLAT but FR24 does not enable MLAT. After removing dump1090-mutability, i observe the same behaviour as mentioned in the previous sentence. With dump1090-fa removed and dump1090-mutability installed, flightaware does not get MLAT, but FR24 does work fine.

    4.Tried everything mentioned in point 3 with receiver changed to Mode-S Beast(TCP) instead of "dvbt" in FR24feeder config file which looks something like this,
    Code:
    bs="no"
    raw="no"
    mlat="yes"
    mlat-without-gps="yes"
    logmode="0"
    receiver="beast-tcp"
    host="127.0.0.1:30005"
    procargs="--gain -10"
    fr24key="xxxxxxxxxxxxxx"
    with the above config file suggested on these forums (to feed piaware and fr24), FR24 also does not run with MLAT enabled or does not upload anything.

    With the below config file,FR24 runs with MLAT enabled and works fine.
    Code:
    bs=yes
    raw=yes
    mlat="yes"
    mlat-without-gps="yes"
    logmode="0"
    procargs="--gain -10"
    fr24key=xxxxxxxxxxxxx
    receiver="dvbt"
    The fact that,
    Code:
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    is giving an error as shown above in this post is what is preventing me from following most guides on this forum to go about uploading data to FR24 and FlightAware!
    How do I go about solving this issue? Any suggestions are very much appreciated! Thanks in advance!


  • #2
    (1) Download Raspbian Buster Lite image from Raspberrypi.org, and wrire to microSD card

    https://www.raspberrypi.org/downloads/raspbian/​​​​​​


    (2) Install dump1090-mutability

    https://forum.flightradar24.com/foru...-15~dev-on-rpi​​​​​​

    (3) Install fr24feed As you are facing GPG key problem when used bash command, use following commands instead:

    CAUTION:
    Do NOT use "receiver=dvbt"
    Use "receiver=beast-tcp", host="127.0.0.1:30005"

    Code:
    wget http://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.25-3_armhf.deb  
    
    sudo dpkg -i fr24feed_1.0.25-3_armhf.deb  
    
    sudo systemctl restart fr24feed
    Last edited by abcd567; 2020-04-22, 23:17.

    Comment


    • #3
      Thanks abcd567 , Your method is the right one! However, I got the bash script
      Code:
      sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
      to run. The issue was that the DNS resolver IP address was set to the IP address of the RaspberryPi on the LAN(itself). Since it was a fresh install it did not have any dns tables to do the querying. There should be a secondary DNS set, in this case which for some reason wasn't set at all in my RPi. Ideally the primary DNS should the gateway and secondary should also be set to something like 8.8.8.8.I think this may be because of how my network is setup! That is why I don't see many others with this issue on this forum So, I changed the DNS server IP address to 8.8.8.8 by editing the resolv.conf using nano,
      Code:
      sudo nano /etc/resolv.conf
      . Then the bash script worked!
      I did the same thing abcd567 mentioned, i.e.
      1. Burn microSD card with Raspbian Lite image. This image contains only Operating system.
      2. Enable SSH: While the microSD card is still in the card reader of your Laptop/Desktop, in File Explorer (Windows) or Finder (Mac) click on drive letter of the microSD card (labelled boot) to open it. It will open folder /boot which has many files & few folders. In the folder /boot, create a new text file and name it ssh.
      3. Slip out microSD card from card reader, slip into RPi and powerup.
      4. Install dump1090-mutability
      5. Install feeders from respective sites:
        Flightradar24
        Flightaware (Install piaware date feeder only. Do not install dump1090-fa)
      I restarted each service after their installations and configuration. MLAT still did not work on the fight radar24 feed. The fr24feed config file I'm using is the following,
      Code:
      receiver="beast-tcp"
      fr24key="xxxxxxxxxxxxxxxx"
      host="127.0.0.1:30005"
      bs="no"
      raw="no"
      logmode="0"
      windowmode="0"
      logpath="/var/log/fr24feed"
      mpx="no"
      mlat="yes"
      mlat-without-gps="yes"
      you canedit this file using nano as follows,
      Code:
      sudo nano  /etc/fr24feed.ini
      Note that multi-lateration(MLAT) will not work with flight aware in this case (becasue we are not going to use dump1090-fa) and that is a fact and nothing is wrong there. However, MLAT should work on Fr24 though. I still don't know the exact cause for this however it was resolved by just updating everything on raspbian using,
      Code:
      sudo apt-get update
      and then
      Code:
      sudo apt-get upgrade
      . In the process I did notice something related to flightaware got updated (dhcpd.conf i believe) and more(i didn't read everything). After which, MLAT started working on flight radar 24 feed and flight aware also started receiving data!

      Comment

      Working...
      X