Announcement

Collapse
No announcement yet.

Ubuntu 18.04.4, fr24feed 1.0.24-5_amd64, segfault in libnss_files-2.27.so

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 18.04.4, fr24feed 1.0.24-5_amd64, segfault in libnss_files-2.27.so

    Hi, can anybody help me with this please?

    I have a small server running dump1080-fa (dump1090-fa_3.8.1_amd64.deb) which is stable and uploading to FlightAware without issue.
    I added fr24feed recently, but I have encountered issues with stability of the binary, it seems.

    Problem:
    fr24feed threads cause a segfaults in the same module. The segfault will normally keep happening until I reboot the system, but sometimes doesn't go away until I reboot multiple times.
    Below are two of the segfaults:

    With "receiver="avr-tcp"" in /etc/fr24feed.ini
    Code:
    Apr 14 21:45:19 aero kernel: [128998.134850] th_reader[9809]: segfault at 63 ip 00007f53de28b448 sp 00007f53d95bf2d0 error 4 in libnss_files-2.27.so[7f53de288000+b000]
    With "receiver="beast-tcp"" in /etc/fr24feed.ini
    Code:
    Apr 14 21:46:20 aero kernel: [129059.168404] mlat_thread_mai[9831]: segfault at 63 ip 00007f4631b64448 sp 00007f461bffd760 error 4 in libnss_files-2.27.so[7f4631b61000+b000]
    Running the binary from the tgz alone (instead of the binary installed by dpkg/.deb):
    Code:
    user@aero:/opt/fr24feed$ ./fr24feed
    ______ _ _ _ _ _ _____ ___
    | ___|| |(_) | | | | | | / __ \ / |
    | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
    | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
    | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
    \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
    __/ |
    |___/
    [main][i]FR24 Feeder/Decoder
    [main][i]Version: 1.0.24-5/generic
    [main][i]Built on Oct 30 2019 07:23:36 (static-i386_amd64-builds-and-macos-dump1090-update-c308dae.git/Linux/amd64)
    [main][i]Running on: ubuntu18.04
    [main][i]Local IP(s): 10.0.0.129
    [main][i]Copyright 2012-2019 Flightradar24 AB
    [main][i]https://www.flightradar24.com
    [main][i]DNS mode: LIBC
    [main][i]Automatic updates are ENABLED
    info | [httpd]Server started, listening on 0.0.0.0:8754
    [i]PacketSenderConfiguration::fetch_config(): Yoda configuration for this receiver is disabled
    [d]TLSConnection::ctor(): Enable verify_peer in production code!
    [master][i]Starting processing thread
    [main][i]Reader thread started
    [reader][i]Initializing reader
    [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    [main][i]MLAT data feed started
    [mlat][i]Waiting for MLAT configuration
    [reader][i]Connected to the receiver, configuring
    [reader][i]Configured, processing messages
    [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
    [time][i]Synchronizing time via NTP
    [time][i]Time synchronized correctly, offset +0.000 seconds
    [main][i]Feed Network client started
    [feed][i]Downloading configuration
    [feed][d]fetching configuration
    [feed][i]configuring decoder
    [feed][c]Max range AIR: 350.0nm
    [feed][c]Max range GND: 100.0nm
    [feed][i]configuration changed
    [feed][i]defined 3 servers
    [feed][c]Timestamps: optional
    info | Stopping ReceiverACSender threads for feed
    info | Configured ReceiverACSender: 185.218.24.22:8099,185.218.24.23:8099,185.218.24.2 4:8099, feed: AABBCC, send_interval: 5s, max age: 15s, send metadata: true, mode: 1, filtering: true
    [feed][n]AABBCC@185.218.24.22:8099/UDP
    info | Network thread connecting to 185.218.24.22:8099 for feed AABBCC
    info | [stats]Stats thread started
    [feed][n]connecting
    [feed][n]connected via UDP (fd 24)
    [feed][i]Feed connected
    [feed][n]working
    [mlat][i]MLAT configuration received, service ENABLED
    [mlat][i]Starting MLAT with preconfigured position: 53.xx,-6.xx,348.0
    [mlat][i]MLAT bandwidth reduction active, level 1
    [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    Segmentation fault (core dumped)

    Versions:
    OS: Ubuntu Server 18.04.4.
    dump1080-fa: dump1090-fa_3.8.1_amd64.deb
    fr24feed: fr24feed_1.0.24-5_amd64.deb
    Source SDR device: FlightAware stick, RTL2832U DVB-T

    File: /etc/fr24feed.ini:
    Code:
    #receiver="avr-tcp"
    #host="127.0.0.1:30002"
    receiver="beast-tcp"
    host="127.0.0.1:30005"
    fr24key="aaaaaaaaaaaaaaa"
    bs="no"
    raw="no"
    logmode="2"
    logpath="/var/log/fr24feed"
    mlat="yes"
    mlat-without-gps="yes"
    Loaded modules:
    Code:
    root@aero:/home/user# lsmod | grep -i rtl
    rtl2832_sdr 36864 0
    videobuf2_vmalloc 16384 1 rtl2832_sdr
    videobuf2_v4l2 24576 1 rtl2832_sdr
    videobuf2_core 40960 2 rtl2832_sdr,videobuf2_v4l2
    videodev 184320 3 rtl2832_sdr,videobuf2_core,videobuf2_v4l2

    Troubleshooting:
    I modified the receiver from avr to beast and noticed that the thread name changed in the segfault statement ("th_reader" to "mlat_thread_mai", as above).
    I verified that the library (libnss_files-2.27.so) was consistent by running a sha256sum on it and a known-good version.
    I ran the binary version of the fr24feed (taken from the tgz file) instead of the dpkg but it also failed with the same segfaults.

    So right now my fr24 feed stays up for about 12hrs before crashing, but my FlightAware feed is fine.
    Any ideas?

  • #2
    .

    Automated Instal of FR24 Feeder on Debian & Ubuntu amd64 on Intel 64bit Computer




    TESTED - "1.0.24-5_amd64" and "1.0.24-5_i386"




    .
    Last edited by abcd567; 2020-04-15, 01:41.

    Comment


    • #3
      abcd567,
      Thank you, I'll read through these links today and hopefully get this working and post back here.

      BTW - Thank you for your work both here and with FA, I built a fine colinear with your guidance in 2016.

      Comment


      • #4
        So the cause of the segfaults appear to be MLAT which is not supported outside of Raspberry Pi and the FR24 receivers.
        Changing back to "mlat="yes"" causes the same segfault as before.

        abcd456, maybe you could mention this in your github page?
        https://github.com/abcd567a/fr24feed...ster/README.md

        Comment


        • #5
          Originally posted by RonnieLast View Post
          abcd456, maybe you could mention this in your github page?
          https://github.com/abcd567a/fr24feed...ster/README.md
          Thanks for reminding. I have now added following in "README.md" at github:

          Caution:
          MLAT is supported only for Raspberry Pi feeder.
          For x86 amd64 feeders, in settings choose mlat=no.
          Setting mlat=yes will result in fr24feed failing with "segmentation fault".

          Comment

          Working...
          X