Announcement

Collapse
No announcement yet.

mlat not running... used to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mlat not running... used to work

    I don't know why however for some reason my mlat is not starting.

    all i can see that could be causing the issue is this, however I don't know how to fix the issue
    [mlat][e]Receiver not compatible with MLAT, timestamps in wrong format![time][i]Time synchronized correctly, offset -0.001 seconds

    It was working, only thing that has change is I had a power blackout and has since rebooted, I have tried rebooting again

    any assistance would be greatly appreaciated

    I have checked the logs and here is the output from /var/log/fr24feed/fr24feed.log
    Code:
    2019-12-21 02:57:23 | info | Joined network thread for feed <removed>
    2019-12-21 02:57:23 | [main][i]Terminated successfully, restarting
    2019-12-21 02:57:23 | ______  _  _         _      _                    _              _____    ___
    2019-12-21 02:57:23 | |  ___|| |(_)       | |    | |                  | |            / __  \  /   |
    2019-12-21 02:57:23 | | |_   | | _   __ _ | |__  | |_  _ __  __ _   __| |  __ _  _ __`' / /' / /| |
    2019-12-21 02:57:23 | |  _|  | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / /  / /_| |
    2019-12-21 02:57:23 | | |    | || || (_| || | | || |_ | |  | (_| || (_| || (_| || |  ./ /___\___  |
    2019-12-21 02:57:23 | \_|    |_||_| \__, ||_| |_| \__||_|   \__,_| \__,_| \__,_||_|  \_____/    |_/
    2019-12-21 02:57:23 |                __/ |                                                        
    2019-12-21 02:57:23 |               |___/                                                          
    2019-12-21 02:57:23 | [main][i]FR24 Feeder/Decoder
    2019-12-21 02:57:23 | [main][i]Version: 1.0.24-7/generic
    2019-12-21 02:57:23 | [main][i]Built on Nov  7 2019 11:23:04 (HEAD-be32703.git/Linux/static_armel)
    2019-12-21 02:57:23 | [main][i]Running on: raspbian8
    2019-12-21 02:57:23 | [main][i]Local IP(s): 10.2.0.249
    2019-12-21 02:57:23 | [main][i]Copyright 2012-2019 Flightradar24 AB
    2019-12-21 02:57:23 | [main][i]https://www.flightradar24.com
    2019-12-21 02:57:23 | [main][i]DNS mode: PING
    2019-12-21 02:57:23 | [main][i]Automatic updates are ENABLED
    2019-12-21 02:57:23 | info | [httpd]Server started, listening on 0.0.0.0:8754
    2019-12-21 02:57:26 | [e]PacketSenderConfiguration::fetch_config(): Unable to parse jsoned response
    2019-12-21 02:57:26 | [d]TLSConnection::ctor(): Enable verify_peer in production code!
    2019-12-21 02:57:26 | [main][i]Reader thread started
    2019-12-21 02:57:26 | [master][i]Starting processing thread
    2019-12-21 02:57:26 | [main][i]MLAT data feed started
    2019-12-21 02:57:26 | [reader][i]Initializing reader
    2019-12-21 02:57:26 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://127.0.0.1:30002)
    2019-12-21 02:57:26 | [reader][i]Connected to the receiver, configuring
    2019-12-21 02:57:26 | [reader][i]Configured, processing messages
    2019-12-21 02:57:26 | [mlat][i]Waiting for MLAT configuration
    2019-12-21 02:57:26 | [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN
    2019-12-21 02:57:27 | [time][i]Synchronizing time via NTP
    2019-12-21 02:57:27 | [mlat][e]Receiver not compatible with MLAT, timestamps in wrong format![time][i]Time synchronized correctly, offset -0.001 seconds
    2019-12-21 02:57:27 | [main][i]Feed Network client started
    2019-12-21 02:57:27 | [feed][i]Downloading configuration
    2019-12-21 02:57:27 | [feed][d]fetching configuration
    2019-12-21 02:57:28 | [reader][i]Timestamp source changed from SYSTEM-UNCERTAIN to SYSTEM-VALIDATED
    2019-12-21 02:57:28 | [feed][i]configuring decoder
    2019-12-21 02:57:28 | [feed][c]Max range AIR: 350.0nm
    2019-12-21 02:57:28 | [feed][c]Max range GND: 100.0nm
    2019-12-21 02:57:28 | [feed][i]configuration changed
    2019-12-21 02:57:28 | [feed][i]defined 3 servers
    2019-12-21 02:57:28 | [feed][c]Timestamps: optional
    2019-12-21 02:57:28 | info | Stopping ReceiverACSender threads for feed
    2019-12-21 02:57:28 | info | Configured ReceiverACSender: 185.218.24.22:8099,185.218.24.23:8099,185.218.24.24:8099, feed: <Removed>, send_interval: 5s, max age: 15s, send metadata: true, mode: 1, filtering: true
    2019-12-21 02:57:28 | info | [stats]Stats thread started
    2019-12-21 02:57:28 | [feed][n]<removed>@185.218.24.22:8099/UDP
    2019-12-21 02:57:28 | info | Network thread connecting to 185.218.24.22:8099 for feed <removed>
    /etc/fr24feed.ini
    Code:
    receiver="avr-tcp"
    fr24key="<removed>"
    host="127.0.0.1:30002"
    bs="no"
    raw="no"
    logmode="1"
    logpath="/var/log/fr24feed"
    mlat="yes"
    mlat-without-gps="yes"
    Thank you for your time and effort in advance.

  • #2
    What receiver do you have?

    Looking at your post history something that uses dump1090.

    Of most the guides here, they say to use dvbt (DONT IMMEDIATELY CHANGE TO THIS), or beast-tcp:30005

    The avr-tcp:30002 format has had issues for a while.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      this will fix your config:
      https://github.com/wiedehopf/adsb-sc...for-dump1090fa

      Comment


      • #4
        @Oblivian hi, i'm using flightaware pro stick plus
        Last edited by ddolbel; 2019-12-21, 20:59.

        Comment


        • #5
          wiedehopf when i built this feeder i used the fr24 pi image and it came with dump1090-mutability the url you provided me seems to talk about dump1090fa wont there be a clash between the two?

          Comment


          • #6
            Yeah it will replace dump1090-mutability with dump1090-fa and modify your fr24 config.

            Fixes 99% of problems people on this forum create for themselves.

            Multiple interfaces, so you can even keep using the old interface if you want to.

            Comment


            • #7
              wiedehopf thanks for the reply i will give it a go, i hadn't actually made any changes to my config or the pi... it just stopped working.

              will let you know how i get on

              Thanks again.

              Comment


              • #8

                receiver="avr-tcp"
                fr24key="<removed>"
                host="127.0.0.1:30002"

                That's not the default configuration though.

                There maybe be other issues if MLAT didn't work with default settings, but it will still be easier to check like this.

                Comment


                • #9
                  wiedehopf it has been working that way for ages

                  Comment


                  • #10
                    wiedehopf i'm getting an error in the script

                    Code:
                    Some packages could not be installed. This may mean that you have
                    requested an impossible situation or if you are using the unstable
                    distribution that some required packages have not yet been created
                    or been moved out of Incoming.
                    The following information may help to resolve the situation:
                    
                    The following packages have unmet dependencies:
                     dump1090-fa : Depends: libncurses5 (>= 6) but 5.9+20140913-1+deb8u3 is to be installed
                                   Depends: libtinfo5 (>= 6) but 5.9+20140913-1+deb8u3 is to be installed
                    E: Unable to correct problems, you have held broken packages.

                    Comment


                    • #11
                      wiedehopf update I have manually found the packages and installed them
                      Code:
                      pi@flightradar:~$ sudo apt-get install libncurses6 libtinfo6
                      Reading package lists... Done
                      Building dependency tree
                      Reading state information... Done
                      libtinfo6 is already the newest version.
                      libncurses6 is already the newest version.
                      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
                      still the error is occuring

                      Comment


                      • #12
                        that's unfortunate.

                        maybe this will help:

                        sudo apt dist-upgrade

                        Comment


                        • #13
                          wiedehopf no change

                          Code:
                          pi@flightradar:~$ sudo apt dist-upgrade
                          Reading package lists... Done
                          Building dependency tree       
                          Reading state information... Done
                          Calculating upgrade... Done
                          0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

                          Comment


                          • #14
                            let's see what you are running:

                            cat /etc/os-release

                            If it's jessie, that might not be supported by dump1090-fa anymore because it's really old.
                            At this point it might be the best solution to just start with a fresh image anyway.

                            Comment


                            • #15
                              Looks that way. Fr reporting raspbian 8 on first output.
                              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                              Comment

                              Working...
                              X