No announcement yet.

Configuration issue: Question 4.3 (COM Port Number/device path)

  • Filter
  • Time
  • Show
Clear All
new posts

  • wiedehopf
    Go with the bundle, it provides an interface that isn't FA branded:

    Anyhow the above link will also fix up your configuration.

    Leave a comment:

  • Oblivian

    Leave a comment:

  • Oblivian
    Microadsb is a different device with different hardware marketed as that.

    You have a tv tuner. Dvbt (digital video broadcast tuner)

    The pi image starts and feeds automatically. However now the config has been changed this wont happen.

    ​​​​​​​Either change to 'dvbt' again, or setup dump1090 separate and use beast-tcp:30005 - wiedhopfs github script can help there.

    Leave a comment:

  • marteno
    Thanks for replying. I went for the manual config as the FR24 website didn't pick up my Pi. Can you advise on what I shoudl be putting if I don't have a microadsb?

    Leave a comment:

  • Oblivian
    If its the image, dont touch the config

    The dvbt setting is automatic

    Changing it when you dont know the implications can make matters worse.

    You appear to have changed it already to microadsb.

    You dont have one of those.

    Leave a comment:

  • Configuration issue: Question 4.3 (COM Port Number/device path)


    Very sorry if this has already been covered here, but I've not been able to find it. Please help!

    I have a Raspberry Pi 3B+ running the Pi24 image. Hardware is a NooElec NESDR Mini USB RTL-SDR & ADS-B receiver. The receiver hardware seems to be working fine - as if I run /usr/bin/dump1090-mutability, I get a rapid stream of data. My problem is that I cannot work out what to put in for Question 4.3 - i.e. my port/COM number.

    The command lsusb gives this:

    Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T

    From dmesg, I know that my hardware is detected. I see a troubling message about the instance being deinitialized and disconnected, but as my data is coming through I have assumed this can be ignored.

    [ +0.000017] rtl2832 3-0010: Realtek RTL2832 successfully attached
    [ +0.000118] usb 1-1.2: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
    [ +0.033371] r820t 4-001a: creating new instance
    [ +0.007219] r820t 4-001a: Rafael Micro r820t successfully identified
    [ +0.016683] Registered IR keymap rc-empty
    [ +0.000215] rc rc0: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0
    [ +0.000205] input: Realtek RTL2832U reference design as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0/input0
    [ +0.000230] rc rc0: lirc_dev: driver dvb_usb_rtl28xxu registered at minor = 0, raw IR receiver, no transmitter
    [ +0.003672] usb 1-1.2: dvb_usb_v2: schedule remote query interval to 200 msecs
    [ +0.008446] usb 1-1.2: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected
    [ +0.000322] usbcore: registered new interface driver dvb_usb_rtl28xxu
    [ +0.148762] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ +0.025606] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
    [ +0.151566] usb 1-1.1.2: reset high-speed USB device number 5 using dwc_otg
    [ +0.140744] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
    [ +0.011925] random: crng init done
    [ +0.000014] random: 7 urandom warning(s) missed due to ratelimiting
    [ +0.005694] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 5370 detected
    [ +0.023633] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
    [ +0.001656] usbcore: registered new interface driver rt2800usb
    [ +0.421625] uart-pl011 3f201000.serial: no DMA platform data
    [ +0.685187] brcmfmac: power management disabled
    [ +0.011546] r820t 4-001a: destroying instance
    [ +0.000460] dvb_usb_v2: 'Realtek RTL2832U reference design:1-1.2' successfully deinitialized and disconnected

    I don't have any /dev/ttyUSB ports.

    I have tried putting in /dev/bus/usb/001/004 (from above), as well as /usr/bin/dump1090-mutability, and have also tried various network options. None of them seem to work and I'm at a loss. Here's a typical message from /var/log/fr24feed/fr24feed.log

    2019-12-13 21:13:06 | [reader][i]Connecting to microADSB receiver via (avr:///dev/bus/usb/001/004@115200)
    2019-12-13 21:13:06 | [bs][reader][e]Could not connect to avr:///dev/bus/usb/001/004@115200

    Can somebody help?

    Many thanks,