Announcement

Collapse
No announcement yet.

Thoughts after a six hour marathon re-install.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Lufthansa View Post
    I just installed FR24feeder on a new RPi (3 B) and have big problems, although I chose option 4 (ModeS Beast) during installation.
    (1) Which image you have written to microSD card, Pi24 or Raspbian?

    (2) Did you install any dcoder yourself? If yes, which one, dump1090-fa or dump1090-mutability?

    Comment


    • #17
      Originally posted by BlackSkyuk View Post

      I'v just set my RPi 4 up and notice in the feeder setting has set option 4 as "ModeS Beast (TCP)" and the guides on this forum say it should be set to ModeS Beast (USB/SERIAL). So dose that mean the number has changed?
      Please indicate where it says use serial to be verified.

      If you have a USB stick - you need to use TCP/internal fed data.
      If you have a beast - USB is the better method (and they have USB). If you dont have a beast, and select USB. You won't get anything.

      https://www.modesbeast.com/pix/meaADSB-mounted-02.jpg this is a beast that uses USB/serial.
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • #18
        Originally posted by abcd567 View Post

        (1) Which image you have written to microSD card, Pi24 or Raspbian?

        (2) Did you install any dcoder yourself? If yes, which one, dump1090-fa or dump1090-mutability?
        Thanks for your reply.

        1. --> Raspbian

        2. --> dump1090-mutability (installed following method 1 https://forum.flightradar24.com/foru...15-dev-on-RPi=)

        Comment


        • #19
          Originally posted by BlackSkyuk View Post

          I'v just set my RPi 4 up and notice in the feeder setting has set option 4 as "ModeS Beast (TCP)" and the guides on this forum say it should be set to ModeS Beast (USB/SERIAL). So dose that mean the number has changed?
          There is nowhere "ModeS Beast (USB/SERIAL)"

          If you run command fr24feed --signup you get option 4 as "ModeS Beast (USB/Network)"

          If you use page IP:8754/settings.html, you get "ModeS Beast (TCP)".

          Both are same, but described differently.



          Step 4.1 - Receiver selection:
          1 - DVBT Stick (USB)
          -----------------------------------------------------
          2 - SBS1/SBS1er (USB/Network)
          3 - SBS3 (USB/Network)
          4 - ModeS Beast (USB/Network)
          5 - AVR Compatible (DVBT over network, etc)
          6 - microADSB (USB/Network)
          7 - SBSx via Basestation (localhost:30006)
          FR24 settings.png

          Comment


          • #20
            Originally posted by Lufthansa View Post



            I just installed FR24feeder on a new RPi (3 B) and have big problems, although I chose option 4 (ModeS Beast) during installation.
            Just saying "big problems" is vauge, and no one can help you with this. Please describe in detail whate are "big problems"

            Comment


            • #21
              Originally posted by abcd567 View Post

              Just saying "big problems" is vauge, and no one can help you with this. Please describe in detail whate are "big problems"
              I can't make any changes in the settings of the feeder (xxxx.8754/settings.html). If I change a property/value (e.g. add "--net --net-http-port 8080") and click the "save" button, the change is not applied.

              The same problem has been described by a user earlier in this thread (post #9).

              Comment


              • #22
                Originally posted by Lufthansa View Post

                I can't make any changes in the settings of the feeder (xxxx.8754/settings.html). If I change a property/value (e.g. add "--net --net-http-port 8080") and click the "save" button, the change is not applied.

                The same problem has been described by a user earlier in this thread (post #9).
                'read only' result

                https://forum.flightradar24.com/foru...489#post178489
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #23
                  Originally posted by Oblivian View Post
                  Many thanks!

                  I'll replace the sd-card.

                  Comment


                  • #24
                    Originally posted by Lufthansa View Post

                    Many thanks!

                    I'll replace the sd-card.
                    New SD-card, installed raspbian + dump1090 + fr24 following the instructions, same problem still can't save changes (8754/settings.html)

                    Comment


                    • #25
                      What are you even trying to do?

                      Try this: https://github.com/wiedehopf/adsb-sc...for-dump1090fa

                      Note this replaces the builtin dump1090 and you won't need the --net --net-port options.
                      dump1090-fa shows something on port 8080 i believe, the other included interfaces are on default http port 80 though.

                      If you understand the lighttpd configuration, you can change pretty much anything you want to change.

                      By the way i'm pretty sure --net-http-port hasn't worked for quite a while.
                      Last edited by wiedehopf; 2020-01-10, 17:31.

                      Comment


                      • #26
                        Originally posted by wiedehopf View Post

                        Note this replaces the builtin dump1090 and you won't need the --net --net-port options.
                        He is NOT using builtin dump1090-mutab of fr24feed. He has burned Raspbian Buster image, installed dump1090-mutabiity by command "sudo apt-get install dump1090-mutabiity" and fr24feed by bash script.

                        His problem is that the page "IP:8754/settings.html" does not save any setting when save button is clicked. This has nothing to do with any type of dump1090 (builtin or mutab or fa). It is purely due to a bug in fr24feed.

                        Give this command, then try to save settings by clicking save button on IP:8754/settings.html page.

                        sudo chmod 666 /etc/fr24feed.ini
                        Last edited by abcd567; 2020-01-11, 01:13.

                        Comment


                        • #27
                          His problem is also that he is trying to use --net-http-port which is not an option that even works.

                          Anyhow the script i linked is a solution to the problem.

                          Comment


                          • #28
                            I have written Piaware SD card image ver 3.8.0 on my RPI 2. This image has dump1090-fa per-installed.

                            I then installed fr24feed by bash script sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)".
                            Edited file /etc/fr24feed.ini and added receiver="beast-tcp", host="127.0.0.1:30005", fr24key=xxxxxxxx and saved file, restarted fr24feed.
                            All working OK

                            Next went to page IP:8754/settings.html.
                            (1) Changed settings and tried to save by clicking SAVE button several times, FAILED TO SAVE SETTINGS.

                            (2) Issued command sudo chmod 666 /etc/fr24feed.ini, and tried to save, FAILED TO SAVE SETTINGS.

                            (3) Issued commands shown in screenshot below, and again changed & tried to save settings at IP:8754/settings.html, but FAILED TO SAVE SETTINGS.

                            Comment


                            • #29
                              On Armbian Buster / OrangePIPC I installed dump1090-mutability by "sudo apt install dump1090-mutability" (i.e. installed EB_VERSION).

                              After installing dump1090-mutability, installed fr24feed by bash command sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)".

                              Edited file /etc/fr24feed.ini and added receiver="beast-tcp", host="127.0.0.1:30005", fr24key=xxxxxxxx and saved file, restarted fr24feed.
                              All working OK


                              Facing same problem i.e. save button on IP:8754/settings.html does not work.
                              Tried all workarounds mentioned in my above post for Piaware SD Card image 3.8.0, and still failed to save from IP:8754/settings.html

                              Comment


                              • #30
                                Hi abcd567 - last weekend I set up RPi 3B Buster Lite image using wiedehopfs bundle installation. I also directly edited the ini file and it all worked. I then played with zerotier VPN and later I found I couldn't save changes using the <ip-or-pi>:8754 settings. I thought it must have been something I did ... so sort of glad you have the problem too !

                                Back to Stretch and 1.0.24-7 !!!


                                ylis

                                Comment

                                Working...
                                X