Announcement

Collapse
No announcement yet.

Raspberry Pi receiver stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspberry Pi receiver stopped working

    My setup has been working great for several months, and then now all of a sudden it stopped feeding data.
    When I reboot the Pi it stops with an error messsage:
    Failed to connect to 127.0.0.1:30005: connect: Connection refused

    Any assistance in what I should look for please?

  • #2
    (1) What is your OS:
    Pi24 image or Raspbian image with fr24feed installed separately?

    (2) Which decoder you have, dump1090-mutability or dump1090-fa

    (3) What is the output of these 2 commands:

    apt-cache policy fr24feed

    cat /etc/fr24feed.ini

    (Remove feeder key before posting)
    Last edited by abcd567; 2019-11-23, 04:16.

    Comment


    • #3
      Thanks for the quick response!
      Software is the Pi24 image
      decoder is an RTL.SDR decoder
      I think its dump1090-fa

      pi@raspberrypi:~ $ apt-cache policy fr24feed

      fr24feed:

      Installed: 1.0.24-7

      Candidate: 1.0.24-7

      Version table:

      *** 1.0.24-7 500

      500 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages

      100 /var/lib/dpkg/status

      Comment


      • #4
        Thanks. As you are not sure about dump1090, output of following 3 commands required:

        (1) cat /etc/fr24feed.ini

        (2) apt-cache policy dump1090-mutability

        (3) apt-cache policy dump1090-fa

        Comment


        • #5
          pi@raspberrypi:~ $ cat /etc/fr24feed.ini

          receiver="beast-tcp"

          fr24key=xxxxxxxxxxx

          host="127.0.0.1:30005"

          path="/usr/lib/fr24/dump1090"

          bs="no"

          raw="no"

          logmode="2"

          windowmode="0"

          logpath="/var/log/fr24feed"

          mpx="no"

          mlat="yes"

          mlat-without-gps="yes

          pi@raspberrypi:~ $ apt-cache policy dump1090-mutability

          dump1090-mutability:

          Installed: (none)

          Candidate: (none)

          Version table:

          1.14 -1

          100 /var/lib/dpkg/status

          pi@raspberrypi:~ $ apt-cache policy dump1090-fa

          dump1090-fa:

          Installed: 3.7.1

          Candidate: 3.7.2

          Version table:

          3.7.2 500

          500 http://flightaware.com/adsb/piaware/files/packages stretch/piaware armhf Packages

          *** 3.7.1 100

          100 /var/lib/dpkg/status




          Last edited by kiwiandy; 2019-11-23, 06:51.

          Comment


          • #6
            This log should be most relevant with your setup:

            sudo journalctl -u dump1090-fa --no-pager

            Best to put it on pastebin com, you have enough posts to share the link.

            Comment


            • #7
              (1) In your post, it is better not to show actual value of fr24key. Replace the fr24key value by xxxxxxxxxxxxx

              (2) All settings are ok. Check if dump1090-fa is running. Give following command and post output:

              sudo systemctl status dump1090-fa

              Comment


              • #8
                OK thanks... i fixed the fr24key!!!

                I just tried something else I searched on the net....
                pi@raspberrypi:~ $ fr24feed-status

                [ ok ] FR24 Feeder/Decoder Process: running.

                [ ok ] FR24 Stats Timestamp: 2019-11-23 04:23:03.

                [ ok ] FR24 Link: connected [UDP].

                [ ok ] FR24 Radar: xxxx

                [ ok ] FR24 Tracked AC: 0.

                [FAIL] Receiver: down ... failed!

                [FAIL] FR24 MLAT: not running ... failed!

                THinking about when I noticed I had stopped reporting, I recalled we had a big electrical storm in the area... I think maybe my RX has been fried!

                Comment


                • #9
                  Check your RX:

                  Is My DVB-T RTL SDR Dongle Healthy?

                  Scroll down to following option:

                  OPTION-2: Dongle plugged into Raspberry Pi.

                  Comment


                  • #10
                    OK thanks will give that a try!

                    Comment


                    • #11
                      pi@raspberrypi:~ $ rtl_test -t

                      No supported devices found.

                      yup, looks like my reciver was toasted by the electrical storm. Luckily I have another spare one.
                      Thanks for the help!

                      Comment

                      Working...
                      X