Announcement

Collapse
No announcement yet.

AMD64 1.0.24-5 is broken

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD64 1.0.24-5 is broken

    does nothing but segfault:

    Code:
    error | Local time: 2019-11-06 16:14:07 -0500
    error | GMT+0 time: 2019-11-06 21:14:07 -0500
    error | Your machine should be set as GMT+0 time zone!
    warning | Time zone is not set to GMT+0
    2019-11-06 16:14:07 | ______  _  _         _      _                    _              _____    ___
    2019-11-06 16:14:07 | |  ___|| |(_)       | |    | |                  | |            / __  \  /   |
    2019-11-06 16:14:07 | | |_   | | _   __ _ | |__  | |_  _ __  __ _   __| |  __ _  _ __`' / /' / /| |
    2019-11-06 16:14:07 | |  _|  | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / /  / /_| |
    2019-11-06 16:14:07 | | |    | || || (_| || | | || |_ | |  | (_| || (_| || (_| || |  ./ /___\___  |
    2019-11-06 16:14:07 | \_|    |_||_| \__, ||_| |_| \__||_|   \__,_| \__,_| \__,_||_|  \_____/    |_/
    2019-11-06 16:14:07 |                __/ |
    2019-11-06 16:14:07 |               |___/
    2019-11-06 16:14:07 | [main][i]FR24 Feeder/Decoder
    2019-11-06 16:14:07 | [main][i]Version: 1.0.24-5/generic
    2019-11-06 16:14:07 | [main][i]Built on Oct 30 2019 07:23:36 (static-i386_amd64-builds-and-macos-dump1090-update-c308dae.git/Linux/amd64)
    2019-11-06 16:14:07 | [main][i]Running on: arch
    hostname: invalid option -- 'I'
    Try 'hostname --help' or 'hostname --usage' for more information.
    2019-11-06 16:14:07 | [main][i]Local IP(s):
    2019-11-06 16:14:07 | [main][i]Copyright 2012-2019 Flightradar24 AB
    2019-11-06 16:14:07 | [main][i]https://www.flightradar24.com
    zsh: segmentation fault  sudo -u fr24 fr24feed --config-file=/etc/fr24feed.ini

  • #2
    AMD64 I assume?

    The jump in version likely has a conflict with new config details added in later versions

    fr24feed --signup

    again

    Also other issue already reported

    https://forum.flightradar24.com/thre...-5-AMD64-error
    Last edited by Oblivian; 2019-11-06, 22:56.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Originally posted by Oblivian View Post
      AMD64 I assume?
      yes.

      Originally posted by Oblivian View Post
      The jump in version likely has a conflict with new config details added in later versions

      fr24feed --signup
      same thing:
      Code:
      error | Local time: 2019-11-06 18:15:17 -0500
      error | GMT+0 time: 2019-11-06 23:15:17 -0500
      error | Your machine should be set as GMT+0 time zone!
      warning | Time zone is not set to GMT+0
      /dev/shm/decoder.txt: Permission denied
      [main][e]Could not create monitor file!
      ______  _  _         _      _                    _              _____    ___
      |  ___|| |(_)       | |    | |                  | |            / __  \  /   |
      | |_   | | _   __ _ | |__  | |_  _ __  __ _   __| |  __ _  _ __`' / /' / /| |
      |  _|  | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / /  / /_| |
      | |    | || || (_| || | | || |_ | |  | (_| || (_| || (_| || |  ./ /___\___  |
      \_|    |_||_| \__, ||_| |_| \__||_|   \__,_| \__,_| \__,_||_|  \_____/    |_/
                     __/ |
                    |___/
      [main][i]FR24 Feeder/Decoder
      [main][i]Version: 1.0.24-5/generic
      [main][i]Built on Oct 30 2019 07:23:36 (static-i386_amd64-builds-and-macos-dump1090-update-c308dae.git/Linux/amd64)
      [main][i]Running on: arch
      hostname: invalid option -- 'I'
      Try 'hostname --help' or 'hostname --usage' for more information.
      [main][i]Local IP(s):
      [main][i]Copyright 2012-2019 Flightradar24 AB
      [main][i]https://www.flightradar24.com
      zsh: segmentation fault  sudo fr24feed --signup

      Comment


      • #4
        I am encountering another error during installation on my AMD64 Linux:

        Err:8 http://giteduberger.fr rpimonitor/ Release
        Redirection loop encountered
        Reading package lists... Done
        N: Skipping acquire of configured file 'piaware/binary-i386/Packages' as repository 'http://flightaware.com/adsb/piaware/files/packages stretch InRelease' doesn't support architecture 'i386'
        N: Skipping acquire of configured file 'piaware/binary-amd64/Packages' as repository 'http://flightaware.com/adsb/piaware/files/packages stretch InRelease' doesn't support architecture 'amd64'
        E: The repository 'http://giteduberger.fr rpimonitor/ Release' no longer has a Release file.
        N: Updating from such a repository can't be done securely, and is therefore disabled by default.
        N: See apt-secure(8) manpage for repository creation and user configuration details.

        Comment


        • #5
          Originally posted by SoNic67 View Post
          I am encountering another error during installation on my AMD64 Linux:
          Unless they have tied those to the install, that is your other apps complaining during a SYSTEM update.

          rpimonitor is an extra
          as is piaware
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            Originally posted by hotaru View Post
            yes.



            same thing:
            Code:
            error | Local time: 2019-11-06 18:15:17 -0500
            error | GMT+0 time: 2019-11-06 23:15:17 -0500
            error | Your machine should be set as GMT+0 time zone!
            warning | Time zone is not set to GMT+0
            /dev/shm/decoder.txt: Permission denied
            [main][e]Could not create monitor file!
            ______  _  _         _      _                    _              _____    ___
            |  ___|| |(_)       | |    | |                  | |            / __  \  /   |
            | |_   | | _   __ _ | |__  | |_  _ __  __ _   __| |  __ _  _ __`' / /' / /| |
            |  _|  | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / /  / /_| |
            | |    | || || (_| || | | || |_ | |  | (_| || (_| || (_| || |  ./ /___\___  |
            \_|    |_||_| \__, ||_| |_| \__||_|   \__,_| \__,_| \__,_||_|  \_____/    |_/
                           __/ |
                          |___/
            [main][i]FR24 Feeder/Decoder
            [main][i]Version: 1.0.24-5/generic
            [main][i]Built on Oct 30 2019 07:23:36 (static-i386_amd64-builds-and-macos-dump1090-update-c308dae.git/Linux/amd64)
            [main][i]Running on: arch
            hostname: invalid option -- 'I'
            Try 'hostname --help' or 'hostname --usage' for more information.
            [main][i]Local IP(s):
            [main][i]Copyright 2012-2019 Flightradar24 AB
            [main][i]https://www.flightradar24.com
            zsh: segmentation fault  sudo fr24feed --signup
            I don't have much of an answer other than flushing all related fr24feed package files and starting again. (and ensuring sudo elevation used)
            Both your examples reference permission faults, And there was all sorts of permission errors similar with the rpi version going from that old 18-x to above

            A clean install of the package would ensure all the files have right permission and fr24 system acct created etc.

            It's also failing to run the 'get local IP script' - hence the hostname messages. Appears ARCH, can't handle it
            https://github.com/sorki/advanced-sh...tory/issues/12
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Spot on Oblivian!

              AMD64 version seems to not like arch, could very well imagine it's segfaulting because hostname -I isn't working to find the IP addresses.

              Sonic: Your problem is with RPi Monitor, not FR24feed.
              sudo rm /etc/apt/sources.list.d/piaware-stretch-testing.list

              This will remove the piaware repository related errors, you don't need those package sources as they don't supply packages for x86.
              In /etc/apt/sources.list.d/ there might also be a file for rpi monitor, remove that to get rid of that error.

              Comment


              • #8
                Hostname thing at least was not a problem prior to this version. I solved it anyways by making /bin/hostname a script that returns the IP address. Obviously this breaks the hostname command for most other things, but this was no problem for me as I run all ADS-B stuff in Docker containers. (Each container kinda is a "mini Linux" of a few MBs, also makes it easy to downgrade.)

                I am pretty sure this is the problem: Your shell seems to be "zsh". FR24Feed requires "bash", or at least parts of bash, and those might be missing in zsh. Earlier versions of FR24Feed, did not require bash but glibc. Thus, try to install bash.

                Comment


                • #9
                  Originally posted by Saturnus View Post
                  I am pretty sure this is the problem: Your shell seems to be "zsh". FR24Feed requires "bash", or at least parts of bash, and those might be missing in zsh. Earlier versions of FR24Feed, did not require bash but glibc. Thus, try to install bash.
                  nope, it does the same thing with bash.

                  Comment


                  • #10
                    It calls the program called hostname, which on your system doesn't support the
                    Code:
                    -I
                    option.
                    Do this on the console:
                    Code:
                    hostname -I
                    It'll show an error.
                    With "which hostname" you can check where the binary is.
                    Replace it with a binary that can handle that option and check if that fixes the problem.

                    You can for example use the binary from the debian package: http://ftp.debian.org/debian/pool/ma...2+b1_amd64.deb
                    Extract that with the command "ar vx filename"
                    Then "tar xf data.tar.xz" which should give you a bin directory in the current folder where you will find the hostname binary.
                    Replace your hostname binary with that and maybe it will no longer segfault :P

                    Comment


                    • #11
                      I tried with the hostname that also did not work for me (Alpine based), and the error is non critical, here at least.

                      Try the ldd command to get a clue about what is up. I think "ldd fr24feed".
                      Last edited by Saturnus; 2019-11-07, 10:27.

                      Comment


                      • #12
                        Originally posted by Saturnus View Post
                        I tried with the hostname that also did not work for me (Alpine based), and the error is non critical, here at least.

                        Try the ldd command to get a clue about what is up. I think "ldd fr24feed".
                        Code:
                                not a dynamic executable

                        Comment


                        • #13
                          Why do I get blocked when replying. FR is crazy...

                          So that is all that ldd gives?

                          How about uname minus a?

                          (Yes apparently that command cannot be writen fully or FR will block me.)

                          Comment


                          • #14
                            Originally posted by Saturnus View Post
                            So that is all that ldd gives?
                            yes.

                            Originally posted by Saturnus View Post
                            How about uname minus a?
                            Code:
                            Linux <hostname redacted> 5.3.9-arch1-1 #1 SMP PREEMPT Wed, 06 Nov 2019 13:30:02 +0000 x86_64 GNU/Linux

                            Comment


                            • #15
                              On Debian 10 amd64

                              Code:
                              wget -O fr24feed_1.0.24-5_amd64.deb https://repo-feed.flightradar24.com/linux_x86_64_binaries/fr24feed_1.0.24-5_amd64.deb 
                              
                              sudo dpkg -i fr24feed_1.0.24-5_amd64.deb
                              
                              sudo fr24feed --signup

                              Last edited by abcd567; 2019-11-07, 20:14.

                              Comment

                              Working...
                              X