No announcement yet.

graphs1090 stopped recording

  • Filter
  • Time
  • Show
Clear All
new posts

  • graphs1090 stopped recording

    Hi, it looks as though graphs1090 stopped recording at 0800 today. I have rebooted, and the service is definitely running. What gives?

  • #2
    Seems like an issue with Buster or maybe the daylight time change?
    Someone else is having a similar problem.
    I'm on Buster though as well and have no such issue.

    I'm not sure what the problem is, see how to check the logs for graphs1090:


    • #3
      Ahhh yes. I just had to run ntpdate. All solved. Thank you.


      • #4
        Is there any way to modify the graphs so that they are all the same size as the top one (ADS-B Message Rate) and all in one column? Also would be interested to learn why Disk IOPS and Bandwidth graphs have never worked, and if that can be resolved. And finally I presume that the MLAT stats are always at zero because I live in a high traffic area, yet I have seen graphs from others in similar areas who also track MLAT. Is there something wrong here? fr24-status shows MLAT as running.
        Last edited by colinLPL; 2019-11-02, 17:25.


        • #5
          FR24 doesn't provide you MLAT results back to your receiver, that's what the graphs are showing.

          Are you using a Raspberry Pi? The system stats are tailored for that.
          I'll still need to see the log in regards to why those graphs don't work, the link in the previous post still applies.

          As to graph size:


          • #6
            Hi, I am back to having the same issue of graphs not running.

            Nov 28 20:30:13 raspberrypi collectd[777]: rrdtool plugin: rrd_update_r (/var/lib/collectd/rrd/localhost/dump1090-localhost/dump1090_range-median.rrd) failed: opening '/var/lib/collectd/rrd/localhost/dump1090-localhost/dump1090_range-median.rrd': Read-only file system

            How can I permanently resolve this?


            • #7
              Read only file system is a different problem from the date problem before.

              sudo mount -o remount,rw /
              sudo sed -i -e 's?$(mount | grep " on / " | grep rw)?{ mount | grep " on / " | grep rw; }?' /usr/lib/fr24/
              Thought they had fixed that problem in the current fr24feed version.

              Read-only file system can also mean the sd-card is dying.


              • #8
                I will make a new image on a new sd card and see what happens. Is this then not the cause of graphs stopping?


                • #9
                  Just try the fix i posted and see if it helps.

                  To find the precise cause is very tedious if the logs aren't set up et cetera.
                  So if it fixes it or if the problem stops i don't care what the real issue was.


                  • #10
                    Will do. If it happens again I will reply in this post. Thank you.


                    • #11
                      It has stopped again.


                      • #12
                        Which "new image" did you use?
                        Standard Raspbian?

                        Install this:

                        And then reinstall the graphs:

                        If this doesn't help, i really don't know how to help you.
                        Maybe you just need to buy a new sd-card.


                        • #13
                          I used the FR24 image, dump1090, graphs1090 and nothing else. I will try those links and if they still fail I'll put in a new card. Thank you.