No announcement yet.

R-Pi 3+ keeps dying. Good time to upgrade to R-Pi 4?

  • Filter
  • Time
  • Show
Clear All
new posts

  • R-Pi 3+ keeps dying. Good time to upgrade to R-Pi 4?

    My R-Pi 3+ keeps dying. I'm not sure what it's problem is, but it's been really hot here lately and the R-Pi is in a hot attic and that probably isn't helping. To get it back online, I just unplug it and plug it back in again and it boots up and it's fine for another 8-10 hours or so. I checked it with a non-contact temperature gun and it read about 120 degrees. R-Pi says its good to 150 degrees or thereabouts.

    I'm considering replacing it with an R-Pi 4. Does anyone have any comparative experience with both or suggestions? I know that I could re-locate it to a cooler environment, but that's easier said than done. I've seen mini fans advertised, but the R-Pi folks say that it isn't necessary.

  • #2
    The Pi 4 has even more a problem with temperature. You can read it everywhere in the different forums.

    A friend of mine bought a Pi 4 after i started my Feeding. He's using a similar environment, but his CPU temperature is constantly above 80C
    The CPU of my 3B never shows more than 60C, even with a high amount of messages and aircrafts

    I would rather think about how to keep the device cooler. Do you use a case without additional fan? Do you use any passive cooler mounted on the CPU?
    Both will help to massively decrease temperature

    This is the temperature reading of my device for the last 30 days. And i have it under the roof in my home office without air condition. During the last weeks i needed to move downstairs in the afternoon for working due to the high temperatures.



    • #3
      It wouldn't hurt to install the graphs so you have a temperature log (even if it causes some additional load, that isn't a problem normally)

      A non-contact thermometer isn't really that accurate compared to the internal temperature measurement.

      Anyway 8-10 hours is way to consistent a time to fail.
      Somewhat ounds like a software problem.

      Try a fresh install with Raspbian Buster Lite or even the pi24 image.

      You might also want to check for power supply problems with this command:
      sudo dmesg --ctime | grep voltage


      • #4
        I'll try to do all of that, thanks.
        I no longer think that it's temperature related. It died late last night after things had cooled down. I reset it again at about 11 PM when it was plenty cool and by morning it had died again. I find it with both LEDs on the R-Pi on solidly. The display connected to the R-Pi shows the PiAware status as fine, but it's just frozen.

        I'm feeding both FA and FR24 and I'm using PiAware 3.7.1


        • #5
          I forgot to ask, where is a good place to find the most recent files to do a fresh install so that I can continue to feed to both FA & FR24?


          • #6
            You are using the piaware sd-card? Starting with that is just fine.

            I personally just use Raspbian and install FA / FR24

            Setup PiAware to directly feed live ADS-B data to FlightAware via a Raspberry Pi running dump1090. Step-by-step instructions along with a link to your statistics and how to register for a free FlightAware Enterprise account.

            Then when installing FR24:
            receiver: beast TCP
            port: 30005
            Last edited by wiedehopf; 2019-08-28, 15:56.


            • #7
              I'm not sure what a Piaware SD card is. I started with a blank SD card and loaded it up.


              • #8
                Originally posted by Pyrojim View Post
                I'm not sure what a Piaware SD card is. I started with a blank SD card and loaded it up.
                The crux of the question, is how did you get the feeders on there originally. (the 'loaded it up' portion)

                Obviously unless the hardware was sent to you ready to go, there was likely some instructions followed to get the feeders on there.
                And knowing which, may help diagnose possible issues.

                The big players provided a ready-to-go image that people often load that have pre-installed things (that can break and are often the root cause if other manual instructions are then followed without knowing consequence) - PiAware, and Pi24 for example they are usually referred to as from the big 2.

                But there are unlimited manual mash up methods also.
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers


                • #9
                  Originally posted by Pyrojim View Post
                  I'm not sure what a Piaware SD card is. I started with a blank SD card and loaded it up.
                  What do you mean by "loaded it up"? This is very vague and no one can help you unless you list all softwares you have installed.


                  • #10
                    By loaded it up, I meant that I took a blank SD card, followed your directions, and placed the image on it as instructed. Then installed the SD card in the R-Pi, turned it on, and followed the rest of the instructions to download and load up the R-Pi with the required software using the commands listed. Obviously, somewhere, I've done something wrong, and I'm trying to figure out what.


                    • #11
                      Originally, I originally purchased an R-Pi, and followed the directions on here to get it up and running from scratch. For whatever reason, it seems to have worked great the first time I did it. It's worked flawlessly for a long time. Until recently.


                      • #12
                        Reading your posts there must have been changed something.
                        If it shows the behavior even with a fresh SD card, your device might have a technical problem.


                        • #13
                          Before you start doing anything with your RasPi, if I was you, I will go and check CPU utilisation on your RasPi.
                          Maybe you have a task which keeps crashing or freezing and using too much CPU and that's why it's going over tepm?
                          Type in your console simple :
                          sudo top
                          And that will show your CPU usage, focus on "load average" which is showing load on your CPU in last 15, 5, 1 minute.
                          Mine looks like that
                          @RasPi 2 v.B
                          load average: 0.56, 0.56, 0.52
                          Top 4 tasks
                          10813 fr24      20   0   31980  13692   2164 R  25.2  1.4 700:23.76 dump1090-mutabi
                          10889 piaware   20   0   12148   8796   5132 R  17.6  0.9 345:24.02 fa-mlat-client
                          10790 fr24      20   0  114432   9016   4700 S   6.9  0.9 139:54.26 fr24feed
                          10837 piaware   20   0   22800  11448   5980 S   2.9  1.2  57:18.47 piaware
                          Which is a little above 50% of usage CPU.

                          You have much stronger RasPi than me so it shouldn't struggle at all.
                          Go and check your software if doesn't help then start digging in hardware.