Announcement

Collapse
No announcement yet.

change settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • change settings

    Hello all,

    yesterday I received my new antenna (https://www.ebay.de/itm/1pcs-ADS-B-P...E/253915016420) and also my RTl-SDR dongle. (https://www.rtl-sdr.com/buy-rtl-sdr-dvb-t-dongles/) All to improve my reception.

    I connected the dongle to my raspberry and rebooted my raspberry. I am wondering do I have to change the settings in myip:8754.
    Do I have to change the receiver in the RTL-SDR dongle.


    I am also feeding to FlightAware and Planefinder. Installed dump1090fa.

    As always thanks for all the advice
    Attached Files
    Last edited by Dutchyb; 2019-08-01, 18:41.

  • #2
    Use this: https://github.com/wiedehopf/adsb-wi...for-dump1090fa

    It takes care of adjusting the settings.

    Or you can use the manual guide:
    https://github.com/wiedehopf/adsb-wi...ng-dump1090-fa

    You'll have to go over the dump1090-fa installation again after selecting the correct fr24feed settings.
    fr24feed in dvb-t mode installs dump1090-mutability 1.14, which then interferes with dump1090-fa.
    (the script should fix up the install pretty much no matter the state, but the guide does as well if you follow all steps)

    Comment


    • #3
      Thank you for your reply.

      I did as you suggested and used your installation guide.
      After doing so, nothing has changed. So I guess the settings were correct already. I have to wait and see if my reception will improve.

      Edit:
      Having troubles feeding after reinstalling the dump1090-fa.
      BTW are you working on your Githup page? Seeing this:
      Screenshot 2019-08-01 at 16.19.07.jpg
      Last edited by Dutchyb; 2019-08-01, 14:21.

      Comment


      • #4
        So the fr24feed screenshot you posted were incorrect settings.

        It needs to be set to ModeS Beast(TCP)

        Host/IP: 127.0.0.1:30005

        The github page works fine, did you try copy and pasting the link?
        Just click it, the displayed version is garbled.

        (Or to copy the link use right click, Copy Link Address)


        Just use the automatic script, that makes it work usually.
        (it caters for some more excentric problems as well.)


        dump1090-mutability shouldn't be installed, so this command should say command not found:

        dump1090-mutability --help

        This command:

        ls /etc/lighttpd/conf-enabled

        should not show 89-dump1090.conf, only 89-dump1090-fa.conf. (and a few others)

        This command should show the following two lines:

        grep -F -e receiver -e host /etc/fr24feed.ini

        receiver="beast-tcp"
        host="127.0.0.1:30005"


        That's mostly it, if you are having trouble you can post the output of this command:

        Code:
        sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-wiki/master/rtl_test.sh)"
        It will test the dongle.
        Last edited by wiedehopf; 2019-08-01, 14:52.

        Comment


        • #5
          Hello again,

          I used your automatic install script again. It seems it did all it had to do So thank you for helping me out again.

          I used your script for optimisation for the gain as well. So will have to see tomorrow.

          Comment


          • #6
            The real question what did you change that required using it?

            Did you change the fr24feed configuration?
            If so why?

            Comment


            • #7
              I did not change anything.

              Thought that the receiver should be changed.
              Ran your test. It says I need to use an original power supply, but I do use the latest original power supply.


              The system seems running smoothly now

              pi@raspberrypi:~ $ sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-wiki/master/rtl_test.sh)"
              Reading package lists... Done
              Building dependency tree
              Reading state information... Done
              The following NEW packages will be installed:
              rtl-sdr
              0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
              Need to get 51.7 kB of archives.
              After this operation, 172 kB of additional disk space will be used.
              Get:1 http://archive.raspberrypi.org/debian stretch/main armhf rtl-sdr armhf 0.5.3-11+rpt1 [51.7 kB]
              Fetched 51.7 kB in 0s (381 kB/s)
              apt-listchanges: Can't set locale; make sure $LC_* and $LANG are correct!
              perl: warning: Setting locale failed.
              perl: warning: Please check that your locale settings:
              LANGUAGE = (unset),
              LC_ALL = (unset),
              LC_CTYPE = "UTF-8",
              LANG = "en_GB.UTF-8"
              are supported and installed on your system.
              perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
              locale: Cannot set LC_CTYPE to default locale: No such file or directory
              locale: Cannot set LC_ALL to default locale: No such file or directory
              Selecting previously unselected package rtl-sdr.
              (Reading database ... 58548 files and directories currently installed.)
              Preparing to unpack .../rtl-sdr_0.5.3-11+rpt1_armhf.deb ...
              Unpacking rtl-sdr (0.5.3-11+rpt1) ...
              Setting up rtl-sdr (0.5.3-11+rpt1) ...
              Processing triggers for man-db (2.7.6.1-2) ...
              4642 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005 --max-range 360 --net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005 --json-location-accuracy 1 --lat 52.50906 --lon 6.11076 --write-json /run/dump1090-fa --quiet
              -----
              Lost samples in the first 2 seconds after starting the test are common and not a problem!
              Starting 30 second rtl_test, standby!
              -----
              Found 1 device(s):
              0: Realtek, RTL2838UHIDIR, SN: 00000001

              Using device 0: Generic RTL2832U OEM
              Found Rafael Micro R820T tuner
              Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
              [R82XX] PLL not locked!
              Sampling at 2400000 S/s.

              Info: This tool will continuously read from the device, and report if
              samples get lost. If you observe no further output, everything is fine.

              Reading samples in async mode...
              Signal caught, exiting!

              User cancel, exiting...
              Samples per million lost (minimum): 0
              -------
              Test finished!
              More than 2 lost samples per million or other errors probably mean the receiver isn't working correctly.
              Try another power supply before condemning the receiver though!
              -------
              -------
              -------
              Your power supply is not adequate, consider the Official Raspberry Pi power supply.
              Any constant voltage supply with 5.1 to 5.2 Volts and 2.5A capability is also a good choice.
              Inadequate power supplies can lead to many different problems!
              -------
              pi@raspberrypi:~ $

              Comment


              • #8
                Hmm, i probably need to change that check.
                I think it also checks for thermal throttling.

                Anyway, no lost samples at all, working very good


                The stick you are using now uses the same driver (rtl-sdr), so nothing needs to be changed.
                Glad it's working again.
                Last edited by wiedehopf; 2019-08-01, 18:43.

                Comment


                • #9
                  Thank you for the support.

                  Does your RTL-SDR dongle getting very hot as well?

                  Comment


                  • #10
                    It actually runs cooler than other dongles.
                    But the case gets hotter and more importantly feels hotter because it's metal.

                    I'm currently running an Airspy Mini and the whole contraption is cooled by a 12cm 12V fan running slowly on 5V.

                    Comment


                    • #11
                      it was very weird to feel hot hot the dongle is. Tried to find answers on the internet, many people seems to have this "problem" some say it is because of the "high" frequencies the dongle has to perform. Guess a fan could be a solution, but IMHO that should not be necessary.

                      Comment


                      • #12
                        glennblum's $10 fan to cool Pi and Dongle both

                        Fan is connected directly to mains supply (110V AC)

                        glennblum fan - 1.jpg glennblum fan - 2.jpg
                        Last edited by abcd567; 2019-08-02, 18:42.

                        Comment


                        • #13
                          I am using the blue FR pro plus stick, equipment is located in my home office under the roof
                          Even with that hot weeks the stick is getting hand warm (outside surface) with a good traffic to be tracked over the day (approx 3500 aircrafts per day in average)

                          Comment


                          • #14
                            Such electronics can run fine at quite high temperatures for a long time.

                            The failures you read about may not be connected to temperature.

                            Anyway as your RPi is also throttling due to heat, the location seems to be quite hot.
                            A case on the RPi will also make it produce more heat and transfer some of that heat via the USB port.

                            So frankly either you don't worry about it, or you do something about it.
                            What do you think is an acceptable failure rate for these devices for example, maybe it's lower when they run cooler.
                            But the question, is it unacceptable when some of them run a little hotter, probably not.

                            Still if you are unlucky, you'll have to get a new one. Or a different product there are other models rtl-sdr compatible receivers available.

                            And as i already said, a plastic case and a metal case feel completely different while the electronics on the inside might be just as hot.
                            Just not as noticeable.

                            Comment


                            • #15
                              As always , thank you for the feedback. will put the dongle on a "metal" .

                              My Pi is in a case indeed. Will check temperature without a case as well.

                              Comment

                              Working...
                              X