Announcement

Collapse
No announcement yet.

Transferred from windows to Pi - different code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Oblivian View Post
    Re targeting me as unhelpful for asking the question.

    Please remember I'm a user too. I taught myself just like most.
    Support staff on email would have probably asked the similar questions
    Oblivian
    Very sorry if you thought I was suggesting you were unhelpful, having been on the receiving end of users questions I fully understand you have to know how they got to where they are before you can help.

    Absolutely NO slight intended towards you!

    I'm very grateful to all those who are trying to help me.

    Comment


    • #32
      ABDC et al
      Thanks for all your help.
      I reran the installation...again, and this time got to the sign up page.
      It reported my email and feeder code didn't match. ( I have had several different feeder numbers whilst trying to get back on-line.)
      By coincidence at exactly this time I received an email from FR24, saying they missed me, and did I have a problem as I hadn't fed for a while?
      So my attempts are on hold whilst they sort out what feeder code they think I should use.
      Once that's sorted I'll be back using ABCD's sign on and wiedehopf's IP6 blockers.
      I am not dead, just sleeping!
      D

      Comment


      • #33
        DONT TRY AND ACTIVATE THE IMAGE


        Every time you do, you will get a new code and start rejecting your email address - The instructions were given prior how to get around it

        Unfortunately, it involves that SSH session.

        https://forum.flightradar24.com/thre...l=1#post124121

        Do NOT use above command. Use following command:

        fr24feed --signup
        Login to the page, and it will list them. (but it should find you on email alone)

        https://www.flightradar24.com/account/data-sharing 4th column
        Last edited by Oblivian; 2019-07-22, 08:55.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #34
          Log-in to your FR24 account and go to this page to find feeder keys:

          https://www.flightradar24.com/account/data-sharing

          Screenshot_20190722-055144_Samsung Internet.jpg

          Comment


          • #35
            two steps forward one step back

            Thanks folk, I think I'm getting closer.
            FR have corrected the email they had on file.
            I followed ABCD's excellent guide literally "to the letter" and using "fr24feed --signup" I have got through ALMOST all of the sign up process.
            so
            Imagine the joy seeing:
            Congratulations! You are now registered and ready to share ADS-D data with Flightradar24.
            + Your radar id is T-EGHH99, please include it in all email communication with us.
            + Please make sure to start sharing data within one month from now as otherwise your ID/KEY will be deleted.
            Thank you for supporting Flightradar24! We hope that you will enjoy our Premium services that will be available to you when you become an active feeder.
            To start sending data now please execute:
            sudo systemctl start fr24feed


            BUT
            Imagine the disappointment at seeing:

            Saving settings to /etc/fr24feed.ini...ERROR

            Full of hope I entered :
            sudo systemctl restart fr24feed
            with no effect and fr24feed -status gave [Fail] FR24 Feeder/Decoder Process ........ failed!
            In the best traditions of computing I have tried rebooting Pi and executing the restart but there is no change.

            I wonder why it couldn't save the ini file? (Yes I have checked the write protect switch on the SD card!)

            Comment


            • #36
              Thanks. both.
              Following your instructions
              Feeder key found, exactly as I had saved it.
              Customer services confirm they had the wrong email on the account, although they wrote to the correct one!

              Comment


              • #37
                ABCD's STEP-7: Checks

                Status in PuTTY : [FAIL] FR24 Feeder/Decoder Process ... failed!
                Status in Browser: and Settings 192.168.0.23 refused to connect.
                check that dump1090 is working http://192.168.0.23/dump1090/gmap.html
                Gave a map, two clocks but 0 aircraft and a yellow box with:
                Problem fetching data from dump1090.
                AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
                The displayed map data will be out of date.

                Unsurprisingly I'm stumped

                Comment


                • #38
                  The fr24feed install has an error which can result in the inability to write to disk, maybe that's why fr24feed.ini couldn't be saved.
                  Can be fixed like this:

                  Code:
                  sudo mount -o remount,rw /
                  sudo sed -i -e 's?$(mount | grep " on / " | grep rw)?{ mount | grep " on / " | grep rw; }?' /usr/lib/fr24/fr24feed_updater.sh &>/dev/null
                  After running the signup again it will hopefully save the fr24feed.ini


                  My bundle install fixes that bug as well, but as you had bad luck getting it to actually complete, i'm hesistant to recommend it again.

                  It doesn't change the settings unless it can install dump1090-fa, so you might just try it one more time and see if it installs dump1090-fa this time around
                  Code:
                  sudo bash -c "$(wget -q -O - raw.githubusercontent.com/wiedehopf/adsb-wiki/master/install-complete.sh)"

                  Comment


                  • #39
                    It is due to Pi24 read only system
                    Issue following commands, then run signup again

                    sudo mount -o remount,rw /
                    sudo touch /etc/fr24feed.ini
                    sudo chmod a+rw /etc/fr24feed.ini

                    Comment


                    • #40
                      Thanks wiedohopf
                      That got it to save the ini file.
                      FR24 actually say I'm online, but not feeding any aircraft!
                      Feeder status in browser is:
                      Linux/generic/static_armel/1.0.23-8
                      Updated: 19:33:45 GMT+0100 (British Summer Time)
                      FR24 Link: Connected via UDP
                      FR24 Radar Code: T-EGHH96
                      Local IP(s): 192.168.0.23
                      Aircraft Tracked:
                      (ModeS & ADS-B) 0
                      Aircraft Uploaded: N/A
                      Receiver: dvbt, Connected
                      MLAT running: NO

                      Running status on the Pi gives this:
                      pi@raspberrypi:~ $ fr24feed -status
                      /dev/shm/decoder.txt: Permission denied
                      [main][e]Could not create monitor file!
                      Could not open /var/log/fr24feed/fr24feed.log for writing!
                      ______ _ _ _ _ _ _____ ___
                      | ___|| |(_) | | | | | | / __ \ / |
                      | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
                      | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
                      | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
                      \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
                      __/ |
                      |___/
                      [main][i]FR24 Feeder/Decoder
                      [main][i]Version: 1.0.23-8/generic
                      [main][i]Built on Oct 11 2018 18:27:28 (HEAD-3c696a7.git/Linux/static_armel)
                      [main][i]Running on: pi24-raspbian9
                      [main][i]Local IP(s): 192.168.0.23
                      [main][i]Copyright 2012-2018 Flightradar24 AB
                      [main][i]https://www.flightradar24.com
                      [main][i]DNS mode: PING
                      [main][i]Automatic updates are ENABLED
                      ERROR: rmmod: ERROR: ../libkmod/libkmod-module.c:793 kmod_module_remove_module() could not remove 'dvb_usb_rtl28xxu': Operation not permitted
                      rmmod: ERROR: could not remove module dvb_usb_rtl28xxu: Operation not permitted
                      [main][i]Reader thread started
                      [main][i]MLAT data feed started
                      [reader][i]Initializing reader
                      [reader][i]Connecting to DVBT receiver via (exe:///usr/bin/dump1090-mutability --raw --mlat)
                      [master][i]Starting processing thread
                      [mlat][i]Waiting for MLAT configuration
                      [httpd][e]bind function failed, errno: 98
                      [httpd][d]Master thread terminated
                      [reader][i]Connected to the receiver, configuring
                      [reader][i]Configured, processing messages
                      Mon Jul 22 18:32:12 2019 UTC dump1090-mutability v1.14 starting up.
                      Found 1 device(s):
                      0: Generic, RTL2832U, SN: 77771111153705700 (currently selected)
                      Detached kernel driver
                      rtlsdr_demod_write_reg failed with -1
                      rtlsdr_demod_read_reg failed with -1
                      rtlsdr_demod_write_reg failed with -1
                      rtlsdr_demod_read_reg failed with -1
                      rtlsdr_demod_write_reg failed with -1
                      rtlsdr_demod_read_reg failed with -1


                      And then much more in the same vein.

                      I particularly note:
                      /dev/shm/decoder.txt: Permission denied
                      [main][e]Could not create monitor file!
                      Could not open /var/log/fr24feed/fr24feed.log for writing!
                      near the beginning.

                      I've had enough for tonight but will try your package again tomorrow.

                      Do I need to reformat the SD and start from there or can I just run your command from the prompt?

                      All the best
                      D

                      Comment


                      • #41
                        Originally posted by abcd567 View Post
                        It is due to Pi24 read only system
                        Issue following commands, then run signup again
                        sudo mount -o remount,rw /
                        sudo touch /etc/fr24feed.ini
                        sudo chmod a+rw /etc/fr24feed.ini
                        Thanks ABCD I will try that tomorrow
                        All the best
                        D

                        Comment


                        • #42
                          fr24feed -status

                          That one is written in one word without the space:

                          fr24feed-status

                          Comment


                          • #43
                            Found 1 device(s):
                            0: Generic, RTL2832U, SN: 77771111153705700 (currently selected)
                            Detached kernel driver
                            rtlsdr_demod_write_reg failed with -1
                            rtlsdr_demod_read_reg failed with -1
                            rtlsdr_demod_write_reg failed with -1
                            This was part of the output of "fr24feed -status" which didn't actually give you the status but started fr24feed. Anyway it was useful information

                            Your dongle seems to be having problems at least on the RPi. (even when it's working fine in Windows)
                            (this is often due to an insufficient power supply)

                            Can you run this command for diagnostics:

                            Code:
                            sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-wiki/master/rtl_test.sh)"
                            You have enough posts now to post the entire output without the post getting blocked
                            Last edited by wiedehopf; 2019-07-22, 18:50.

                            Comment


                            • #44
                              Thanks Wiedehopf
                              I ran it this morning and this is what it said.

                              login as: pi
                              pi@192.168.0.23's password:
                              Linux raspberrypi 4.14.71+ #1145 Fri Sep 21 15:06:38 BST 2018 armv6l
                              ______ _ _ _ _ _ _____ ___
                              | ___|| |(_) | | | | | | / __ \ / |
                              | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
                              | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
                              | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
                              \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
                              __/ |
                              |___/


                              SSH is enabled and the default password for the 'pi' user has not been changed.
                              This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.

                              pi@raspberrypi:~ $ sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-wiki/master/rtl_test.sh)"
                              Reading package lists... Done
                              Building dependency tree
                              Reading state information... Done
                              The following NEW packages will be installed:
                              rtl-sdr
                              0 upgraded, 1 newly installed, 0 to remove and 93 not upgraded.
                              Need to get 51.7 kB of archives.
                              After this operation, 172 kB of additional disk space will be used.
                              Get:1 http://archive.raspberrypi.org/debian stretch/main armhf rtl-sdr armhf 0.5.3-11+rpt1 [51.7 kB]
                              Fetched 51.7 kB in 0s (393 kB/s)
                              Selecting previously unselected package rtl-sdr.
                              (Reading database ... 52837 files and directories currently installed.)
                              Preparing to unpack .../rtl-sdr_0.5.3-11+rpt1_armhf.deb ...
                              Unpacking rtl-sdr (0.5.3-11+rpt1) ...
                              Setting up rtl-sdr (0.5.3-11+rpt1) ...
                              Processing triggers for man-db (2.7.6.1-2) ...
                              -----
                              Lost samples in the first 2 seconds after starting the test are common and not a problem!
                              Starting 30 second rtl_test, standby!
                              -----
                              Found 1 device(s):
                              0: Generic, RTL2832U, SN: 77771111153705700

                              Using device 0: Generic RTL2832U
                              Detached kernel driver
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_read_reg failed with -1
                              rtlsdr_write_reg failed with -1
                              rtlsdr_read_reg failed with -1
                              rtlsdr_write_reg failed with -1
                              rtlsdr_read_reg failed with -1
                              rtlsdr_write_reg failed with -1
                              rtlsdr_read_reg failed with -1
                              rtlsdr_write_reg failed with -1
                              No supported tuner found
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              Enabled direct sampling mode, input 1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -1
                              rtlsdr_demod_write_reg failed with -1
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              Supported gain values (1): 0.0
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              WARNING: Failed to set sample rate.
                              rtlsdr_demod_write_reg failed with -4
                              rtlsdr_demod_read_reg failed with -4
                              rtlsdr_write_reg failed with -4
                              rtlsdr_write_reg failed with -4

                              Info: This tool will continuously read from the device, and report if
                              samples get lost. If you observe no further output, everything is fine.

                              Reading samples in async mode...
                              Failed to submit transfer 0!

                              Library error -5, exiting...
                              rtlsdr_write_reg failed with -4
                              Reattaching kernel driver failed!
                              -------
                              Test finished!
                              More than 2 lost samples per million or other errors probably mean the receiver isn't working correctly.
                              Try another power supply before condemning the receiver though!
                              -------
                              -------
                              No undervoltage detected, looking fine!
                              If the dongle is not directly plugged into the Raspberry Pi, lack of power/voltage could still be an issue.
                              Even without detected undervoltage a better power supply can often improve reception!
                              For optimum performance i would recommend the Official Raspberry Pi power supply.
                              -------
                              pi@raspberrypi:~ $

                              Comment


                              • #45
                                Running Staus correctly gives:

                                pi@raspberrypi:~ $ fr24feed-status
                                [ ok ] FR24 Feeder/Decoder Process: running.
                                [ ok ] FR24 Stats Timestamp: 2019-07-23 07:54:29.
                                [ ok ] FR24 Link: connected [UDP].
                                [ ok ] FR24 Radar: T-EGHH96.
                                [ ok ] FR24 Tracked AC:.
                                [ ok ] Receiver: connected ( MSGS/ SYNC).
                                [FAIL] FR24 MLAT: not running ... failed!

                                FR24 website reports online but no data

                                Comment

                                Working...
                                X