No announcement yet.

Distance n/s dump1090

  • Filter
  • Time
  • Show
Clear All
new posts

  • Distance n/s dump1090

    Again I am trying to learn more and more.
    In my dump1090 I can not see the distance from site.

    Screenshot 2019-06-30 at 16.31.46.png

    I searched the forum and found this thread: In # 6 it is suggested that I add my long/lat in the settings. But I cannot find where to add those.
    I am using dump1090-fa

    Screenshot 2019-06-30 at 16.35.26.jpg

    probably something rather easy to do, but trying to sind a way to do so for about a day.

    Thanks for the help, as always

  • #2
    Check here:

    You could also just install piaware as you want to that anyway.
    (only one command needed: sudo apt install piaware)
    Then after claiming your station and configuring your location on your statistics page, dump1090-fa will use the location provided by piaware.


    • #3
      As always, thank you for the fast reply.

      Will try both solutions, just to learn. And I bookmarked your githup site.

      looks like PiAware is playing with me again.
      pi@raspberrypi:~ $ piaware-status
      PiAware master process (piaware) is running with pid 1010.
      PiAware ADS-B client (faup1090) is running with pid 1038.
      PiAware ADS-B UAT client (faup978) is not running.
      PiAware mlat client (fa-mlat-client) is not running.
      Local ADS-B receiver (dump1090-fa) is running with pid 492.

      dump1090-fa (pid 492) is listening for connections on port 30005.
      no program appears to be listening for connections on port 30978.
      faup1090 is connected to the ADS-B receiver.
      faup978 is NOT connected to the ADS-B UAT receiver.
      piaware is connected to FlightAware.

      got 'couldn't open socket: cannot assign requested address'
      dump1090 is producing data on localhost:30005.

      Your feeder ID is xxxxxxxxxxxxxxxxxxxx(from /var/cache/piaware/feeder_id)

      Guess Piaware don't like me
      Last edited by Dutchyb; 2019-06-30, 16:03.


      • #4

        Uninstalled PiAware and installed it again. Now it is working, except the distance is still not showing


        • #5
          Did you go on the web page to claim your receiver? (just google "claim flightaware")
          And register an account of course?

          The piaware-status output signifies everything is working correctly.

          Edit: Seems their webpage isn't working at the moment, that doesn't happen very often, they must have known you were looking for them


          • #6

            Guess you are they do not like me:0. Did you contact them?
            I am connected to Flightaware, long /lat are set, I am feeding. But in the dump still no distance.

            Screenshot 2019-07-01 at 13.33.40.jpg

            Screenshot 2019-07-01 at 13.37.58.png

            Any ideas?


            Used your first suggestion, manually adjusted it in /etc/dafault/dump1090-fa and now it is working.
            Last edited by Dutchyb; 2019-07-01, 12:14.


            • #7
              Are you really 3m above sea level?

              That seems strange.

              Anyway after configuring the location you need to wait for piaware to restart or restart it yourself.
              Then you need to restart dump1090-fa so it displays the location.


              • #8
                The city I am living in is 3m above sea level. Checked it on Google. ( and you know if Google says so.....). My guess is, that you are above sea level as well

                Screenshot 2019-07-01 at 18.59.20.png

                I adjusted the Lon and lat and now it is showing the actual distance.
                Screenshot 2019-07-01 at 19.01.37.png


                • #9
                  Flightaware somehow showed nearest airport ETUO, doesn't make any sense after looking at your GPS coordinates

                  Other airports seem much closer.


                  • #10
                    You are right, changed it today