Announcement

Collapse
No announcement yet.

Feeder filtering most data from upload

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feeder filtering most data from upload

    Hi!

    I'm using Linux feeding client, however, it is trying to filter out 90% of the traffic after some time from feed start. So, in the beginning nothing has been filtered, in starts after some minutes. This results in "no data sent" in statistic or even "offline" mode. Is there any parameters for fr24.ini to prevent this behaviour?
    Last edited by djpeter; 2019-06-24, 08:48.

  • #2
    The filtering is for traffic that is already well received by enough FR24 receivers.
    The statistics page isn't perfect so there might be some glitches.

    The uptime / availability shouldn't be affected.

    Don't think you can do anything about it except asking FR24 to change the stats system (good luck )

    If you have better reception it's less likely that all planes you receive will be filtered however.
    So improve your reception

    At night with little traffic it might still behave like you described.

    Comment


    • #3
      The reception is perfect, however, there are dozens of receivers in my area, so even I'm in the top part of statistic, there can be overcomers for sure. Strange that feed restart helps for a while, than it starts again

      Comment


      • #4
        Could i have a look at your stats?
        You can't post the URL because you have few posts, but you can post the number at the end mine is 21745

        https://www.flightradar24.com/accoun...tats/?id=21745

        Or you could attach a screenshot.

        The filtering only proceeds after some time.

        The filtering should not affect the positions/hits reported.
        The feed program counts those internally and sends that statistic data to the server.

        But the "current upload rate" and apparently the "Online" flag depends on the actual data sent.
        Last edited by wiedehopf; 2019-06-24, 10:27.

        Comment


        • #5
          My id is id=5446
          As you can see, there are holes in the time line, when feed was "offline"

          Comment


          • #6
            Can't see anything, it's not public.
            There is a toggle for that on the statistic page named "STATS SHARING".

            Anyway it can help to add these two lines to /etc/fr24feed.ini

            Code:
            use-http=yes
            http-timeout=20
            Might help, might not, depends on what the problem is.

            If you don't want or know how to use an editor, you can add the two lines with this command:
            Code:
            sudo echo -n -e 'use-http=yes\r\nhttp-timeout=20\r\n' >> /etc/fr24feed.ini

            Comment


            • #7
              Those 2 lines are already added based on my search in this forum. Filtering however continues regardless of those lines. Let's see how it will be with "offline" for now.
              My statistics are here and public
              https://www.flightradar24.com/accoun...stats/?id=5446
              Last edited by djpeter; 2019-06-24, 12:40.

              Comment


              • #8
                Still showing private for me.

                Anyway nothing i can do for you.

                You can always open a ticket with support, that's the best way to get in touch with FR24.

                Comment


                • #9
                  Originally posted by djpeter View Post
                  Hi!

                  I'm using Linux feeding client, however, it is trying to filter out 90% of the traffic after some time from feed start. So, in the beginning nothing has been filtered, in starts after some minutes. This results in "no data sent" in statistic or even "offline" mode. Is there any parameters for fr24.ini to prevent this behaviour?
                  I found similar problems with this old Linux client, there are obviously problems with it, including your issue and the over-reporting of hits. This has already come up in threads. Adding the http lines to the .ini file did not fix it.
                  When I switched to the X86 version of Raspbian OS and used the Raspbian client the problems went away.

                  Comment


                  • #10
                    I do not have free machines for Raspbian, so Linux binary is the only option for me for now. I will raise the ticket to FR24 dev team.

                    Comment


                    • #11
                      Originally posted by djpeter View Post
                      I do not have free machines for Raspbian, so Linux binary is the only option for me for now. I will raise the ticket to FR24 dev team.
                      Good luck!

                      Comment


                      • #12
                        This is the reply I've got:
                        Filtering is always going to happen because the software removes the AC that have already been sent. And it doesn't affect online availability. It's also not affected by if any data is sent or not. The breaks that you see are most probably from the software not being able to upload stats info to our servers.

                        Comment


                        • #13
                          Originally posted by djpeter View Post
                          This is the reply I've got:
                          Filtering is always going to happen because the software removes the AC that have already been sent. And it doesn't affect online availability. It's also not affected by if any data is sent or not. The breaks that you see are most probably from the software not being able to upload stats info to our servers.
                          If you are experiencing the same as I did, the filtering basically increased until I was uploading practically nothing. A restart restored the feed, but then the same thing would happen some time later. I also found that the reported hits sometimes increased to double the normal rate. Drop outs did not happen very often, but weach time a restart brought things back online.

                          There is no doubt that the software is broken, at least on the two versions of Linux I tried with it. Once I installed Raspbian (on a VM) and the Raspbian feeder all was good. Filtering was occurring, but it appeared to be reasonable.feed.PNG
                          Last edited by Stealth; 2019-06-25, 08:34.

                          Comment


                          • #14
                            There are 3 packages available


                            (1) fr24feed_1.0.18-5_i386.deb

                            (2) fr24feed_1.0.18-5_amd64.tgz

                            (3) fr24feed_1.0.23-8_armhf.deb

                            The first two are for linux on x64 and x86 Computer. Both are outdated (ver 1.0.18-5) and give problem.

                            The last one is the latest (ver 1.0.23-8) and gives trouble free service. It is for RPi and other computer boards with armh cpu. It fail to install and/or run on main stream linux distros like ubuntu, debian etc. It works ONLY on Raspbian Desktop OS which emulates armhf while runing on x64 x86 machines. Even on Raspbian Desktop OS, it requires using command "sudo dpkg --add-architecture armhf", and installation of armhf specific dependenies by adding ":armhf" at the end of package name.

                            To summerize, the only troble free option for x64 x86 machines is to install Raspbian Desktop OS, and use:

                            "OPTION-1: Installing fr24feed Using debian package for RPi:
                            fr24feed_1.0.23-8_armhf.deb"

                            of this post:

                            https://forum.flightradar24.com/thre...l=1#post116967


                            .

                            Comment

                            Working...
                            X