Announcement

Collapse
No announcement yet.

Dump1090 - error 404 - PiAware + FR24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dump1090 - error 404 - PiAware + FR24

    I need some help if you would be so kind. Dump1090 shows error 404.

    I am using:
    • FlightAware ProStick Plus
    • RPi 3B+
    • PiAware pre-installed (dump1090-fa is working now)

    + just installed FR24 using sudo bash -c "$(wget -O - ......etc.... install_fr24_rpi.sh)", provided all data during configuration, typed everything in settings in IP-of-Pi:8754 (as per the Settings page image in the #2 post: 2019-PI24-QuickStart-Guide).

    Changed receiver to Beast TCP (as per the thread BUG-receiver-type-avr-tcp-and-auto-configuration-not-working) but dump1090 still isn't working. IP-of-Pi/dump1090 returns "404 - Not Found"

    What am I doing wrong?


  • #2
    dump1090-fa is reachable at http://Ip-of-Pi/dump1090-fa

    If fr24feed already installed dump1090-mutability because you didn't use the correct settings at the start, follow these steps
    https://github.com/wiedehopf/adsb-wi...ng-dump1090-fa

    you can also use this script:
    https://github.com/wiedehopf/adsb-wi...or-dump1090-fa

    It removes dump1090-mutability and reinstalls dump1090-fa.
    Last edited by wiedehopf; 2019-06-18, 17:15.

    Comment


    • #3
      Originally posted by wiedehopf View Post
      dump1090-fa is reachable at [...]
      Thank you, but dump1090-fa is working as it was before FR24. So I understand mutability was NOT installed.

      The FR24's dump1090 is not working.

      Comment


      • #4
        you can't have two dump1090 running at the same time.

        (well technically you can but you don't want to, it's complicated and unnecessary)

        fr24feed is getting data from dump1090-fa
        (receiver=beast-tcp and host=127.0.0.1:30005)

        what does

        fr24feed-status

        say?

        Don't really know what the problem is?

        Comment


        • #5
          Looks like the feeder is running, connected, with MLAT on.
          fr24feed-status.png
          Have I typed anything wrong here?
          404-not_found.PNG
          Attached Files
          Last edited by FlightStrip; 2019-06-18, 18:16. Reason: image upside down...

          Comment


          • #6
            yes you need to add -fa

            /dump1090-fa

            there is no /dump1090 when running dump1090-fa.

            Comment


            • #7
              So I understand the -fa view is all I will see, no changes to the map or more info etc.
              Thank you!

              Comment


              • #8
                I'm not sure what you were expecting.

                you can check this page: http://192.168.0.7:8754
                but no planes on that page.

                dump1090-fa has some more info than dump1090-mutability, indicated airspeed and stuff like that but only if it's queried by your local ATC.

                If you are looking for more features, maybe you want some statistics?
                https://github.com/wiedehopf/graphs1090#graphs1090

                Or a 24h replay of your local data:
                https://github.com/wiedehopf/timelap...#timelapse1090

                Comment


                • #9
                  Originally posted by FlightStrip View Post
                  I need some help if you would be so kind. Dump1090 shows error 404.

                  I am using:

                  PiAware pre-installed (dump1090-fa is working now)
                  ....

                  typed everything in settings in IP-of-Pi:8754 (as per the Settings page image in the #2 post: 2019-PI24-QuickStart-Guide).

                  The settings in that guide are for PI24 image, and do NOT work with Piaware image. The title is very clear "Pi24 Quickstart guide".

                  Changed receiver to Beast TCP (as per the thread BUG-receiver-type-avr-tcp-and-auto-configuration-not-working) but dump1090 still isn't working. IP-of-Pi/dump1090 returns "404 - Not Found"

                  What am I doing wrong?
                  The setting AVR TCP no more works with current version of fr24feed.
                  Use Beast TCP, port 30005.
                  Please see screenshot below:

                  FR24 settings - External dump1090 - BEAST-TCP.png

                  Above setting disables fr24feed's built-in dump1090-mutability ver 1.14, and uses data from builtin dump1090-fa of Piaware image.The map is displayed at:

                  IP-of-Pi/dump1090-fa/



                  Since you have initially chosen Pi24 settings (receiver dvbt), fr24feed has probably already installed dump1090-mutabilty. However it will become inactive when you choose setting receiver Beast-TCP, host/port 127.0.0.1:30005.

                  You can check if it is already installed or not by following command:

                  Code:
                  apt-cache policy dump1090-mutability
                  Last edited by abcd567; 2019-06-19, 14:52.

                  Comment

                  Working...
                  X