Announcement

Collapse
No announcement yet.

2019 - PI24 (Image) QuickStart Guide

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • randys
    replied
    Crystal clear, abcd567!

    Many thanks!

    Leave a comment:


  • abcd567
    replied
    Originally posted by randys View Post
    I wondering if exists a quality difference between using PI4 image or a complete setup (Raspian OS + Dump1090 + FR24 Data Feeder).

    There is no quality difference, as the latest Pi24 image has same components (i.e. Raspbian Buster + FR24 feeder + dump1090-mutability 1.15 EB_VER).

    The only difference is in configuration. In Pi24 image, the fr24feed uses setting "receiver=dvbt". This setting modifies dump1090-mitability configuration as follows:

    (1) dump1090-mitability does not start at boot by itself. It is started by fr24feed.

    (2) All output ports of dump1090-mutability are blocked. Other feedes dont get data unless in fr24feed settings field "Process arguments" an argument --net is added.

    (3) The user cannot directly set gain, latitude, longitude in dump1090 configurayion. These are specified in fr24feed settings, and fr24feed passes these to dump1090-mutability when fr24feed issues start command to it.

    (4) The systemctl command start stop restart are also blocked.

    In nutshell, in Pi24 image, the dump1090-mutability is under control of fr24feed, but this does NOT affect performance in any way.

    If you use Raspbian Buster image, and install dump1090-mutability by following command and use fr24feed setting
    "receiver=beast-tcp"
    "host=127.0.0.1:30005"
    then dump1090-mutability functions as an independent software.


    Raspbian Bister image from Raspberrypi.org - Install and configure dump1090-mutability
    Code:
    sudo apt update
    sudo apt install dump1090-mutability
    
    sudo usermod -a -G plugdev dump1090
    sudo systemctl restart dump1090-mutability  
    
    sudo dpkg-reconfigure dump1090-mutability

    Raspbian Buster image from Raspberrypi.org - Install FR24 feeder

    Note:With Raspbian image, Do NOT use setting "receiver=dvbt". Use setting "receiver=beast-tcp"

    Code:
    sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"
    Last edited by abcd567; 2020-04-21, 02:57.

    Leave a comment:


  • randys
    replied
    Hi abcd567, thank you for this.

    I wondering if exists a quality difference between using PI4 image or a complete setup (Raspian OS + Dump1090 + FR24 Data Feeder).

    Thank you in advance!

    Leave a comment:


  • Mike6158
    replied
    My system stopped working. Probably due to a power failure (a UPS is probably a good idea). I connected it to a monitor and it boots but... and of course when I rebooted just now to see what was on the screen everything loaded. It appears to be working. It hasn't picked up any aircraft but there aren't any in range yet.

    Leave a comment:


  • abcd567
    replied
    Originally posted by fribse View Post
    But with this guide the dump1090 setup looks odd.
    Where is it I configure the center of the map, and the radius and zoom?
    Why it looks odd?
    To display station marker and 3 range rings on the dump1090 map, you have to add latitude & longitude in the field "Process arguments" (--lat xx.xxxx --lon yy.yyyy).

    This is shown in screeshot of settings page in following step:

    STEP-8: SETTINGS & CONFIGURATION
    Last edited by abcd567; 2020-02-15, 11:49.

    Leave a comment:


  • fribse
    replied
    Thankyou for this guide, works perfectly. I've reinstalled my card, to get a new clean install. But with this guide the dump1090 setup looks odd.
    Where is it I configure the center of the map, and the radius and zoom?

    Leave a comment:


  • Mike6158
    replied
    Originally posted by Oblivian View Post

    4 May still not work with the pi24 image (not sure if been updated) and needs more manual work. Those stats are fine, it will take some time to update online once it has a dataset.
    The 3B seems to be working fine (as you noted). I'll stick with that. The Pi4 I have is powered by USB-C, has built in WiFi, has heat sinks and fan (thanks to the case I bought for it), and is probably overkill for what I want to do. Thanks for your help

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Mike6158 View Post
    The Pi3B+ seems to be working

    [ ok ] FR24 Feeder/Decoder Process: running.

    [ ok ] FR24 Stats Timestamp: 2019-11-24 20:30:55.

    [ ok ] FR24 Link: connected [UDP].

    [ ok ] FR24 Radar: T-xxxx. I didn't know if this was something "secure" so I x'd out some of the info

    [ ok ] FR24 Tracked AC: 7.

    [ ok ] Receiver: connected (5661 MSGS/0 SYNC).

    [ ok ] FR24 MLAT: ok [UDP].

    [ ok ] FR24 MLAT AC seen: 7.

    I've searched and I don't see anything about using a PI4. It has built in WiFi and it would be pretty convenient to use.
    When I log into my account on FR24 there's nothing under backslash data-sharing.
    I haven't lost my key but I was going to double check it and the link in this thread to do that is dead, kind of like this thread seems to be.
    4 May still not work with the pi24 image (not sure if been updated) and needs more manual work. Those stats are fine, it will take some time to update online once it has a dataset.

    Leave a comment:


  • Mike6158
    replied
    The Pi3B+ seems to be working

    [ ok ] FR24 Feeder/Decoder Process: running.

    [ ok ] FR24 Stats Timestamp: 2019-11-24 20:30:55.

    [ ok ] FR24 Link: connected [UDP].

    [ ok ] FR24 Radar: T-xxxx. I didn't know if this was something "secure" so I x'd out some of the info

    [ ok ] FR24 Tracked AC: 7.

    [ ok ] Receiver: connected (5661 MSGS/0 SYNC).

    [ ok ] FR24 MLAT: ok [UDP].

    [ ok ] FR24 MLAT AC seen: 7.

    I've searched and I don't see anything about using a PI4. It has built in WiFi and it would be pretty convenient to use.
    When I log into my account on FR24 there's nothing under backslash data-sharing.
    I haven't lost my key but I was going to double check it and the link in this thread to do that is dead, kind of like this thread seems to be.

    Leave a comment:


  • Mike6158
    replied
    Unfortunately, although I have quite a few Raspberry Pi's (including but not currently using a Pi4 because I followed the instructions to make the card, whatever that's called, for a Pi3 and the Pi 4 doesn't work with that image), I always struggle with getting these things to work.

    This was a very helpful thread but after running fr24feed-status I see:
    ok
    ok
    ok
    ok
    ok
    ok
    FAIL FR24 MLAT is not running (yes I told it to use MLAT). I'm using the DVB-T from JetVision. It's got power. I used the SSH command with a Mac so that part was easy.
    I have gold membership but when I try to use the data sharing link (deleted link since I'm new here) I see nothing in data sharing.

    192.168.ccc.ccc:8754/settings.html connects and I see the note about running Pi3B+. I am using a B+. Network is hardwired since I can see the feeder settings and I see it from the router, the pi is connected.

    Any ideas why MLAT isn't running?

    I may have figured it out. I used the Activation ID for my sharing key. Those aren't the same. I need to figure out where my sharing key is...

    Edit... nope... I had already registered and my sharing key is correct

    Uh oh... Model B version 1.2. Apparently I ordered a B and a B+. The B+ is being used elsewhere. So... I either need to try to figure out how to make the Pi 4 work or swap the B+ into FlightRadar24
    Last edited by Mike6158; 2019-11-24, 18:49.

    Leave a comment:


  • orion_jb2001
    replied
    I am just about to hook up my odroid XU4 to flightradar24. Currently operating a FA piaware set up. Should I use the raspberry pi script as per FR24 other installs??

    Leave a comment:


  • uyaffe
    replied
    Thanks a lot for the tutorial.

    Leave a comment:


  • abcd567
    replied
    Steve N:

    Yes, it is possible.
    I am away from my computer, so whatever given below is by memory.
    I will check when I am at my Desktop, and edit if needed.

    In FR24 settings page
    IP-of-Pi:8754/settings.html
    In Process Arguments add:
    --net

    In VRS Settings
    Format: Beast
    Network: IP-of-Pi
    Port: 30005

    Leave a comment:


  • Steve N
    replied
    Thanks for the info, abcd567.
    Pi now up and running successfully.

    Is there a way to configure Virtual Radar Server on a Windows Laptop to track the aircraft you are feeding to FR24?

    Cheers,
    Steve

    Leave a comment:


  • cbehm
    replied
    Thank you!!

    Just wanted to say thank you I have been looking for this information for a long time. I appreciate you putting this all together!!

    Leave a comment:

Working...
X