Announcement

Collapse
No announcement yet.

I'm stumped- new Pi system

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I'm stumped- new Pi system

    I was a Windows feeder up until May 8th. I picked up a Kano computer kit (Raspberry Pi 3 Model B, case, power supply, 16GB MicroSD card and keyboard) for $35 on clearance from Walmart.

    Followed the instructions on the website. Downloaded and installed the Pi24 image on the card. Plugged in the USB ADSB dongle I have been using for the past 6 years, plugged in the ethernet cable to my router and powered up. Power appears to be on. Ethernet traffic lights on the router and the Pi suggest it is communicating fine. I checked my router and I can see the Pi at 192.168.254.11 on my local network.

    Ignore this:
    Only thing is in the instructions-

    "4. You should see a solid red LED, a blinking green one and as well as green and yellow Ethernet LEDs."

    The solid red, the green and yellow ethernet LEDs are all there, no blinking green one.

    Actually, editing this to say that the blinking green one is there, it was on the side away from me and doesn't flash continuously...

    I click the link on the instruction page and the next page comes up- "Activate new receiver".

    There is no receiver listed.

    I have no clues where to go from there. I have built my own PCs in the past and know how to force Windows to do my bidding, but Linux is a mystery to me, as is coding. I see people talk about SSH, but seriously it is all new to me.

    Can someone give me some hints? That a borderline non-techie can follow? I'm no Luddite, I have a Pixel 3 phone and 3 different PCs as well as running an online business but I am lost here.

    Thanks.

    Edited: More info...
    Last edited by madkiwi; 2019-06-01, 03:44.

  • #2
    First find your fr24 key.
    (1) Go to https://www.flightradar24.com/ and login to your account

    (2) After login, go to my data sharing page https://www.flightradar24.com/account/data-sharing

    (3) Copy your Windows feeder's ID from this page. See screenshot below

    FR24-Key.png

    (4) Go to this address in your browser and type this address

    ip-of-pi:8754/settings.html

    ip-of-pi is Pi's local network address it will be something like 192.168.0.21. You can find it from your router.

    Paste the fr24 key you have copied in the field named "Sharing key" of above page. Please see screenshot below (xxxxxxx is NOt actual key)
    Click Save button, then Restart button. Both button are on bottom-right corner of settings page.

    FR24 settings - Integral dump1090.png
    Last edited by abcd567; 2019-06-01, 05:56.

    Comment


    • #3
      Thank you for replying.

      Well I don't know what's going on now, my browser presents me with an Unable to connect message- Firefox can’t establish a connection to the server at 192.168.254.11:8754

      That is the IP address for my Pi, so maybe something went wrong with the Pi24 image write and it isn't booting? Besides the Pi24 image should there be anything else on the SD card?

      Thanks again,
      Mark

      Comment


      • #4
        You want etcher to write the image to the card.
        Can i assume you copied it onto it?

        https://www.balena.io/etcher/

        Comment


        • #5
          No, I used Win32DiskImager. It did the writing and appeared to be successful.

          Does the card need to be formatted in any particular way? I just left it with FAT32, is there something else I should have done? If I plug the card back into my Windows PC what should the contents look like? Just the pi24-2.1.0.img or will it be a bunch of folders and files?

          Thanks

          Comment


          • #6
            The imagers take care of writing the image.

            I'm not sure in Windows you will only see a boot partition i think.
            The main partition isn't visible in Windows.

            Please note the default credentials for SSH access to Raspberry Pi
            Username: pi
            Password: raspberry

            Get yourself putty: https://www.chiark.greenend.org.uk/~...ty/latest.html

            And connect via ssh and see if that works.
            Can you ping the IP-address?

            I'd recommend going with Raspbian Stretch Lite instead and installing FR24 via the script.
            But setting up Raspbian may be a little more complicated than just using the image.

            Comment


            • #7
              I had the router (?) change ip on my Pi yesterday.. check the router software. Was still feeding but couldn’t see anything in the browser.
              ENFB.net
              Radarstation KGVL

              Comment


              • #8
                Originally posted by madkiwi View Post
                No, I used Win32DiskImager. It did the writing and appeared to be successful.
                Does the card need to be formatted in any particular way? I just left it with FAT32, is there something else I should have done?
                The image writer (Win32diskimager or Etcher) take care of formatting. You dont have to do anything.


                Originally posted by madkiwi View Post
                If I plug the card back into my Windows PC what should the contents look like? Just the pi24-2.1.0.img or will it be a bunch of folders and files?
                Yes you will see a bunch of files and folder, but only those located in /boot folder. All other files and folders are not visible in Windows. Please see screenshot below:

                Pi24 image opened in Windows.png


                In case the issue remains unresolved, use Win32DiskImager and write Pi24 image again
                Last edited by abcd567; 2019-06-01, 18:49.

                Comment


                • #9
                  OK, tried more things. I was able to ping the Pi, but still wasn't working. I took the memory card out and re-imaged with Win32DiskImager. Then before I ejected it I had Win32DiskImager verify the files. All checked out. Used Windows Explorer and looked at the contents and it looked like the image above.

                  Got the Raspberry Pi fired up again and still won't connect or appear on the signup page. Downloaded and installed Putty.

                  Got connected, typed fr24feed-status

                  Here's what was returned- [FAIL] FR24 Feeder/Decoder Process ... failed!

                  I tried- sudo fr24feed --reconfigure

                  [main][i]FR24 Feeder/Decoder
                  [main][i]Version: 1.0.23-8/generic
                  [main][i]Built on Oct 11 2018 18:27:28 (HEAD-3c696a7.git/Linux/static_armel)
                  [main][i]Running on: pi24-raspbian9
                  [main][i]Local IP(s): 192.168.254.11
                  [main][i]Copyright 2012-2018 Flightradar24 AB
                  [main][i]https://www.flightradar24.com
                  [main][i]DNS mode: PING

                  Welcome to the FR24 Decoder/Feeder sign up wizard!

                  Before you continue please make sure that:

                  1 - Your ADS-B receiver is connected to this computer or is accessible over network
                  2 - You know your antenna's latitude/longitude up to 4 decimal points and the altitude in feet
                  3 - You have a working email address that will be used to contact you
                  4 - fr24feed service is stopped. If not, please run: sudo systemctl stop fr24feed

                  To terminate - press Ctrl+C at any point


                  Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):

                  1 - DVBT Stick (USB)
                  -----------------------------------------------------
                  2 - SBS1/SBS1er (USB/Network)
                  3 - SBS3 (USB/Network)
                  4 - ModeS Beast (USB/Network)
                  5 - AVR Compatible (DVBT over network, etc)
                  6 - microADSB (USB/Network)
                  7 - SBSx via Basestation (localhost:30006)


                  Enter your receiver type (1-7)$:1
                  Checking for dump1090...FOUND

                  Step 4.3 - Enter your additional dump1090 arguments or leave empty
                  $:

                  Step 5.1 - Would you like to enable RAW data feed on port 30002 (yes/no)$:yes

                  Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$:yes

                  Step 6A - Please select desired logfile mode:
                  0 - Disabled
                  1 - 48 hour, 24h rotation
                  2 - 72 hour, 24h rotation
                  Select logfile mode (0-2)$:1

                  Step 6B - Please enter desired logfile path (/var/log/fr24feed):
                  $:

                  Submitting form data...ERROR

                  Invalid email provided!

                  Would you like to try again?

                  Saving settings to /etc/fr24feed.ini...OK
                  Settings saved, please run "sudo systemctl restart fr24feed" to use new configuration.

                  So first thing I noticed is that it skipped over steps 1 through 3, didn't ask me for my email, sharing key or location.

                  I wish I knew what I was doing...

                  Mark

                  Comment


                  • #10
                    you can use
                    sudo fr24feed --signup

                    then it will ask for email as well.

                    Also note you might want to change the default password which is open for ssh.

                    just use the command
                    passwd

                    it will ask you old and new password.

                    I would also recommend installing a newer dump1090-fa version with better decoding and a map that's actually working:
                    https://github.com/wiedehopf/combine...ng-dump1090-fa
                    Last edited by wiedehopf; 2019-06-02, 06:27.

                    Comment


                    • #11
                      Success! Maybe?

                      So I started Putty, logged in to the Pi, typed fr24feed-status and got the same message as before.

                      [FAIL] FR24 Feeder/Decoder Process ... failed!

                      I then typed sudo fr24feed --signup

                      Entered my email, old sharing key and the location. This is what came up next-

                      Congratulations! You are now registered and ready to share ADS-D data with Flightradar24.
                      + Your radar id is T-KMSO9, please include it in all email communication with us.
                      + Please make sure to start sharing data within one month from now as otherwise your ID/KEY will be deleted.

                      Thank you for supporting Flightradar24! We hope that you will enjoy our Premium services that will be available to you when you become an active feeder.

                      To start sending data now please execute:
                      sudo systemctl start fr24feed

                      Saving settings to /etc/fr24feed.ini...OK
                      Settings saved, please run "sudo systemctl restart fr24feed" to use new configuration.
                      pi@raspberrypi:~ $ sudo systemctl start fr24feed

                      I then went over to FR24 and for the first time in 3 weeks it shows me as Online!!!!!

                      It shows that I have only reported 1 aircraft since starting (10 minutes) but according to the website I should be seeing at least 4 aircraft at the moment- with 2 literally flying right over us. Should I worry about it yet?

                      pi@raspberrypi:~ $ fr24feed-status
                      [ ok ] FR24 Feeder/Decoder Process: running.
                      [ ok ] FR24 Stats Timestamp: 2019-06-02 20:48:41.
                      [ ok ] FR24 Link: connected [UDP].
                      [ ok ] FR24 Radar: T-KMSO1.
                      [ ok ] FR24 Tracked AC: 1.
                      [ ok ] Receiver: connected (458 MSGS/0 SYNC).
                      [ ok ] FR24 MLAT: ok [UDP].
                      [ ok ] FR24 MLAT AC seen: 0.
                      pi@raspberrypi:~ $

                      Look good?

                      If I power this down will it start running FR24feed automatically when it gets powered up again?

                      Thanks for all your assistance- still don't understand why the auto-enroll didn't work. Is it something that can get screwed up by the browser? Or my router?

                      Comment


                      • #12
                        CONGRATULATIONS

                        Dont worry about number of planes shown on FR24 is less than shown by fr24feed-status command. This normal.

                        Yes, whenever you restart/powerup your Pi, fr24feed will automatically start. You dont have to do anything to start it.

                        Did you check the map in browser at following address?

                        IP-of-Pi/dump1090/

                        .
                        You should now concentrate on antenna location and type of antenna. Where is your antenna located, and what type of antenna you have?

                        .

                        Comment


                        • #13
                          Oh, my antenna and location sucks. Problem is my router is in our basement and I am using one of those magnetic antennas that came with the USB stick, it is technically underground. I explored the idea of installing an antenna on the roof and drilling a lot of holes to run the cable but the wife vetoed that...

                          I plan on moving the Raspberry Pi to our 2nd home 20 miles away. In that home the router is on the 2nd floor and I have some flexibility on antenna positions.

                          Cheers,

                          Mark

                          Comment


                          • #14
                            That's like expecting to have WiFi reception when the router is placed 50 m above your house

                            No seriously, attic or window is the minimum for some form of reasonable reception.

                            Apropos WiFi, don't you have that? Placing the Rpi and antenna in the attic is a good solution.
                            But that depends on the insulation as well, if it has metallic foil that can be a problem as well.
                            (antenna on the roof is better obviously but you can't have everything)

                            Also give this a read: https://forum.flightradar24.com/thre...h-DVB-T-Dongle
                            Last edited by wiedehopf; 2019-06-03, 04:14.

                            Comment


                            • #15
                              Why not locate Pi in ground floor or 1st floor, and run a network cable between Pi and the router?

                              Comment

                              Working...
                              X