Announcement

Collapse
No announcement yet.

Problem installing Raspberry FR24 image

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    You're running it a second time. So errors.

    If the status is good, it's hidden and running in the background already

    Sent from my EML-L09 using Tapatalk

    Leave a comment:


  • LN-MOW
    replied
    I'm getting planes, I think. All is green.

    FR24 Link: Connected via UDP
    FR24 Radar Code: T-KGVL5
    Local IP(s): 192.168.1.25
    Aircraft Tracked:
    (ModeS & ADS-B) 26
    Aircraft Uploaded: 17
    Receiver: dvbt, Connected
    MLAT running: N/A

    However, when running SUDO FR24FEED I get this in a loop .. Any idea why?

    2019-05-14 00:03:05 | [reader][i]Connecting to DVBT receiver via (exe:///usr/bin/dump1090-mutability --raw)
    2019-05-14 00:03:05 | [reader][i]Connected to the receiver, configuring
    2019-05-14 00:03:05 | [reader][i]Configured, processing messages
    Tue May 14 00:03:05 2019 UTC dump1090-mutability v1.14 starting up.
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
    usb_claim_interface error -6
    Error opening the RTLSDR device: Device or resource busy
    2019-05-14 00:03:05 | [reader][i]Connection terminated
    2019-05-14 00:03:05 | [main][i]Terminating child process 1110 with SIGTERM

    Leave a comment:


  • wiedehopf
    replied
    That's the connection to FR24, doesn't necessarily means you are receiving any airplanes.

    Leave a comment:


  • LN-MOW
    replied
    Restored it back, and it seems to do better.

    At least I’m learning something. Pi was absolutly greek to me until yesterday ..

    Leave a comment:


  • Oblivian
    replied
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    - Dump1090 not actually running / unstable
    (Possible SDR device blacklist issue or not present)
    - Feeder cannot upload to server
    Still need to stop service and run with full screen output and monitor it.

    Leave a comment:


  • wiedehopf
    replied
    It seems that there is a problem with dos line endings, do the following:

    sudo nano /etc/fr24feed.ini

    Ctrl-o and enter to save, then Ctrl-x to exit.

    sudo systemctl restart fr24feed

    This should fix the line endings
    Last edited by wiedehopf; 2019-05-13, 22:02.

    Leave a comment:


  • LN-MOW
    replied
    Originally posted by wiedehopf View Post
    Try this:

    Code:
    sudo echo -e 'use-http=yes\nhttp-timeout=20' >> /etc/fr24feed.ini
    sudo systemctl restart fr24feed
    This will add
    use-http=yes
    http-timeout=20
    to your settings.

    This often helps with the typical intermittent pattern you have.
    Thanks but all it did was stop the uploads ...

    Aircraft Tracked:
    (ModeS & ADS-B) 0
    Aircraft Uploaded: N/A

    Leave a comment:


  • wiedehopf
    replied
    Try this:

    Code:
    sudo echo -e 'use-http=yes\nhttp-timeout=20' >> /etc/fr24feed.ini
    sudo systemctl restart fr24feed
    This will add
    use-http=yes
    http-timeout=20
    to your settings.

    This often helps with the typical intermittent pattern you have.

    Leave a comment:


  • LN-MOW
    replied
    Originally posted by wiedehopf View Post
    do the following:

    sudo systemctl stop fr24feed

    sudo fr24feed

    And check the output of that.

    Regarding your station not being visible, did you enter the mail address correctly?
    You can also rerun the process where the mail address is required with
    sudo fr24feed --signup

    use the command:
    cat /etc/fr24feed.ini

    to check your settings
    if you didn't install dump1090 separately then the receiver-type should be set to dvb-t
    Thanks. Changed to dvb-t and it came up - somewhat.

    I did sudo fr24feed earlier, and it wouldn't connect to server. It's still very unstable when I look at the stats page. So something isn't right.



    I used my original sharing code as I have been a feeder for years, so my user is known.

    Now getting 'Device or resource busy' ... Is the problem on FR24's end?
    Last edited by LN-MOW; 2019-05-13, 19:43.

    Leave a comment:


  • wiedehopf
    replied
    do the following:

    sudo systemctl stop fr24feed

    sudo fr24feed

    And check the output of that.

    Regarding your station not being visible, did you enter the mail address correctly?
    You can also rerun the process where the mail address is required with
    sudo fr24feed --signup

    use the command:
    cat /etc/fr24feed.ini

    to check your settings
    if you didn't install dump1090 separately then the receiver-type should be set to dvb-t
    Last edited by wiedehopf; 2019-05-13, 18:22.

    Leave a comment:


  • LN-MOW
    replied
    OK, so I chose another signup method found on the forum. Followed the instructions and entered my sharing key and all is well. Almost. The process changed my location code. However it is not visible on my page and when i enter status command, I get ... HELP!

    It does show online on the stat-page, though ....


    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-05-13 14:42:08.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-KGVL5.
    [ ok ] FR24 Tracked AC:.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!
    pi@raspberrypi:~ $
    Last edited by LN-MOW; 2019-05-13, 14:49.

    Leave a comment:


  • LN-MOW
    started a topic Problem installing Raspberry FR24 image

    Problem installing Raspberry FR24 image

    Can't find a solution in the foum, so trying a new post. I'm not very competent on Pi ..

    I bought a Vilros Pi and a stick as my old feeder no longer works. Installed the image on a 32gb miniSD according to instructions. Hooked everything up.
    The Pi is now connected to LAN and will change to WLAN.

    Found the Pi on the network and connected via Putty - no problem.

    However when trying to activate the unit, it is not visible on the FR24 page. Tried to run the command under the 'instructions' - no luck. Here is the response. Looks to me like the problem is with the FR24 keyserver?



    login as: pi
    pi@192.168.1.30's password:
    Linux raspberrypi 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l
    ______ _ _ _ _ _ _____ ___
    | ___|| |(_) | | | | | | / __ \ / |
    | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
    | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
    | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
    \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
    __/ |
    |___/

    a new password.

    pi@raspberrypi:~ $ raspi-config
    Script must be run as root. Try 'sudo raspi-config'
    pi@raspberrypi:~ $ sudo raspi-config
    OK
    pi@raspberrypi:~ $ sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    --2019-05-13 13:06:20-- http://repo.feed.flightradar24.com/install_fr24_rpi.sh
    Resolving repo.feed.flightradar24.com (repo.feed.flightradar24.com)... 52.216.234.45
    Connecting to repo.feed.flightradar24.com (repo.feed.flightradar24.com)|52.216.234.45|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1281 (1.3K) [application/x-sh]
    Saving to: ‘STDOUT’

    - 100%[================================================== ================================================== ====================================>] 1.25K --.-KB/s in 0s

    2019-05-13 13:06:20 (44.4 MB/s) - written to stdout [1281/1281]

    Get:1 http://repo.feed.flightradar24.com flightradar24 InRelease [13.0 kB]
    Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
    Get:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
    Get:4 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages [606 B]
    Get:5 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
    Get:6 http://archive.raspberrypi.org/debian stretch/main armhf Packages [221 kB]
    Get:7 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [45.0 kB]
    Get:8 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages [95.5 kB]
    Fetched 12.1 MB in 11s (1,020 kB/s)
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
    gnupg gnupg-agent
    Suggested packages:
    tor parcimonie xloadimage scdaemon
    Recommended packages:
    gnupg-l10n
    The following packages will be upgraded:
    dirmngr gnupg gnupg-agent
    3 upgraded, 0 newly installed, 0 to remove and 85 not upgraded.
    Need to get 2,069 kB of archives.
    After this operation, 5,120 B of additional disk space will be used.
    Get:1 http://mirror.umd.edu/raspbian/raspbian stretch/main armhf dirmngr armhf 2.1.18-8~deb9u4 [547 kB]
    Get:2 http://mirror.umd.edu/raspbian/raspbian stretch/main armhf gnupg-agent armhf 2.1.18-8~deb9u4 [499 kB]
    Get:3 http://mirror.umd.edu/raspbian/raspbian stretch/main armhf gnupg armhf 2.1.18-8~deb9u4 [1,023 kB]
    Fetched 2,069 kB in 2s (950 kB/s)
    apt-listchanges: Reading changelogs...
    (Reading database ... 52837 files and directories currently installed.)
    Preparing to unpack .../dirmngr_2.1.18-8~deb9u4_armhf.deb ...
    Unpacking dirmngr (2.1.18-8~deb9u4) over (2.1.18-8~deb9u2) ...
    Preparing to unpack .../gnupg-agent_2.1.18-8~deb9u4_armhf.deb ...
    Unpacking gnupg-agent (2.1.18-8~deb9u4) over (2.1.18-8~deb9u2) ...
    Setting up gnupg-agent (2.1.18-8~deb9u4) ...
    (Reading database ... 52837 files and directories currently installed.)
    Preparing to unpack .../gnupg_2.1.18-8~deb9u4_armhf.deb ...
    Unpacking gnupg (2.1.18-8~deb9u4) over (2.1.18-8~deb9u2) ...
    Setting up gnupg (2.1.18-8~deb9u4) ...
    Processing triggers for install-info (6.3.0.dfsg.1-1+b1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up dirmngr (2.1.18-8~deb9u4) ...
    Executing: /tmp/apt-key-gpghome.MglGWyLWmp/gpg.1.sh --recv-key --keyserver pool.sks-keyservers.net 40C430F5
    gpg: keyserver receive failed: Server indicated a failure
    Executing: /tmp/apt-key-gpghome.CeuxgS44Xq/gpg.1.sh --recv-key --keyserver pgp.mit.edu 40C430F5
    gpg: keyserver receive failed: Server indicated a failure
    pi@raspberrypi:~ $
Working...
X