Announcement

Collapse
No announcement yet.

DD-WRT direct Feeding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Did you update dump1090 as well?
    Maybe it doesn't like the old configuration file.

    As far as i see, it should work using port 30005 and beast-tcp

    Your fr24feed.ini should look like this:
    Code:
    receiver="beast-tcp"
    fr24key="xxxxxxxxxxxxxxxx"
    host="127.0.0.1:30005"
    If you are really on a remote IP you should change the 127.0.0.1 of course.
    Don't forget to restart fr24feed after making changes.

    Check if those settings work and if they don't continue with deleting the dump1090 configuration.
    Then you can use
    sudo dpkg-reconfigure dump1090
    to create a new config file. (you can probably leave pretty much everything default)
    Last edited by wiedehopf; 2019-05-09, 21:40.

    Comment


    • #17
      Originally posted by wiedehopf View Post
      Did you update dump1090 as well?
      Maybe it doesn't like the old configuration file.

      As far as i see, it should work using port 30005 and beast-tcp

      Your fr24feed.ini should look like this:
      Code:
      receiver="beast-tcp"
      fr24key="xxxxxxxxxxxxxxxx"
      host="127.0.0.1:30005"
      If you are really on a remote IP you should change the 127.0.0.1 of course.
      Don't forget to restart fr24feed after making changes.

      Check if those settings work and if they don't continue with deleting the dump1090 configuration.
      Then you can use
      sudo dpkg-reconfigure dump1090
      to create a new config file. (you can probably leave pretty much everything default)
      I am not on the same machine where the dump runs, and it still fails.
      Here is the current log:
      2019-05-09 23:47:45 | [main][i]FR24 Feeder/Decoder
      2019-05-09 23:47:45 | [main][i]Version: 1.0.18-5/generic
      2019-05-09 23:47:45 | [main][i]Built on Mar 4 2016 16:26:55 (devel-d11ca48.git/Linux/x86_64)
      2019-05-09 23:47:45 | [main][i]Copyright 2012-2016 Flightradar24 AB
      2019-05-09 23:47:45 | [main][i]http://flightradar24.com
      2019-05-09 23:47:45 | [main][i]DNS mode: LIBC
      2019-05-09 23:47:45 | [main][i]Automatic updates are DISABLED
      2019-05-09 23:47:45 | [httpd][i]Server started, listening on 0.0.0.0:8754
      2019-05-09 23:47:45 | [main][i]Reader thread started
      2019-05-09 23:47:45 | [time][i]Synchronizing time via NTP
      2019-05-09 23:47:45 | [master][i]Starting processing thread
      2019-05-09 23:47:45 | [reader][i]Initializing reader
      2019-05-09 23:47:45 | [reader][i]Connecting to Beast receiver via (tcp://<router ip>:30005)
      2019-05-09 23:47:45 | [reader][i]Connected to the receiver, configuring
      2019-05-09 23:47:45 | [reader][i]Configured, processing messages
      2019-05-09 23:47:46 | [reader][w]Setting new UTC offset: 0!
      2019-05-09 23:47:47 | [time][i]Time synchronized correctly, offset +0.0001 seconds
      2019-05-09 23:47:47 | [main][i]Feed Network client started
      2019-05-09 23:47:47 | [feed][i]Downloading configuration
      2019-05-09 23:47:47 | [feed][i]Failed on start, Sleeping 120 seconds

      more /etc/fr24feed.ini
      receiver="beast-tcp"
      fr24key="<key>"
      host="federbear.noip.me:30005"
      bs="no"
      raw="no"
      logmode="1"
      mlat="no"
      mlat-without-gps="no"
      T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

      My photos - Planespotters
      My photos - Jetphotos

      Comment


      • #18
        Edit:

        Nevermind the connection to dump1090 is working fine, it just doesn't want to connect to fr24.

        Maybe they killed off all the old versions.

        Can you recheck your feed key here:
        https://www.flightradar24.com/account/data-sharing
        Last edited by wiedehopf; 2019-05-09, 21:55.

        Comment


        • #19
          Originally posted by wiedehopf View Post
          Yeah as i wrote above, maybe dump1090 is not even starting for some reason, like the config file being meant for a much earlier version?
          Dump is running. I see the map. It shows the planes and if I start in the console, and it is not running as service, I see it writes a lot of messages about planes. I think It is a problem somewhere in the fr24feed that can not connect to the fr24 server. Perhaps it can not log in or something else. since it writes [reader][i]Configured, processing messages
          T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

          My photos - Planespotters
          My photos - Jetphotos

          Comment


          • #20
            I seems you don't have a log file configured but logmode is still 1.

            Maybe just try this config (adapting the key and IP)
            This config also uses use-http which can sometimes fix connection errors.

            Code:
            receiver="beast-tcp"
            fr24key="xxxxxxxxxxxxxxxx"
            host="127.0.0.1:30005"
            bs="no"
            raw="no"
            logmode="0"
            logpath="/var/log/fr24feed"
            mlat="no"
            mlat-without-gps="no"
            use-http=yes
            http-timeout=20

            Comment


            • #21
              Originally posted by wiedehopf View Post
              I seems you don't have a log file configured but logmode is still 1.

              Maybe just try this config (adapting the key and IP)
              This config also uses use-http which can sometimes fix connection errors.

              Code:
              receiver="beast-tcp"
              fr24key="xxxxxxxxxxxxxxxx"
              host="127.0.0.1:30005"
              bs="no"
              raw="no"
              logmode="0"
              logpath="/var/log/fr24feed"
              mlat="no"
              mlat-without-gps="no"
              use-http=yes
              http-timeout=20
              2019-05-09 23:59:13 | [main][i]FR24 Feeder/Decoder
              2019-05-09 23:59:13 | [main][i]Version: 1.0.18-5/generic
              2019-05-09 23:59:13 | [main][i]Built on Mar 4 2016 16:26:55 (devel-d11ca48.git/Linux/x86_64)
              2019-05-09 23:59:13 | [main][i]Copyright 2012-2016 Flightradar24 AB
              2019-05-09 23:59:13 | [main][i]http://flightradar24.com
              2019-05-09 23:59:13 | [main][i]DNS mode: LIBC
              2019-05-09 23:59:13 | [main][i]Automatic updates are DISABLED
              2019-05-09 23:59:13 | [httpd][i]Server started, listening on 0.0.0.0:8754
              2019-05-09 23:59:13 | [main][i]Reader thread started
              2019-05-09 23:59:13 | [time][i]Synchronizing time via NTP
              2019-05-09 23:59:13 | [master][i]Starting processing thread
              2019-05-09 23:59:13 | [reader][i]Initializing reader
              2019-05-09 23:59:13 | [reader][i]Connecting to Beast receiver via (tcp://federbear.noip.me:30005)
              2019-05-09 23:59:14 | [reader][i]Connected to the receiver, configuring
              2019-05-09 23:59:14 | [reader][i]Configured, processing messages
              2019-05-09 23:59:16 | [time][i]Time synchronized correctly, offset +0.0003 seconds
              2019-05-09 23:59:16 | [main][i]Feed Network client started
              2019-05-09 23:59:16 | [feed][i]Downloading configuration
              2019-05-09 23:59:16 | [feed][i]Failed on start, Sleeping 120 seconds
              2019-05-09 23:59:17 | [reader][w]Setting new UTC offset: 0!

              Just a question. Where it should save information that I wrote during the --signup process?...If it saves something at all. I do not think of the ini file now. It asked me about my email.
              T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

              My photos - Planespotters
              My photos - Jetphotos

              Comment


              • #22
                Just tested the x86_64 version, it's working fine for me:

                2019-05-10 00:01:10 | [main][i]Version: 1.0.18-5/generic

                Code:
                2019-05-10 00:01:11 | [reader][i]Configured, processing messages
                2019-05-10 00:01:11 | [reader][w]Setting new UTC offset: 0!
                2019-05-10 00:01:12 | [time][i]Synchronizing time via NTP
                2019-05-10 00:01:15 | [time][i]Time synchronized correctly, offset -0.0003 seconds
                2019-05-10 00:01:15 | [main][i]Feed Network client started
                2019-05-10 00:01:15 | [feed][i]Downloading configuration

                Comment


                • #23
                  Just a question. Where it should save information that I wrote during the --signup process?...If it saves something at all. I do not think of the ini file now.
                  All information is saved in /etc/fr24feed.ini

                  That's where it should also save the key you get during signup.

                  You should make it writeable for everyone:

                  sudo chmod a+w /etc/fr24feed.ini

                  If you already have a feed key you can just use that and the signup isn't really required.

                  Comment


                  • #24
                    Originally posted by wiedehopf View Post
                    All information is saved in /etc/fr24feed.ini

                    That's where it should also save the key you get during signup.

                    You should make it writeable for everyone:

                    sudo chmod a+w /etc/fr24feed.ini
                    777 but it does not help. Does the feeder require any other file that should be installed correctly? I use it as a standalone command file.
                    T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

                    My photos - Planespotters
                    My photos - Jetphotos

                    Comment


                    • #25
                      Have you checked for the key here: https://www.flightradar24.com/account/data-sharing

                      Did the signup write a key to /etc/fr24feed.ini ?

                      As far as i see it should work.

                      Did you try the http option?

                      Comment


                      • #26
                        Originally posted by wiedehopf View Post
                        Have you checked for the key here: https://www.flightradar24.com/account/data-sharing

                        Did the signup write a key to /etc/fr24feed.ini ?

                        As far as i see it should work.

                        Did you try the http option?
                        I tried that you wrote.
                        receiver="beast-tcp"
                        fr24key="<key>"
                        host="<router ip>:30005"
                        bs="no"
                        raw="no"
                        logmode="0"
                        logpath="/var/log/fr24feed"
                        mlat="no"
                        mlat-without-gps="no"
                        use-http=yes
                        http-timeout=20

                        I rerun the signup again and it found my setup correct:

                        fr24feed_x64 --signup
                        [main][i]FR24 Feeder/Decoder
                        [main][i]Version: 1.0.18-5/generic
                        [main][i]Built on Mar 4 2016 16:26:55 (devel-d11ca48.git/Linux/x86_64)
                        [main][i]Copyright 2012-2016 Flightradar24 AB
                        [main][i]http://flightradar24.com
                        [main][i]DNS mode: LIBC

                        Welcome to the FR24 Decoder/Feeder sign up wizard!

                        Before you continue please make sure that:

                        1 - Your ADS-B receiver is connected to this computer or is accessible over network
                        2 - You know your antenna's latitude/longitude up to 4 decimal points and the altitude in feet
                        3 - You have a working email address that will be used to contact you
                        4 - fr24feed service is stopped. If not, please run: sudo service fr24feed stop

                        To terminate - press Ctrl+C at any point


                        Step 1.1 - Enter your email address (username@domain.tld)
                        $:<email>

                        Step 1.2 - If you used to feed FR24 with ADS-B data before enter your sharing key.
                        If you don't remember your sharing key, pelase use the retrival form:
                        http://feed.flightradar24.com/forgotten_key.php

                        Otherwise leave this field empty and continue.
                        $:<key>

                        Verifying sharing key...OK



                        Step 1.3 - Would you like to participate in MLAT calculations? (yes/no)$:no

                        Step 4.1 - Receiver selection:

                        1 - DVBT Stick (USB)
                        -----------------------------------------------------
                        2 - SBS1/SBS1er (USB/Network)
                        3 - SBS3 (USB/Network)
                        4 - ModeS Beast (USB/Network)
                        5 - AVR Compatible (DVBT over network, etc)
                        6 - microADSB (USB/Network)
                        7 - SBSx via Basestation (localhost:30006)


                        Enter your receiver type (1-7)$:4

                        Step 4.2 - Please select connection type:

                        1 - Network connection
                        2 - USB directly to this computer

                        Enter your connection type (1-2)$:1

                        Step 4.3A - Please enter your receiver's IP address/hostname
                        $:<router ip>

                        Step 4.3B - Please enter your receiver's data port number
                        $:30005

                        Step 5.1 - Would you like to enable RAW data feed on port 30334 (yes/no)$:no

                        Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$:no

                        Step 6A - Please select desired logfile mode:
                        0 - Disabled
                        1 - 48 hour, 24h rotation
                        2 - 72 hour, 24h rotation
                        Select logfile mode (0-2)$:0

                        Step 6B - Please enter desired logfile path (/var/log):
                        $:/var/log/fr24feed

                        Saving settings to /etc/fr24feed.ini...OK
                        Settings saved, please run "sudo service fr24feed restart" to use new configuration.
                        T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

                        My photos - Planespotters
                        My photos - Jetphotos

                        Comment


                        • #27
                          Yeah i'm at a loss, sorry.

                          The config i just posted works for me with the x86_64 binary fr24feed.

                          Comment


                          • #28
                            Originally posted by wiedehopf View Post
                            Yeah i'm at a loss, sorry.

                            The config i just posted works for me with the x86_64 binary fr24feed.
                            Thx. I will continue this tomorrow afternoon, but today I have no idea....
                            T-ENGM162 ex T-ENHA4, T-ENGM86, T-LHBP22

                            My photos - Planespotters
                            My photos - Jetphotos

                            Comment


                            • #29
                              Time to send the message to support and ask what the cause may be.
                              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                              Comment


                              • #30
                                I just started successfully feeding with your beast input
                                So it's not the dump1090, somehow the signup must not have worked correctly.

                                Have you checked this page? https://www.flightradar24.com/account/data-sharing

                                Comment

                                Working...
                                X