Announcement

Collapse
No announcement yet.

FR24 - adding Flightaware data feed doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24 - adding Flightaware data feed doesn't work

    OK - so I've got my FR24 image running fine on a RPi (just waiting to install a better - outdoor - antenna). And I have a separate SD card with Piaware image which also works as it should. I would like to feed both FR24 and Flightaware simultaneously so I have added the Piaware feed package to FR24 - but I'm at a loss to get it to run. How do I do this?

    Mike

  • #2
    Easier to start with the piaware image.

    There are guides how to configure all the stuff here:
    https://forum.flightradar24.com/thre...ll=1#post64528

    Comment


    • #3
      @ mhl

      If on your PI24 image you have already installed PiAware data feeder (Step 2 ONLY at this page (click here)), and want to transfer your current station number, then you have to:

      (1) Logg-in to your Flightaware account, and find your existing feeder id from your "My ADSB" page (Click here) on Flightaware.

      (2) Add it to PiAware by following command:
      Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by your actual 32-charactor feeder-id (Unique Identifier) you found from your "My ADSB" page of Flightaware.

      Code:
      sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx   
      sudo systemctl restart piaware

      If you want to get a brand new station number, go to this page while logged in to your Flightaware account:
      https://flightaware.com/adsb/piaware/claim
      Last edited by abcd567; 2019-05-04, 20:46.

      Comment


      • #4
        Thanks wiedehopf and abcd567. I've tried both your suggestions but it seems that the second feeder doesn't work in either case -

        - with FR24 feeder added to the Piaware image, my Flightaware ADS-B stats confirm Piaware is running fine, but FR24 does not show my local traffic - so I assume fr24feed is not running

        - with Piaware feeder added to the FR24 image, FR24 clearly displays my local traffic, but I can see that my Flightaware ADS-B stats are now zero and opening a web page to my RPi IP address confirms Piaware isn't running

        I'm sure I must be missing some simple step - can you suggest what it might be?

        Comment


        • #5
          Originally posted by mhl View Post
          - with FR24 feeder added to the Piaware image, my Flightaware ADS-B stats confirm Piaware is running fine, but FR24 does not show my local traffic - so I assume fr24feed is not running
          In that case what is your fr24feed.ini?
          cat /etc/fr24feed.ini

          This is a version of the fr24feed.ini settings that works with piaware:
          Code:
          receiver="beast-tcp"
          fr24key="xxxxxxxxxxxxxxxx"
          host="127.0.0.1:30005"
          bs="no"
          raw="no"
          logmode="1"
          logpath="/var/log/fr24feed"
          mlat="yes"
          mlat-without-gps="yes"
          use-http=yes
          http-timeout=20
          Make sure you use those settings and restart fr24feed:
          sudo systemctl restart fr24feed

          Anyway what do you mean with "but FR24 does not show my local traffic"
          (where are you checking)

          Comment


          • #6
            Thanks again wiedehopf - your fr24feed.ini settings have fixed the problem. The receiver setting and the host port were incorrect, and the last two lines missing - now sorted.

            I'm checking for my local traffic on a networked PC browser at the FR24 website (radar view), with Local Traffic selected under Settings - they appear as red targets (before the edit to fr24feed.ini no such targets appeared). Also my FR24 ADS-B stats page is showing activity again.

            Comment


            • #7
              Last two lines are optional but fix intermittent connections that sometimes occur.

              Glad it's working now.

              Comment

              Working...
              X