Announcement

Collapse
No announcement yet.

Dump1090 mutability 1-15 on Mint linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wiedehopf
    replied
    Upgrading might help as well.

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade

    Edit: Oh gamin is not a webserver, i just assumed
    Linked library fun!
    Last edited by wiedehopf; 2019-04-06, 11:28.

    Leave a comment:


  • Oblivian
    replied
    Mint right?

    It's disto specific https://bugs.launchpad.net/ubuntu/+s...d/+bug/1453463

    Try installing gamin as mentioned there

    Sent from my EML-L09 using Tapatalk

    Leave a comment:


  • Space Pilot
    replied
    ...about 4 times per second:

    Apr 05 20:27:07 T510 systemd[1]: Starting Lighttpd Daemon...
    Apr 05 20:27:07 T510 lighttpd[2686]: /usr/sbin/lighttpd: Symbol `FamErrlist' has different size in shared object, consider re-linking
    Apr 05 20:27:07 T510 lighttpd[2686]: /usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists
    Apr 05 20:27:07 T510 systemd[1]: lighttpd.service: Control process exited, code=exited status=127
    Apr 05 20:27:07 T510 systemd[1]: lighttpd.service: Failed with result 'exit-code'.
    Apr 05 20:27:07 T510 systemd[1]: Failed to start Lighttpd Daemon.
    Apr 05 20:27:07 T510 systemd[1]: lighttpd.service: Service hold-off time over, scheduling restart.
    Apr 05 20:27:07 T510 systemd[1]: lighttpd.service: Scheduled restart job, restart counter is at 1.
    Apr 05 20:27:07 T510 systemd[1]: Stopped Lighttpd Daemon.
    Apr 05 20:27:07 T510 systemd[1]: Starting Lighttpd Daemon...
    What is FAMNoExists ?

    root@T510:/etc/lighttpd# ls /etc/lighttpd/conf-enabled
    89-dump1090.conf
    root@T510:/etc/lighttpd#
    Last edited by Space Pilot; 2019-04-06, 09:54.

    Leave a comment:


  • wiedehopf
    replied
    journalctl -u lighttpd

    This should show possible errors.

    ls /etc/lighttpd/conf-enabled

    This shows you which configurations are enabled.

    Leave a comment:


  • Space Pilot
    replied
    yeah, I recall the good old times...

    But as Google Maps is no longer for free I wanted to switch to Open Street Map. Thats why I installed dump1090-mutability.

    Well, it seems lighttpd is not working
    Last edited by Space Pilot; 2019-04-06, 09:25.

    Leave a comment:


  • abcd567
    replied
    The localhost:8080 originated in dump1090 Malcolm Robb which used its internal webserver instead of lighttpd.

    For a long period, dump1090 MR was in Pi24 as well as installed by fr24feed when receiver=dvbt was set.

    Leave a comment:


  • wiedehopf
    replied
    Don't know where you picked up 8080, that is only the default for dump1090-fa i believe.
    Try here:
    http://localhost/dump1090/

    Leave a comment:


  • Space Pilot
    replied
    I can't see a website under http://localhost:8080 - how can I tell dump1090-mutability is working?

    Leave a comment:


  • Space Pilot
    replied
    oh, I see, thanks again. Will set up the wireless hardware now :-)

    Leave a comment:


  • wiedehopf
    replied
    You don't need a signed package for a local install.

    Signing is for verifying cryptographically that the package comes from debian when the package is distributed via apt.

    Leave a comment:


  • Space Pilot
    replied
    That worked, thanks a lot!

    Just one little thing: dpkg-buildpackage: Warning: UNRELEASED build not signed; use --force-sign to override

    I tried to build again with --force-sign

    dpkg-buildpackage: Error: Signing .buildinfo-File failed
    Last edited by Space Pilot; 2019-04-05, 21:01.

    Leave a comment:


  • abcd567
    replied
    (1) Edit file debian/rules and disabled dh_shlibdeps:
    Code:
    cd dump1090 
    
    sudo nano debian/rules 
    
    # In file debian/rules, the last two lines are:
    
    %: 
            dh $@ --with=systemd 
    
    #Below last line, add following two lines, then Save & Close file:
    
    override_dh_shlibdeps: 
            dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
    Note: Indenting of last line (which starts with dh_shlibdeps) to be done by pressing Tab key

    (2) Run build command:
    Code:
    dpkg-buildpackage -b -d
    Last edited by abcd567; 2019-04-05, 20:37.

    Leave a comment:


  • wiedehopf
    replied
    If you use a self compiled library you'll have to override the dependency checks.

    Try this command before starting the build:
    Code:
    export DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info
    Or you can uninstall the local library you installed.

    Leave a comment:


  • Space Pilot
    replied
    No luck so far...

    Step 4:
    ...
    sudo dpkg-buildpackage -b

    dpkg-shlibdeps: Fehler: keine Abhängigkeitsinformationen für /usr/local/lib/librtlsdr.so.0 (verwendet von debian/dump1090-mutability/usr/bin/dump1090-mutability) gefunden

    which more or less translates to

    "Error: No dependency information found for /usr/local/lib/librtlsdr.so.0 (used by debian / dump1090-mutability / usr / bin / dump1090-mutability)"

    I don't have my dpkg-shlibdeps manpages handy - can anybody help me please?

    TIA
    SpacePilot
    Last edited by Space Pilot; 2019-04-05, 19:07.

    Leave a comment:


  • Space Pilot
    replied
    I thought so, thanks for confirmation. Dump1090-mutability on my laptop is just for experimentation (different RF hardware setups, Open Street Map). Later I'll install the FR24 feeder on a Raspberry Pi.

    Thank you very much!

    SpacePilot
    Last edited by Space Pilot; 2019-04-05, 18:57.

    Leave a comment:

Working...
X