Announcement

Collapse
No announcement yet.

Dump1090 mutability 1-15 on Mint linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dump1090 mutability 1-15 on Mint linux

    I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

    Thanks,
    SpacePilot

  • #2
    Originally posted by Space Pilot View Post
    I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

    Thanks,
    SpacePilot
    Should work in principal.

    You can't install the fr24feed pi version which is mentioned in this thread.
    But compiling and installing dump1090 should be more or less the same no matter the system (that is if you have apt-get, which Mint apparently has)

    Comment


    • #3
      Originally posted by Space Pilot View Post
      I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

      Thanks,
      SpacePilot
      Originally posted by wiedehopf View Post
      Should work in principal.

      You can't install the fr24feed pi version which is mentioned in this thread.
      But compiling and installing dump1090 should be more or less the same no matter the system (that is if you have apt-get, which Mint apparently has)
      To install FR24 feeder on Lnux Mint installed on Laptop, follow the instructions here:

      https://forum.flightradar24.com/thre...l=1#post116967


      .

      Comment


      • #4
        I thought so, thanks for confirmation. Dump1090-mutability on my laptop is just for experimentation (different RF hardware setups, Open Street Map). Later I'll install the FR24 feeder on a Raspberry Pi.

        Thank you very much!

        SpacePilot
        Last edited by Space Pilot; 2019-04-05, 18:57.

        Comment


        • #5
          No luck so far...

          Step 4:
          ...
          sudo dpkg-buildpackage -b

          dpkg-shlibdeps: Fehler: keine Abhängigkeitsinformationen für /usr/local/lib/librtlsdr.so.0 (verwendet von debian/dump1090-mutability/usr/bin/dump1090-mutability) gefunden

          which more or less translates to

          "Error: No dependency information found for /usr/local/lib/librtlsdr.so.0 (used by debian / dump1090-mutability / usr / bin / dump1090-mutability)"

          I don't have my dpkg-shlibdeps manpages handy - can anybody help me please?

          TIA
          SpacePilot
          Last edited by Space Pilot; 2019-04-05, 19:07.

          Comment


          • #6
            If you use a self compiled library you'll have to override the dependency checks.

            Try this command before starting the build:
            Code:
            export DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info
            Or you can uninstall the local library you installed.

            Comment


            • #7
              (1) Edit file debian/rules and disabled dh_shlibdeps:
              Code:
              cd dump1090 
              
              sudo nano debian/rules 
              
              # In file debian/rules, the last two lines are:
              
              %: 
                      dh $@ --with=systemd 
              
              #Below last line, add following two lines, then Save & Close file:
              
              override_dh_shlibdeps: 
                      dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
              Note: Indenting of last line (which starts with dh_shlibdeps) to be done by pressing Tab key

              (2) Run build command:
              Code:
              dpkg-buildpackage -b -d
              Last edited by abcd567; 2019-04-05, 20:37.

              Comment


              • #8
                That worked, thanks a lot!

                Just one little thing: dpkg-buildpackage: Warning: UNRELEASED build not signed; use --force-sign to override

                I tried to build again with --force-sign

                dpkg-buildpackage: Error: Signing .buildinfo-File failed
                Last edited by Space Pilot; 2019-04-05, 21:01.

                Comment


                • #9
                  You don't need a signed package for a local install.

                  Signing is for verifying cryptographically that the package comes from debian when the package is distributed via apt.

                  Comment


                  • #10
                    oh, I see, thanks again. Will set up the wireless hardware now :-)

                    Comment


                    • #11
                      I can't see a website under http://localhost:8080 - how can I tell dump1090-mutability is working?

                      Comment


                      • #12
                        Don't know where you picked up 8080, that is only the default for dump1090-fa i believe.
                        Try here:
                        http://localhost/dump1090/

                        Comment


                        • #13
                          The localhost:8080 originated in dump1090 Malcolm Robb which used its internal webserver instead of lighttpd.

                          For a long period, dump1090 MR was in Pi24 as well as installed by fr24feed when receiver=dvbt was set.

                          Comment


                          • #14
                            yeah, I recall the good old times...

                            But as Google Maps is no longer for free I wanted to switch to Open Street Map. Thats why I installed dump1090-mutability.

                            Well, it seems lighttpd is not working
                            Last edited by Space Pilot; 2019-04-06, 09:25.

                            Comment


                            • #15
                              journalctl -u lighttpd

                              This should show possible errors.

                              ls /etc/lighttpd/conf-enabled

                              This shows you which configurations are enabled.

                              Comment

                              Working...
                              X