Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • arash
    replied
    abcd567

    I tried your procedure but it didn't work for me.

    Leave a comment:


  • arash
    replied
    abcd567

    I'll try your procedure & let you know.

    Leave a comment:


  • WayneKing
    replied
    Thank you both, will experiment and report back.

    Well it appears my CPU doesn't support VT-X so I cant run 64bit VM only 32bit Oh well...
    Last edited by WayneKing; 2020-11-17, 12:02.

    Leave a comment:


  • abcd567
    replied
    Originally posted by Oblivian View Post
    (you probably want 3 - SBS3, rather than 4-beast )
    Thanks for pointing out the mistake.
    Corrected it to 3 now.

    The choice 4 automatically came to my mind, possibly from almost always using self-installed dump1090

    Leave a comment:


  • Oblivian
    replied
    (you probably want 3 - SBS3, rather than 4-beast )

    Leave a comment:


  • abcd567
    replied
    Configuration of fr24feed for SBS3 connected to Raspbian Buster/VM via USB.

    Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):

    1 - DVBT Stick (USB)
    -----------------------------------------------------
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)
    4 - ModeS Beast (USB/Network)
    5 - AVR Compatible (DVBT over network, etc)
    6 - microADSB (USB/Network)
    7 - SBSx via Basestation (localhost:30006)


    Enter your receiver type (1-7)$: 3

    Step 4.2 - Please select connection type:

    1 - Network connection
    2 - USB directly to this computer

    Enter your connection type (1-2)$: 2

    Step 4.3A - Please enter your receiver's COM port number/device path
    $: /dev/ttyUSB0

    Originally posted by Oblivian View Post
    Default device for the com port field should be (beast device)

    /dev/ttyUSB0

    However, if the feed fails. There are Additional to locate correct USB/Dev details

    Check for detection:
    sudo lsusb
    Result:
    Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

    Check for port details:
    dmesg | grep tty
    Result:
    usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

    This is used in the "COM/DEV/PATH:" field (case sensitive)
    /dev/ttyUSB0


    (if someone could run this with a SBS plugged in and get the outputs it may assist other users who don't use the radio function)
    Last edited by abcd567; 2020-11-16, 22:54.

    Leave a comment:


  • abcd567
    replied
    SBS user should use only this option

    On Raspbian Buster in VM, Install fr24feed Using debian package for RPi:
    "fr24feed_1.0.26-9_armhf.deb"




    Code:
    # Add architecture armhf to use RPi armhf package on i386 / i686 / x86_64 PC:
    sudo dpkg --add-architecture armhf
    sudo apt update
    
    # Install dependencies
    sudo apt install libc6:armhf libstdc++6:armhf
    
    # Download fr24feed armhf.deb package and install it on i386 / x86_64 PC
    wget -O fr24feed_1.0.26-9_armhf.deb http://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.26-9_armhf.deb
    sudo dpkg -i fr24feed_1.0.26-9_armhf.deb
    
    
    # Signup and configure receiver
    sudo fr24feed --signup
    
    sudo systemctl restart fr24feed
    
    fr24feed-status

    Leave a comment:


  • WayneKing
    replied
    I have tried to take in all the info posted in the many threads...

    I have an SBS-3 plugged in to a Win7 laptop via USB which I access remotely (So buying an rpi + dongle not practical in this instance)

    If I download Virtual box + buster and follow the various instructions in this thread, do I stand some chance of sharing the data to FR or its a no go from the off?

    Leave a comment:


  • abcd567
    replied
    Originally posted by arash View Post

    I test multi ways to run VM & plug in & out the dongle, this method is working for me & dongle report correctly:

    1- Turn on the VM.
    2- Turn on the Debian in VM.
    3- Plug in dongle after complete boot of Debian.
    4- Select it form button tool bar in Debian.
    If you go to settings, and do the steps in the screenshot below, then you will not need your step 4 above.
    I have done what is shown in screenshot below. Now I start Debian this way:

    1- Plug in dongle before starting VM / boot of Debian.
    2- Turn on the VM.
    3- Turn on the Debian in VM.

    The dongle is automatically selected in button tool bar of Debian. No need to do your step 4


    NOTE: Executing steps in screenshot below is required only once.
    It is not required on every boot, as it is saved when you click OK button.


    VM Dongle Settings.png
    Last edited by abcd567; 2020-11-15, 23:16.

    Leave a comment:


  • arash
    replied
    abcd567

    I test multi ways to run VM & plug in & out the dongle, this method is working for me & dongle report correctly:

    1- Turn on the VM.
    2- Turn on the Debian in VM.
    3- Plug in dongle after complete boot of Debian.
    4- Select it form button tool bar in Debian.

    Now it's working correctly.

    To shutdown:

    1- Remove dongle form button tool bar by deselect it.
    2- Shutdown the Debian.
    3- Remove the dongle form windows by remove usb.

    11.jpg



    Last edited by arash; 2020-11-15, 21:34.

    Leave a comment:


  • abcd567
    replied
    arash

    Your instsllation is ok.

    If you see receiver down, either restart dump1090-mutability or reboot Debian/VM.

    If you see link to FR24 down, this is FR24 server problem. Be patient, it will go away after some time. It may reappear again, then disappera again after a while. This is a chronic problem with FR24 servers and lot of feeders face this situstion.
    Last edited by abcd567; 2020-11-11, 22:22.

    Leave a comment:


  • abcd567
    replied
    Your dump1090 and fr24feed are working ok, however there is problem with fr24 server

    Leave a comment:


  • arash
    replied
    This is output on fist command:
    10-1.jpg

    Code:
    nc localhost 30003
    10-2.jpg

    Code:
    sudo apt install rtl-sdr
    10-3.jpg

    Code:
    sudo systemctl stop dump1090-mutability
    rtl_test -t
    10-4.jpg

    After:

    Code:
    sudo systemctl restart dump1090-mutability
    10-5.jpg

    Link is down!
    Last edited by arash; 2020-11-11, 08:32.

    Leave a comment:


  • abcd567
    replied
    sudo apt install netcat
    nc localhost 30003

    Ctrl+c to break stream of data


    sudo apt install rtl-sdr
    sudo systemctl stop dump1090-mutability
    rtl_test -t

    sudo systemctl restart dump1090-mutability
    Last edited by abcd567; 2020-11-11, 08:03.

    Leave a comment:


  • arash
    replied
    My problem does not seem to end!!!

    Now, the link is down!

    9-6.jpg

    I reboot the Debian, disconnect and reconnect the dongle again and again but there is no change and link remain down!

    Also, I remove 127.0.0.1 from dump1090 configuration but there is no any change.
    Last edited by arash; 2020-11-11, 08:31.

    Leave a comment:

Working...
X