Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by tomascubero View Post

    They differ from the guide... are they ok or should I add or modify the different lines. I am concerned on the host= line as I think that has to change from localhost to 127.0.0.1

    Let me know!
    Thanks.
    ABCDs example was for DVB-T.

    Yours is set for using the basestation software output. You'll need the same settings now, So replicate yours.

    127.0.0.1 is the safe way if the device can't understand 'localhost' (which happened in a fr24feed version).

    But as you are running virtual, it may need to actually be the IP of your windows PC instead - Treating it as 2 PCs, 1 with Windows, 1 with Linux, rather than 1 as you aren't using USB direct so local host won't find basestation
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • Originally posted by Oblivian View Post
      ABCDs example was for DVB-T.

      Yours is set for using the basestation software output. You'll need the same settings now, So replicate yours.

      127.0.0.1 is the safe way if the device can't understand 'localhost' (which happened in a fr24feed version).

      But as you are running virtual, it may need to actually be the IP of your windows PC instead - Treating it as 2 PCs, 1 with Windows, 1 with Linux, rather than 1 as you aren't using USB direct so local host won't find basestation
      Ok so my IP for my computer on my router is 192.168.0.2. Will the port be the same (30005) or 30006 as I had it before?

      Comment


      • Hopefully this may make some sense

        Untitled Diagram (1).jpg

        The guide assumes pass-though USB access.

        Your setup requires some internal network access instead

        /edit posted at same time. now personalised - And the default output from basestation is 30006
        Last edited by Oblivian; 2019-05-08, 07:24.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • Ok I have done everything and the FR24 feeder is running on the VM but checking my FR24 stats page it says my receiver is offline so I'm doing something wrong:

          https://www.flightradar24.com/accoun...tats/?id=10549

          Maybe set 127.0.0.1?

          Comment


          • Originally posted by tomascubero View Post
            Ok I have done everything and the FR24 feeder is running on the VM but checking my FR24 stats page it says my receiver is offline so I'm doing something wrong:

            https://www.flightradar24.com/accoun...tats/?id=10549

            Maybe set 127.0.0.1?
            The command window within the VM will need to remain open for fr24feed to function.

            And fr24feed should be restarted after changing .ini settings (or visit the web page and save)

            It should allow you to go
            sudo fr24feed-status

            And see where it is going wrong.

            You can't use localhost/127.0.0.1 - as the virtual is not the device running basestation (the source) as it would if a TV stick/dump1090 would if installed. Your PC itself is the source.
            As long as the virtual machine gets a network address in the same range, it should be able see your PC. However not having set one up myself I can't confirm what the default virtual network setting may be

            The command is
            ifconfig

            It may get its own IP (and the host) on a different range to the PC but still allow them to talk to each other. The settings may be in the Oracle settings.
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • ifconfig gives this:

              aser.png

              And which command window must stay open? I mean how to you "start" the feeder is it with this command?

              sudo systemctl restart fr24feed

              sudo systemctl status fr24feed

              Comment


              • And this is the current status:

                staus.png

                Comment


                • Theres the VM IP, 10.0.2.15 - so that wont find your PC on 192.168.0.2

                  I just noticed in the Oracle options, default setting allows outgoing requests to internet only. It's own secure network. You will need to adjust to 'NAT network' From NAT I think under network settings

                  Which hopefully gives you an address on the normal network

                  sudo systemctl restart fr24feed

                  Will start it as a service in the background. But I believe if you then close the console window, it will quit (others will confirm). So better to just leave sitting at prompt

                  'sudo fr24feed-status' should give a graphical output
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • ;ouy8.png

                    Ok, NAT Network was not letting me save it but I changed to bridged mode and the VM IP is now a "local" IP. So set that in the fr24feed.ini file along with 30006?

                    Comment


                    • Originally posted by tomascubero View Post
                      [ATTACH=CONFIG]10580[/ATTACH]

                      Ok, NAT Network was not letting me save it but I changed to bridged mode and the VM IP is now a "local" IP. So set that in the fr24feed.ini file along with 30006?
                      Ooooh closer.

                      Yes, 192.168.0.2:30006
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • Originally posted by Oblivian View Post
                        Ooooh closer.

                        Yes, 192.168.0.2:30006
                        Nothing yet.

                        Tried changing the Network Settings IP on Basestation to 192.168.0.2 but doesn't work either.

                        This is very complicated and frustrating!

                        Comment


                        • I use Planeplotter as well... can't I just share from inside PP to FR24? It would make it REALLY easy...

                          Comment


                          • Originally posted by tomascubero View Post
                            Nothing yet.

                            Tried changing the Network Settings IP on Basestation to 192.168.0.2 but doesn't work either.

                            This is very complicated and frustrating!
                            DONT TOUCH BASESTATION!

                            By default. The data out is always on port 30006 in basestation. And changing any setting on that will likely stop the data from the decoder too!

                            The ONLY change that should be being made, is the localhost/127.0.0.1 before :30006 in fr24feed.ini

                            To the REAL IP, of the PC.

                            What is planeplotter configured as for the source of data.

                            If planeplotter is working, yes, there is the option to enable data-out. And use that instead.

                            https://forum.flightradar24.com/thre...l=1#post116908
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • Yeah the Planeplotter option does the same... I am positive the error is coming from the IP. By real IP you mean the actual IP on the web?

                              Comment


                              • I can't get the graphical status of the fr24feed with this command:

                                sudo fr24feed-status

                                Comment

                                Working...
                                X