Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • arash
    replied
    Dear Sir

    I did everything as you instructed & the doungle start to feed fr24 in good status.unfortunately, after 4 days, it's stop to feed fr24 & I start to set everything from beginning.

    when I want to enter this command to install dependencies:
    # Install dependencies
    sudo apt install gcc-6-base:armhf libc6:armhf libgcc1:armhf libstdc++6:armhf

    I got this error from debian operating system:

    Untitled1.jpg

    I tried to continue installation, but when I finish it, the feed didn't work & on the usb panel on dashboard, the red circle flashes and the connection between the dongles and the operating system is not established, like this:

    Untitled.jpg

    I have read various parts of the forum to resolve the problem but did not find the solution.

    Please help me solve this problem.

    P.S:

    I did the installation method on the two Windows operating systems, 7 & 10, but unfortunately I encountered the same error message.
    Last edited by arash; 2019-06-22, 14:29.

    Leave a comment:


  • Capecod
    replied

    Leave a comment:


  • Capecod
    replied
    Originally posted by Capecod View Post
    I find that PlaneFinder is very poor compared to FR24, whether it is the aircraft (much more on FR24), the options, the filters, or the mobile app...
    So no, I'm not going to add it to my Pi (which is one of the first Pi and therefore quite slow)
    I am very happy with what I have today, and besides I will disable the PlaneFinder Client and the rebroadcast

    Regards
    Capecod
    Well, that's it, problem solved.

    Regards,
    Capecod

    Leave a comment:


  • Capecod
    replied
    Originally posted by wiedehopf View Post
    The linux planefinder client provides a nice map at XXXX
    Inlcudes a nice range outline and some basic statistics.
    Well worth adding to your Raspberry Pi.

    Personally i'd switch to using dump1090-fa with the dongle in the Raspberry Pi and configure VRS to take that as a source.
    It provides very nice decoding (and a local map that you don't need when running VRS)
    In case you ever want to try it, check these instructions
    RTL1090 can also produce unreliable data.
    (Doesn't mean yours does it depends on the settings i guess)
    I find that PlaneFinder is very poor compared to FR24, whether it is the aircraft (much more on FR24), the options, the filters, or the mobile app...
    So no, I'm not going to add it to my Pi (which is one of the first Pi and therefore quite slow)
    I am very happy with what I have today, and besides I will disable the PlaneFinder Client and the rebroadcast

    Regards
    Capecod

    Leave a comment:


  • wiedehopf
    replied
    The linux planefinder client provides a nice map at http://pi:30053
    Inlcudes a nice range outline and some basic statistics.
    Well worth adding to your Raspberry Pi.

    Personally i'd switch to using dump1090-fa with the dongle in the Raspberry Pi and configure VRS to take that as a source.
    It provides very nice decoding (and a local map that you don't need when running VRS)
    In case you ever want to try it, check these instructions (https://github.com/wiedehopf/combine...ng-dump1090-fa)

    RTL1090 can also produce unreliable data.
    (Doesn't mean yours does it depends on the settings i guess)

    Leave a comment:


  • Capecod
    replied
    Originally posted by abcd567 View Post
    Capecod:

    The RTL1090 outputs data as follows:
    (1) AVR on port 30003
    (2) Beast at port 31001

    As fr24feed is able to get AVR on port 30006, most likely you have configured a "Rebroadcast Server" in VRS with format Basestation, port # 30006.

    Can you please check your VRS settings and confirm?
    Hi,

    yes indeed, but not in Basestation format. I rebroadcast : format AVR, port 30006 for PlaneFinder feeder client

    But since I am again a feeder of FR24, I don't really need to feed PlaneFinder anymore......

    Regards
    Capecod
    Last edited by Capecod; 2019-06-01, 08:44.

    Leave a comment:


  • abcd567
    replied
    Capecod:

    The RTL1090 outputs data as follows:
    (1) AVR on port 30003
    (2) Beast at port 31001

    As fr24feed is able to get AVR on port 30006, most likely you have configured a "Rebroadcast Server" in VRS with format Basestation, port # 30006.

    Can you please check your VRS settings and confirm?
    Last edited by abcd567; 2019-05-31, 23:47.

    Leave a comment:


  • Capecod
    replied
    Well

    It seems to work well with this data in FR24 Feeder settings:
    Receiver: AVR TCP
    HOST IP: my PC IP:30006

    Regards
    Capecod

    Leave a comment:


  • abcd567
    replied
    Capecode:

    Do NOT use setting avr-tcp. It often creates problem.

    Use
    receiver: beast-tcp
    host: ip-of-windows-computer:31001

    (As your windows computer's ip is 192.168.0.10, in your case it will be host=192.168.0.10:31001)

    You have to setup RTL1090, VRS and fr24feed as shown in the post linked below. This post is for all 3 items (RTL1090, fr24feed, and VRS) on Windows computer.

    In your current setup, RTL1090 and VRS are still on Windows computer, but fr24feed is now on another computer (Raspberry Pi). Therefore in fr24feed.ini, instead of host=127.0.0.1:31001, use host=ip-of-windows-computer:31001 (in your case it will be host=192.168.0.10:31001)

    Windows: How-to Feed FR24FEED And VRS From RTL1090

    .
    Last edited by abcd567; 2019-05-31, 19:25.

    Leave a comment:


  • Capecod
    replied
    Hello fellow feeders,

    Since the FR24 windows client stopped, I've been looking for a way to continue to feed FR24 but without redoing my entire installation under w10 which works perfectly for several years.

    I am progressing....
    The FR24 client is now installed on the Pi (raspbian)
    The Pi is in wifi, the PC on which Virtual Radar Server is installed is also in wifi.
    During the installation of the FR24 client I gave the requested information (email address, lat/long of the receiver, IP address of the receiver etc...)
    On the FR24 website my receiver is well "online" but 0 planes.....
    by connecting from a PC to the FR24 client via http ip-du-pi:8754 I can modify the options but I can't get any aircraft.........
    The pi is in fixed IP 192.168.0.11
    The PC is in fixed IP 192.168.0.10
    The dongle is DVB-T with RTL1090 on the PC of course, with more or less 100/150 aircraft's tracked

    Any idea of wich option i should activate ?
    AVR, BEAST, other
    Port, 31001, 30003 other ?

    Regards,
    Capecod

    Leave a comment:


  • riki
    replied
    how feed from virtual radar server? maybe i can write ip and port to rebroadcast server in VRS on win10?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by MerNion View Post
    I managed to make it work!!!!

    Setup:
    SBS1 USB connected to Host Computer with IP 192.168.0.7. Basestation running on Host Computer. On Virtual Computer running the Raspberry-PI Desktop with the fr24feed.

    You --signup or --reconfigure and select option "7 - SBSx via Basestation (localhost:30006)"

    Then before starting the fr24feed you edit the file:
    /etc/fr24feed.ini

    and change the line which says

    localhost:30006

    to

    192.168.0.7:30006


    Save and run fr24feed and voila!
    That's what the other 3 SBS users have had to do :/

    The 30003 data is pre-decoded. And for some reason the feeder stopped listening to that (despite being the first type when they started out!)

    30006 is proprietary encoded sbs format, and they seem to be able to handle that.

    Guess your tests confirm the USB methods are all but useless again.

    Sent from my EML-L09 using Tapatalk

    Leave a comment:


  • MerNion
    replied
    I managed to make it work!!!!

    Setup:
    SBS1 USB connected to Host Computer with IP 192.168.0.7. Basestation running on Host Computer. On Virtual Computer running the Raspberry-PI Desktop with the fr24feed.

    You --signup or --reconfigure and select option "7 - SBSx via Basestation (localhost:30006)"

    Then before starting the fr24feed you edit the file:
    /etc/fr24feed.ini

    and change the line which says

    localhost:30006

    to

    192.168.0.7:30006


    Save and run fr24feed and voila!

    Leave a comment:


  • MerNion
    replied
    I tried all combinations of these settings:
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)
    4 - ModeS Beast (USB/Network)
    5 - AVR Compatible (DVBT over network, etc)
    6 - microADSB (USB/Network)

    with USB version and all baud rates:
    1 - 57600 | Generic AVR
    2 - 115200 | microADSB
    3 - 921600 | SBS1,SBS1er
    4 - 1000000 | ModeS Beast - older configuration
    5 - 3000000 | ModeS Beast, SBS3

    and none works!

    Those 2 options:
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)

    always give this result no matter the baud rate:
    2019-05-23 00:54:00 | [reader][i]Connecting to SBS1 receiver via USB (/dev/ttyUSB0)
    2019-05-23 00:54:00 | [reader][i]Connected to the receiver, authenticating
    2019-05-23 00:54:29 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver

    2019-05-23 01:07:50 | [reader][i]Connecting to SBS3 receiver via USB (/dev/ttyUSB0)
    2019-05-23 01:07:50 | [reader][i]Connected to the receiver, authenticating
    2019-05-23 01:08:31 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver

    While this option:
    4 - ModeS Beast (USB/Network)

    gives these results:
    2019-05-23 01:28:47 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@57600)
    2019-05-23 01:28:47 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:28:47 | [reader][i]Configured, processing messages

    2019-05-23 01:32:56 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@115200)
    2019-05-23 01:32:56 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:32:56 | [reader][i]Configured, processing messages

    2019-05-23 01:36:25 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@921600)
    2019-05-23 01:36:26 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:36:26 | [reader][i]Configured, processing messages

    2019-05-23 01:38:49 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@1000000)
    2019-05-23 01:38:49 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:38:49 | [reader][i]Configured, processing messages

    2019-05-23 01:40:46 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@3000000)
    2019-05-23 01:40:46 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:40:46 | [reader][i]Configured, processing messages

    This option:
    6 - microADSB (USB/Network)

    Gives these results:
    2019-05-23 01:42:47 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@57600)
    2019-05-23 01:42:47 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:42:47 | [reader][i]Configured, processing messages

    2019-05-23 01:47:19 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@115200)
    2019-05-23 01:47:19 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:47:19 | [reader][i]Configured, processing messages

    2019-05-23 01:49:27 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@921600)
    2019-05-23 01:49:27 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:49:27 | [reader][i]Configured, processing messages

    2019-05-23 01:51:28 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@1000000)
    2019-05-23 01:51:28 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:51:28 | [reader][i]Configured, processing messages

    2019-05-23 01:54:01 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@3000000)
    2019-05-23 01:54:01 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:54:01 | [reader][i]Configured, processing messages
    And this option:
    5 - AVR Compatible (DVBT over network, etc)

    Gives these results:
    2019-05-23 01:56:07 | [reader][i]Connecting to AVR-USB receiver via (avr:///dev/ttyUSB0@921600)
    2019-05-23 01:56:07 | [reader][i]Connected to the receiver, configuring
    2019-05-23 01:56:07 | [reader][i]Configured, processing messages
    2019-05-23 01:56:14 | [reader][w]Setting new UTC offset: 0!
    (The same for the other baud rates but I lost the clipboard)
    No aircraft are tracked and obviously no message is actually decoded..


    I then tried to run Basestation on the Host Computer and using the ip address and port 30003 to get the results. I am sure that basestation send data on port 30003 because if I telnet on this port I get stuff like that:
    MSG,4,35,6645,3944F3,350596,2019/05/24,00:57:16.786,2019/05/24,00:57:17.369.0,138.5,,,-1472,,,,,
    MSG,8,35,6645,3944F3,350596,2019/05/24,00:57:16.786,2019/05/24,00:57:17.36,,,,,,,0
    MSG,1,35,6645,3944F3,350596,2019/05/24,00:57:16.991,2019/05/24,00:57:17.363TN,,,,,,,,,,,
    MSG,3,35,6645,3944F3,350596,2019/05/24,00:57:17.192,2019/05/24,00:57:17.3675,,,38.67048,22.96619,,,0,0,0,0
    and on port 30006 i get stuff like:

    oι↨░ΑV8ω♦ί<dΔ►♥aτ►☻╖═sι↨░▒y1 <☺<dΔ►♥╡*►☻z[θι↓►►╞4╧α J╔├►♥=♦►☻☺ΠKλΞ<dΔX┐☺╔βΏ┼►♥╣
    ►☻☺:lλΞ<dΔβ9σ ♦↕►♥ΥD►☻▌SμρΦ╠00υJ╔├►♥Ψ╕►☻Aπι↓►►Α↨4
    ίJ╔├►♥b7►☻▼Dτι↓►►└9ώ1`
    J╔├►♥Ύ
    ►☻bq╣]E╨i►♥Μ▒►☻m╠]<dΔ►♥▬╖►☻☺ΖύEΞJ╔├β♥┤♠►♥Ρ"►☻☺↨\aΞJ╔├Ρ╔☺▐RAά►♥zΥ►☻Οψ s]J╔├►♥r██☻☺
    ]═Ξ<dΔX┐☺╔YΏέ►♥Op►☻☺Α~═Ξ<dΔβ9σ ♦►♥Δ►☻☺
    γRΞJ╔├β♥┤►♥Ξⁿ►☻☺hΞJ╔├╞4╧α ►♥xό►☻☺Τ4χΞJ╔├Ρ╔
    oΦ▼►♥σ☻►☻☺6ξ♦Ξ<dΔX┐☺╔▼Ώⁿ►♥vh►☻☺ω┼♦Ξ<dΔβ9σ ♦►♥=Α►☻╞╧<ι↨░ ►►┬5ήh <dΔ►♥∟ξ►☻l_?ι↨░ ►
    ►┬5ήh <dΔ►♥╛%►☻=ΎAι↨░ ►►┬5ήh <dΔ►♥φ►☻ADι↨░ ►►┬5ήh <dΔ►♥-╛►☻Έ
    Gι↨░ ►►┬5ήh <dΔ►♥eΖ
    ►☻dδIι↨░ ►►┬5ήh <dΔ►♥↕B►☻☺╤ΨqΞJ╔├β♥┤♠►♥╝Σ►☻dΔ]<dΔ►♥τ╣►☻cλ]J╔├►♥├\►☻☺
    but none of these
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)
    4 - ModeS Beast (USB/Network)
    5 - AVR Compatible (DVBT over network, etc)
    6 - microADSB (USB/Network)

    on the network option ( 1 - Network connection) works using either 30003 or 30006.

    What I believe is that the last option:
    7 - SBSx via Basestation (localhost:30006)
    might be my case but the basestation is not working on the localhost:30006 rather than on 192.168.0.7:30006

    Now, I don't know much about linux, but is there a way to "fool" the system and send traffic from 192.168.0.7:30006 to localhost 30006 so it receives the data??

    Leave a comment:


  • Oblivian
    replied
    Originally posted by MerNion View Post
    I just tried SBS3 and gives the same error:

    I will try with other slower data baudrates as I selected "5 - 3000000 | ModeS Beast, SBS3" this time. Am I the first one to try direct USB from an SBS1 with fr24feed??? Hard to believe that, how is it working on all others?
    Thanks!
    Despite my best efforts for feedback in the SBS section to help others.. noone ever replies their finding - just disappears into the fold without knowing if they succeeded or failed. So yep, you are the first to actively try and report back

    Leave a comment:

Working...
X