Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • So far so good.

    I have successfully managed how to deal with wifi:

    I booted with the live ISO I have got so far, went to /etc/NetworkManager/system-connections/
    There was a file named: mySSIDname, which I copied to the Cubic (custom ISO creator), in the same path: /etc/NetworkManager/system-connections/

    Now it's working good, even when I turn off my router for 10min, it reconnect ownself.

    I just had some problems with the splash screen where I had to choose from "Try it now" or "Install", but after half a day it went gone forever!

    So for now I need to add TeamViewer and that would be all.

    Thank you for now, but if I would encounter some problem will write.

    Will post info when ThinClient would be under the attic, without any needs of my attention.

    Cheers!

    Comment


    • As a contributor via Windows since 2014 I hadnt considered changing my setup until now. I thought I would have a go at using the Oracle VM Raspberry Pi method described by abcd567 in this thread. I am not a Linux user so I was quite pleased when it all seemed to go well, however, although I appear to be online the number of aircraft seen remains 0.

      I am using the same PC (Win 10) and DVBT stick as I did with the Windows setup, all seems to recognised and working.

      The status via the browser reads:-

      FR24 Link: Connected via UDP
      Aircraft Tracked: 0 (been online for several hours)
      Aircraft Uploaded: N/A
      Receiver: dvbt Connected.
      MLAT:No

      The FR24 Feeder settings are:-

      Baudrate: Default
      Raww data: No
      SBS Feed:No
      Logfile mode: Keep up to48h, rotate every 24h
      MLAT:Yes


      If anyone could help me with this, I'm sure it's finger trouble..

      Apologies if this has been answered elsewhere.

      Comment


      • To: crumplezone

        Please note that setting "Receiver=DVB-T" FAILS on Raspberrypi Desktop x64_86
        REASON: The dump1090 provided by fr24feed fails to run on X64_86 machines.

        Did you install dump1090-mutability ver 1.15~dev?

        CASE-A: If you did install dump1090-mutability version 1.15~dev:
        First Change settings to as shown in screenshot below:

        FR24 settings - External dump1090 - BEAST-TCP.png


        If you have installed fr24feed_1.0.23-8
        As the setting "Receiver = DVB-T" has already replaced dump1090-mutability ver 1.15~dev by ver 1.14, you have to purge the ver 1.14 and re-install ver 1.15~dev

        Purge ver 1.14
        Code:
        sudo apt-get purge dump1090-mutability
        Install ver 1.15~dev from the package you have already built as per STEP 1 of post #2
        Code:
        cd /home/pi/
        sudo dpkg -i  dump1090-mutability_1.15~dev_*.deb
        
        sudo reboot


        If you have installed fr24feed_1.0.18-5
        Changing settings as in screenshot above, and restarting fr24feed, will fix the problem.





        CASE-B: If you did not install dump1090-mutability version 1.15~dev:

        If you have installed fr24feed_1.0.23-8
        With "Receiver=DVB-T" setting, it has installed dump1090-mutability ver 1.14, but it fails to run on RaspberryPi Desktop.
        You will have to:
        (a) Change settings to as shown in screenshot above
        (b)Purge dump1090-mutability ver 1.14 by following command
        Code:
        sudo apt-get purge dump1090-mutability
        (c) Install dump1090-mutability ver 1.15~dev as shown in STEP 1 of post #2



        If you have installed fr24feed_1.0.18-5
        The integral mr-dump1090 fails to run on Raspberrypi Desktop
        You will have to
        (a) Change settings to as shown in screenshot above
        (b) Install dump1090-mutability ver 1.15~dev as shown in STEP 1 of post #2


        (3) ADDITIONAL INFO: What is output of following command:

        Code:
        lsusb
        On my VM, the above command gives following output, in which "RTL2838 DVB-T" is listed.
        Does your output also list "RTL2838 DVB-T"?

        pi@raspberry:~ $ lsusb
        Bus 001 Device 002: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
        Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
        Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
        Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
        Last edited by abcd567; 2019-05-19, 20:46.

        Comment


        • To abcd567

          Thank you for your reply abcd567.

          I made the changes and re-installed dump1090-mutability v1.5~dev as you suggested, hopefully correctly, but still no joy...

          Aircraft Tracked: 0
          Aircraft Uploaded: N/A

          My output only lists the following:-

          i@raspberry:~ $ lsusb
          Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
          Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

          I also checked that uname –m revealed i686
          Last edited by crumplezone; 2019-05-20, 16:32. Reason: Additional info

          Comment


          • To: crumplezone

            Your Dongle is NOT attached to the VM. You have to attach it.
            The two screenshots below give steps to attach the dongle (steps 1 to 7):

            VM USB -1.png . VM USB -2.png
            Last edited by abcd567; 2019-05-20, 18:21.

            Comment


            • To abcd567

              Yep that's the one. Thank you

              Bunny = happy

              BTW how come we changed threads -- bit confusing?

              Comment


              • Originally posted by crumplezone View Post
                To abcd567

                Yep that's the one. Thank you

                Bunny = happy

                BTW how come we changed threads -- bit confusing?
                The other gives option alternates as a central location/guide. This is for helping with them

                For help with issues arising from completing any of the options suggested here.

                Please use https://forum.flightradar24.co...etu...ion-Assistance
                Sent from my EML-L09 using Tapatalk
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • Windows Virtualbox - RPI Debian image & fr24feed 1.0.23-8 problem with USB SBS1

                  Hello all,

                  after the windows feeder stopped working I tried this tutorial here:
                  forum.flightradar24.com/threads/12483-Feed-options-for-depreciated-windows-feeder

                  and did everything as described but I end up with this:

                  [ ok ] FR24 Feeder/Decoder Process: running.
                  [ ok ] FR24 Stats Timestamp: 2019-05-22 20:37:19.
                  [ ok ] FR24 Link: connected [UDP].
                  [ ok ] FR24 Radar: T-LGAV19.
                  [ ok ] FR24 Tracked AC:.
                  [FAIL] Receiver: down ... failed!
                  [FAIL] FR24 MLAT: not running ... failed!
                  I am using an SBS-1 connected through USB. I can see it from Virtualbox that the USB is ticked:
                  Untitled.png

                  Also if i do lsusb, I see:
                  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
                  Bus 002 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
                  Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
                  Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
                  and it is found under /dev/ttyUSB0

                  I had configured and reconfigured the fr24feed several times but no result. These are the values I tried:

                  Step 4.1 - Receiver selection:

                  1 - DVBT Stick (USB)
                  -----------------------------------------------------
                  2 - SBS1/SBS1er (USB/Network)
                  3 - SBS3 (USB/Network)
                  4 - ModeS Beast (USB/Network)
                  5 - AVR Compatible (DVBT over network, etc)
                  6 - microADSB (USB/Network)
                  7 - SBSx via Basestation (localhost:30006)


                  Enter your receiver type (1-7)$:2

                  Step 4.2 - Please select connection type:

                  1 - Network connection
                  2 - USB directly to this computer

                  Enter your connection type (1-2)$:2

                  Step 4.3A - Please enter your receiver's COM port number/device path
                  $:/dev/ttyUSB0

                  Step 4.3B - Please select your receiver's data baudrate:
                  1 - 57600 | Generic AVR
                  2 - 115200 | microADSB
                  3 - 921600 | SBS1,SBS1er
                  4 - 1000000 | ModeS Beast - older configuration
                  5 - 3000000 | ModeS Beast, SBS3
                  Select baudrate (1-5)$:3

                  Step 5.1 - Would you like to enable RAW data feed on port 30334 (yes/no)$:no

                  Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$:no

                  Step 5.3 - Would you like to enable SBS/Basestation RAW data feed on port 20072 (yes/no)$:no

                  Step 6A - Please select desired logfile mode:
                  0 - Disabled
                  1 - 48 hour, 24h rotation
                  2 - 72 hour, 24h rotation
                  Select logfile mode (0-2)$:0

                  Step 6B - Please enter desired logfile path (/var/log/fr24feed):
                  $:/var/log

                  Submitting form data...ERROR

                  Invalid email provided!

                  Would you like to try again?

                  Saving settings to /etc/fr24feed.ini...OK
                  Settings saved, please run "sudo systemctl restart fr24feed" to use new configuration.
                  I don't know why it says invalid email, when I used the fr24feed --signup and entered the key and email it said it was verified correctly.

                  What else may I try to make it work? I understand that for some reason it is not reading the USB data.. Any ideas?

                  Thanks!

                  Comment


                  • Originally posted by MerNion View Post
                    Also if i do lsusb, I see:


                    and it is found under /dev/ttyUSB0

                    I had configured and reconfigured the fr24feed several times but no result. These are the values I tried:



                    I don't know why it says invalid email, when I used the fr24feed --signup and entered the key and email it said it was verified correctly.

                    What else may I try to make it work? I understand that for some reason it is not reading the USB data.. Any ideas?

                    Thanks!
                    Which version of the feeder did you follow? Can only use the 23-8 version

                    That said, I do not know if anyone has attempted direct USB yet, but rather data from Basestation on a windows machine still going. So do not know the expected results.

                    Load the config page in chromium and make sure the config file appears to have been populated properly. Or stop fr24feed and run it stand-alone/visually to see what is hanging

                    sudo systemctl stop fr24feed
                    sudo fr24feed
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • I am using feeder 1.0.23-8

                      This is what I am getting:
                      2019-05-23 00:54:00 | [reader][i]Connecting to SBS1 receiver via USB (/dev/ttyUSB0)
                      2019-05-23 00:54:00 | [reader][i]Connected to the receiver, authenticating
                      2019-05-23 00:54:29 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver
                      I don't have Basestation or anything else running on the host or guest system which might interfere with that. Any other idea or a workaround?

                      Thanks!

                      Comment


                      • Originally posted by MerNion View Post
                        I am using feeder 1.0.23-8

                        This is what I am getting:


                        I don't have Basestation or anything else running on the host or guest system which might interfere with that. Any other idea or a workaround?

                        Thanks!
                        Potentially adjust it for SBS3?

                        The later FWs may have streamlined the output a bit more
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • I just tried SBS3 and gives the same error:

                          2019-05-23 01:07:50 | [reader][i]Connecting to SBS3 receiver via USB (/dev/ttyUSB0)
                          2019-05-23 01:07:50 | [reader][i]Connected to the receiver, authenticating
                          2019-05-23 01:08:31 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver
                          I will try with other slower data baudrates as I selected "5 - 3000000 | ModeS Beast, SBS3" this time. Am I the first one to try direct USB from an SBS1 with fr24feed??? Hard to believe that, how is it working on all others?
                          Thanks!

                          Comment


                          • Originally posted by MerNion View Post
                            I just tried SBS3 and gives the same error:

                            I will try with other slower data baudrates as I selected "5 - 3000000 | ModeS Beast, SBS3" this time. Am I the first one to try direct USB from an SBS1 with fr24feed??? Hard to believe that, how is it working on all others?
                            Thanks!
                            Despite my best efforts for feedback in the SBS section to help others.. noone ever replies their finding - just disappears into the fold without knowing if they succeeded or failed. So yep, you are the first to actively try and report back
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • I tried all combinations of these settings:
                              2 - SBS1/SBS1er (USB/Network)
                              3 - SBS3 (USB/Network)
                              4 - ModeS Beast (USB/Network)
                              5 - AVR Compatible (DVBT over network, etc)
                              6 - microADSB (USB/Network)

                              with USB version and all baud rates:
                              1 - 57600 | Generic AVR
                              2 - 115200 | microADSB
                              3 - 921600 | SBS1,SBS1er
                              4 - 1000000 | ModeS Beast - older configuration
                              5 - 3000000 | ModeS Beast, SBS3

                              and none works!

                              Those 2 options:
                              2 - SBS1/SBS1er (USB/Network)
                              3 - SBS3 (USB/Network)

                              always give this result no matter the baud rate:
                              2019-05-23 00:54:00 | [reader][i]Connecting to SBS1 receiver via USB (/dev/ttyUSB0)
                              2019-05-23 00:54:00 | [reader][i]Connected to the receiver, authenticating
                              2019-05-23 00:54:29 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver

                              2019-05-23 01:07:50 | [reader][i]Connecting to SBS3 receiver via USB (/dev/ttyUSB0)
                              2019-05-23 01:07:50 | [reader][i]Connected to the receiver, authenticating
                              2019-05-23 01:08:31 | [reader][e]Authentication failed, please make sure the specified device is a SBSX-USB receiver

                              While this option:
                              4 - ModeS Beast (USB/Network)

                              gives these results:
                              2019-05-23 01:28:47 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@57600)
                              2019-05-23 01:28:47 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:28:47 | [reader][i]Configured, processing messages

                              2019-05-23 01:32:56 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@115200)
                              2019-05-23 01:32:56 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:32:56 | [reader][i]Configured, processing messages

                              2019-05-23 01:36:25 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@921600)
                              2019-05-23 01:36:26 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:36:26 | [reader][i]Configured, processing messages

                              2019-05-23 01:38:49 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@1000000)
                              2019-05-23 01:38:49 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:38:49 | [reader][i]Configured, processing messages

                              2019-05-23 01:40:46 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@3000000)
                              2019-05-23 01:40:46 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:40:46 | [reader][i]Configured, processing messages

                              This option:
                              6 - microADSB (USB/Network)

                              Gives these results:
                              2019-05-23 01:42:47 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@57600)
                              2019-05-23 01:42:47 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:42:47 | [reader][i]Configured, processing messages

                              2019-05-23 01:47:19 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@115200)
                              2019-05-23 01:47:19 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:47:19 | [reader][i]Configured, processing messages

                              2019-05-23 01:49:27 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@921600)
                              2019-05-23 01:49:27 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:49:27 | [reader][i]Configured, processing messages

                              2019-05-23 01:51:28 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@1000000)
                              2019-05-23 01:51:28 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:51:28 | [reader][i]Configured, processing messages

                              2019-05-23 01:54:01 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@3000000)
                              2019-05-23 01:54:01 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:54:01 | [reader][i]Configured, processing messages
                              And this option:
                              5 - AVR Compatible (DVBT over network, etc)

                              Gives these results:
                              2019-05-23 01:56:07 | [reader][i]Connecting to AVR-USB receiver via (avr:///dev/ttyUSB0@921600)
                              2019-05-23 01:56:07 | [reader][i]Connected to the receiver, configuring
                              2019-05-23 01:56:07 | [reader][i]Configured, processing messages
                              2019-05-23 01:56:14 | [reader][w]Setting new UTC offset: 0!
                              (The same for the other baud rates but I lost the clipboard)
                              No aircraft are tracked and obviously no message is actually decoded..


                              I then tried to run Basestation on the Host Computer and using the ip address and port 30003 to get the results. I am sure that basestation send data on port 30003 because if I telnet on this port I get stuff like that:
                              MSG,4,35,6645,3944F3,350596,2019/05/24,00:57:16.786,2019/05/24,00:57:17.369.0,138.5,,,-1472,,,,,
                              MSG,8,35,6645,3944F3,350596,2019/05/24,00:57:16.786,2019/05/24,00:57:17.36,,,,,,,0
                              MSG,1,35,6645,3944F3,350596,2019/05/24,00:57:16.991,2019/05/24,00:57:17.363TN,,,,,,,,,,,
                              MSG,3,35,6645,3944F3,350596,2019/05/24,00:57:17.192,2019/05/24,00:57:17.3675,,,38.67048,22.96619,,,0,0,0,0
                              and on port 30006 i get stuff like:

                              oι↨░ΑV8ω♦ί<dΔ►♥aτ►☻╖═sι↨░▒y1 <☺<dΔ►♥╡*►☻z[θι↓►►╞4╧α J╔├►♥=♦►☻☺ΠKλΞ<dΔX┐☺╔βΏ┼►♥╣
                              ►☻☺:lλΞ<dΔβ9σ ♦↕►♥ΥD►☻▌SμρΦ╠00υJ╔├►♥Ψ╕►☻Aπι↓►►Α↨4
                              ίJ╔├►♥b7►☻▼Dτι↓►►└9ώ1`
                              J╔├►♥Ύ
                              ►☻bq╣]E╨i►♥Μ▒►☻m╠]<dΔ►♥▬╖►☻☺ΖύEΞJ╔├β♥┤♠►♥Ρ"►☻☺↨\aΞJ╔├Ρ╔☺▐RAά►♥zΥ►☻Οψ s]J╔├►♥r██☻☺
                              ]═Ξ<dΔX┐☺╔YΏέ►♥Op►☻☺Α~═Ξ<dΔβ9σ ♦►♥Δ►☻☺
                              γRΞJ╔├β♥┤►♥Ξⁿ►☻☺hΞJ╔├╞4╧α ►♥xό►☻☺Τ4χΞJ╔├Ρ╔
                              oΦ▼►♥σ☻►☻☺6ξ♦Ξ<dΔX┐☺╔▼Ώⁿ►♥vh►☻☺ω┼♦Ξ<dΔβ9σ ♦►♥=Α►☻╞╧<ι↨░ ►►┬5ήh <dΔ►♥∟ξ►☻l_?ι↨░ ►
                              ►┬5ήh <dΔ►♥╛%►☻=ΎAι↨░ ►►┬5ήh <dΔ►♥φ►☻ADι↨░ ►►┬5ήh <dΔ►♥-╛►☻Έ
                              Gι↨░ ►►┬5ήh <dΔ►♥eΖ
                              ►☻dδIι↨░ ►►┬5ήh <dΔ►♥↕B►☻☺╤ΨqΞJ╔├β♥┤♠►♥╝Σ►☻dΔ]<dΔ►♥τ╣►☻cλ]J╔├►♥├\►☻☺
                              but none of these
                              2 - SBS1/SBS1er (USB/Network)
                              3 - SBS3 (USB/Network)
                              4 - ModeS Beast (USB/Network)
                              5 - AVR Compatible (DVBT over network, etc)
                              6 - microADSB (USB/Network)

                              on the network option ( 1 - Network connection) works using either 30003 or 30006.

                              What I believe is that the last option:
                              7 - SBSx via Basestation (localhost:30006)
                              might be my case but the basestation is not working on the localhost:30006 rather than on 192.168.0.7:30006

                              Now, I don't know much about linux, but is there a way to "fool" the system and send traffic from 192.168.0.7:30006 to localhost 30006 so it receives the data??

                              Comment


                              • I managed to make it work!!!!

                                Setup:
                                SBS1 USB connected to Host Computer with IP 192.168.0.7. Basestation running on Host Computer. On Virtual Computer running the Raspberry-PI Desktop with the fr24feed.

                                You --signup or --reconfigure and select option "7 - SBSx via Basestation (localhost:30006)"

                                Then before starting the fr24feed you edit the file:
                                /etc/fr24feed.ini

                                and change the line which says

                                localhost:30006

                                to

                                192.168.0.7:30006


                                Save and run fr24feed and voila!

                                Comment

                                Working...
                                X