Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tomascubero
    replied
    I use Planeplotter as well... can't I just share from inside PP to FR24? It would make it REALLY easy...

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    Ooooh closer.

    Yes, 192.168.0.2:30006
    Nothing yet.

    Tried changing the Network Settings IP on Basestation to 192.168.0.2 but doesn't work either.

    This is very complicated and frustrating!

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    [ATTACH=CONFIG]10580[/ATTACH]

    Ok, NAT Network was not letting me save it but I changed to bridged mode and the VM IP is now a "local" IP. So set that in the fr24feed.ini file along with 30006?
    Ooooh closer.

    Yes, 192.168.0.2:30006

    Leave a comment:


  • tomascubero
    replied
    ;ouy8.png

    Ok, NAT Network was not letting me save it but I changed to bridged mode and the VM IP is now a "local" IP. So set that in the fr24feed.ini file along with 30006?

    Leave a comment:


  • Oblivian
    replied
    Theres the VM IP, 10.0.2.15 - so that wont find your PC on 192.168.0.2

    I just noticed in the Oracle options, default setting allows outgoing requests to internet only. It's own secure network. You will need to adjust to 'NAT network' From NAT I think under network settings

    Which hopefully gives you an address on the normal network

    sudo systemctl restart fr24feed

    Will start it as a service in the background. But I believe if you then close the console window, it will quit (others will confirm). So better to just leave sitting at prompt

    'sudo fr24feed-status' should give a graphical output

    Leave a comment:


  • tomascubero
    replied
    And this is the current status:

    staus.png

    Leave a comment:


  • tomascubero
    replied
    ifconfig gives this:

    aser.png

    And which command window must stay open? I mean how to you "start" the feeder is it with this command?

    sudo systemctl restart fr24feed

    sudo systemctl status fr24feed

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    Ok I have done everything and the FR24 feeder is running on the VM but checking my FR24 stats page it says my receiver is offline so I'm doing something wrong:

    https://www.flightradar24.com/accoun...tats/?id=10549

    Maybe set 127.0.0.1?
    The command window within the VM will need to remain open for fr24feed to function.

    And fr24feed should be restarted after changing .ini settings (or visit the web page and save)

    It should allow you to go
    sudo fr24feed-status

    And see where it is going wrong.

    You can't use localhost/127.0.0.1 - as the virtual is not the device running basestation (the source) as it would if a TV stick/dump1090 would if installed. Your PC itself is the source.
    As long as the virtual machine gets a network address in the same range, it should be able see your PC. However not having set one up myself I can't confirm what the default virtual network setting may be

    The command is
    ifconfig

    It may get its own IP (and the host) on a different range to the PC but still allow them to talk to each other. The settings may be in the Oracle settings.

    Leave a comment:


  • tomascubero
    replied
    Ok I have done everything and the FR24 feeder is running on the VM but checking my FR24 stats page it says my receiver is offline so I'm doing something wrong:

    https://www.flightradar24.com/accoun...tats/?id=10549

    Maybe set 127.0.0.1?

    Leave a comment:


  • Oblivian
    replied
    Hopefully this may make some sense

    Untitled Diagram (1).jpg

    The guide assumes pass-though USB access.

    Your setup requires some internal network access instead

    /edit posted at same time. now personalised - And the default output from basestation is 30006
    Last edited by Oblivian; 2019-05-08, 07:24.

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    ABCDs example was for DVB-T.

    Yours is set for using the basestation software output. You'll need the same settings now, So replicate yours.

    127.0.0.1 is the safe way if the device can't understand 'localhost' (which happened in a fr24feed version).

    But as you are running virtual, it may need to actually be the IP of your windows PC instead - Treating it as 2 PCs, 1 with Windows, 1 with Linux, rather than 1 as you aren't using USB direct so local host won't find basestation
    Ok so my IP for my computer on my router is 192.168.0.2. Will the port be the same (30005) or 30006 as I had it before?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post

    They differ from the guide... are they ok or should I add or modify the different lines. I am concerned on the host= line as I think that has to change from localhost to 127.0.0.1

    Let me know!
    Thanks.
    ABCDs example was for DVB-T.

    Yours is set for using the basestation software output. You'll need the same settings now, So replicate yours.

    127.0.0.1 is the safe way if the device can't understand 'localhost' (which happened in a fr24feed version).

    But as you are running virtual, it may need to actually be the IP of your windows PC instead - Treating it as 2 PCs, 1 with Windows, 1 with Linux, rather than 1 as you aren't using USB direct so local host won't find basestation

    Leave a comment:


  • tomascubero
    replied
    I am using a DVB-T, so I copied my file which is below. Your file may differ depending on your receiver.
    I then deletes lines in red and inserted lines in green.
    Code:
    receiver="dvbt"
    receiver="beast-tcp"

    fr24key="xxxxxxxxxxxxxxxx"

    path="mr-dump1090.exe"
    host="127.0.0.1:30005"

    bs="no"
    raw="no"
    logmode="0"
    procargs="--net --gain -10 --lat 43.5xxx --lon -79.6xxx"
    mlat="yes"
    mlat-without-gps="yes"
    use-http=yes
    http-timeout=20

    This is the contents of my fr24feed.ini file in Windows:

    receiver="basestation"
    fr24key="left blank purposely"
    host="localhost:30006"
    bs="no"
    raw="yes"
    logmode="1"
    windowmode="1"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"

    They differ from the guide... are they ok or should I add or modify the different lines. I am concerned on the host= line as I think that has to change from localhost to 127.0.0.1

    Let me know!
    Thanks.

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    .deb

    raspbian stretch is built around debian.
    Great thanks!

    Leave a comment:


  • Oblivian
    replied
    .deb

    raspbian stretch is built around debian.

    Leave a comment:

Working...
X