Announcement

Collapse
No announcement yet.

Windows Setup/Feed Migration (virtualVM) Assistance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by tomascubero View Post
    I don't think it is... its just not getting the data from the receiver so there is something wrong between the VM and the receiver not being able to communicate with each other.
    sudo service fr24feed stop

    sudo fr24feed


    Watch the output and look for a stable connection to the TCP device/settings or any errors.

    Leave a comment:


  • Oblivian
    replied
    I just spun up a Raspbian VM the same

    And on the default 'NAT' network setting (virtual 10.0.2.x) can still reach my ADSB source on a different device/IP (192.168.0.x). So your initial issue was most likely the key not starting the uploader.

    But a screenshot of your planeplotter IO settings would assist. To ensure relay data is on correctly before attempting to source the network data from that

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Stealth View Post
    I haven't been following closely, but is this a port number issue?
    SBS device.

    So you need to hang off a external decoder directly via USB. Or use 'Basestation' software output - which is encoded

    The debain install isn't the same version of the Pi install, and well behind. I'm not 100% that it has the 'fix' that was applied to the pi version to let it decode it properly.

    But at the same time, as the decoder is external, not sure if the virtual environment is capable of seeing data from the host in realtime over tcp

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Stealth View Post
    I haven't been following closely, but is this a port number issue?
    I don't think it is... its just not getting the data from the receiver so there is something wrong between the VM and the receiver not being able to communicate with each other.

    Leave a comment:


  • Stealth
    replied
    I haven't been following closely, but is this a port number issue?

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    Correct.

    But the data out type is likely to be beast-tcp not SBS.
    Yes, tried using Beast-TCP but still the same. I can't get it to get any data at all... either from directly Basestation or Planeplotter. Don't understand what could be going wrong. All is setup correctly. I even tried closing Planeplotter to see if it was conflicting but no.

    Any other ideas why the data is not synchronizing?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    So in that case, a share from Planeplotter to the VM and FRFeeder should theoreticall work as its not interfering with Basestation's single data-out connection which apparently is set to Planeplotter right?
    Correct.

    But the data out type is likely to be beast-tcp not SBS.

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    Planeplotter may work fine. But if that is set for localhost:30006

    Basestation I believe is limited to 1x connection - Fr24feed won't be able to connect too. And therefore no data to upload.

    The alternate, is the .deb version of fr24feed is still not updated to work with SBS encoded data type after they changed format (only the pi version). But only the developers or more SBS users can confirm that.
    So in that case, a share from Planeplotter to the VM and FRFeeder should theoreticall work as its not interfering with Basestation's single data-out connection which apparently is set to Planeplotter right?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    Planeplotter works fine... the error was coming from the fr24feed.ini file, for some reason the key field was missing a character... once I fixed that I got the Online-No Data on the stats page so I reverted back to the original settings, directly from the SBS-1 and not going throught Planeplotter. Nevertheless, both give the Online-No Data.

    Yes, I got that on internal IP addresses, its working now, just need to figure out how to get the data up to FR.

    Why would I get Online-No Data? Someone else also posted the same issue on the earlier post I mentioned but never got an answer.

    Thanks.
    Planeplotter may work fine. But if that is set for localhost:30006

    Basestation I believe is limited to 1x connection - Fr24feed won't be able to connect too. And therefore no data to upload.

    The alternate, is the .deb version of fr24feed is still not updated to work with SBS encoded data type after they changed format (only the pi version). But only the developers or more SBS users can confirm that.

    Leave a comment:


  • tomascubero
    replied
    Originally posted by Oblivian View Post
    You didn't answer if planeplotter is still working or not. And how it was configured. It may have been using the RAW out of fr24feed which is now not starting.

    You may be a case of starting again with basic and building on it. As you didn't mention planeplotter was in use from the start, there is no way of knowing the true flow of data your original fr24feed was setup for using all the different software input/output.

    Forget internet addresses. We are dealing with INTERNAL addresses. Nothing is coming to/from the internet other than fr24feed needing to go out to upload

    The same way wireless devices at home can find other devices like media/chromecast etc.

    Basestation may be limited to 1 connection at a time. And now conflicting. You need to provide more information as to ALL ADSB related software and settings.

    Noone can see your stats. They are private.
    Planeplotter works fine... the error was coming from the fr24feed.ini file, for some reason the key field was missing a character... once I fixed that I got the Online-No Data on the stats page so I reverted back to the original settings, directly from the SBS-1 and not going throught Planeplotter. Nevertheless, both give the Online-No Data.

    Yes, I got that on internal IP addresses, its working now, just need to figure out how to get the data up to FR.

    Why would I get Online-No Data? Someone else also posted the same issue on the earlier post I mentioned but never got an answer.

    Thanks.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    Yeah the Planeplotter option does the same... I am positive the error is coming from the IP. By real IP you mean the actual IP on the web?
    You didn't answer if planeplotter is still working or not. And how it was configured. It may have been using the RAW out of fr24feed which is now not starting.

    You may be a case of starting again with basic and building on it. As you didn't mention planeplotter was in use from the start, there is no way of knowing the true flow of data your original fr24feed was setup for using all the different software input/output.

    Forget internet addresses. We are dealing with INTERNAL addresses. Nothing is coming to/from the internet other than fr24feed needing to go out to upload

    The same way wireless devices at home can find other devices like media/chromecast etc.

    Basestation may be limited to 1 connection at a time. And now conflicting. You need to provide more information as to ALL ADSB related software and settings.

    Noone can see your stats. They are private.

    Leave a comment:


  • tomascubero
    replied
    Ok I am moving now! Got Online-No Data at least...

    https://www.flightradar24.com/accoun...tats/?id=10549

    Leave a comment:


  • tomascubero
    replied
    I can't get the graphical status of the fr24feed with this command:

    sudo fr24feed-status

    Leave a comment:


  • tomascubero
    replied
    Yeah the Planeplotter option does the same... I am positive the error is coming from the IP. By real IP you mean the actual IP on the web?

    Leave a comment:


  • Oblivian
    replied
    Originally posted by tomascubero View Post
    Nothing yet.

    Tried changing the Network Settings IP on Basestation to 192.168.0.2 but doesn't work either.

    This is very complicated and frustrating!
    DONT TOUCH BASESTATION!

    By default. The data out is always on port 30006 in basestation. And changing any setting on that will likely stop the data from the decoder too!

    The ONLY change that should be being made, is the localhost/127.0.0.1 before :30006 in fr24feed.ini

    To the REAL IP, of the PC.

    What is planeplotter configured as for the source of data.

    If planeplotter is working, yes, there is the option to enable data-out. And use that instead.

    https://forum.flightradar24.com/thre...l=1#post116908

    Leave a comment:

Working...
X