Announcement

Collapse
No announcement yet.

Cannot see my dump1090 gmap anymore on local network

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot see my dump1090 gmap anymore on local network

    For the last week or so when I go to the gmap page (http://[local IP]/dump1090/gmap.html) all I see is the basic info/titles on the right, and a big blank page. I have tried different browsers, different computers and mobile devices, I tried a reboot of the Pi, and still nothing. What could I be doing wrong?

    UTC Last Update
    [ Reset Map ]
    DUMP1090

    (no aircraft selected)

    Aircraft (total): n/a Messages: n/a/sec
    (with positions): n/a History: n/a positions
    ICAO Flight Squawk Altitude Speed Distance Track Msgs Age

  • #2
    Sounds to me like google maps has changed it's api and does not allow access anymore even with watermark.

    First try Ctrl-F5 maybe google maps still works and it's just not loading properly.

    Anyway to change from google maps to openstreetmaps, you can use either of these options:

    Option 1:
    https://forum.flightradar24.com/thre...uot-Water-Mark

    Option 2:
    https://forum.flightradar24.com/thre...-15-dev-on-RPi

    Comment


    • #3
      Oops I should have mentioned I do have 1.15 already installed, it was working fine until a week or so ago when it suddenly stopped (and I did not make any changes)
      On the 8754 page it shows "Linux/generic/static_armel/1.0.23-8" I am not sure if that's what it showed before but I can't remember right now.
      Also, I tried ctrl F5 many times, cleared cookies, cache, etc and still no go

      Comment


      • #4
        I tried option 1 above, on step 4 I get this error:

        cp: cannot stat 'dump1090/public_html': No such file or directory

        Comment


        • #5
          I should also note that since this happened, if I do sudo reboot the Pi will go offline but will no longer come back on the network (although it will still share data apparently), I have to unplug and replug it

          Comment


          • #6
            If you have 1.15, Port conflict with dump1090 service vs run on demand likely.

            If config has anything in the extra command field. It seems to run. Clear it and ensure set to beast-tcp:30005

            In most cases when --net is added, it will ignore the bs/raw but not always

            Sent from my EML-L09 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Originally posted by 71sbeetle View Post
              I tried option 1 above, on step 4 I get this error:

              cp: cannot stat 'dump1090/public_html': No such file or directory
              Step 3 failed to download from Github.
              Delete folder dump1090
              Code:
              cd ~/
              sudo rm -rf dump1090
              Now repeat Step 3

              Code:
              cd ~/
              git clone https://github.com/mutability/dump1090.git

              The output is shown below.
              The last few line should contain 100% like in example below:

              Code:
              Cloning into 'dump1090'...
              remote: Enumerating objects: 5330, done.
              Receiving objects:  31% (1653/5330), 1.05 MiB | 
              Receiving objects:  32% (1706/5330), 1.05 MiB | 
              Receiving objects:  33% (1759/5330), 1.05 MiB | 
              .........
              .........
              .........
              Receiving objects:  98% (5224/5330), 6.69 MiB | 
              Receiving objects:  99% (5277/5330), 6.69 MiB | 
              Receiving objects: 100% (5330/5330), 6.69 MiB | 
              Receiving objects: 100% (5330/5330), 6.93 MiB | 
              2.67 MiB/s, done.
              Resolving deltas: 100% (3572/3572), done.

              Check the download
              Code:
              cd ~/
              ls dump1090
              Above command should give following output
              Code:
              COPYING             dump1090.c
              LICENSE             dump1090.h
              Makefile            faup1090.c
              README-dump1090.md  icao_filter.c
              README-json.md      icao_filter.h
              README.md           interactive.c
              anet.c              mode_ac.c
              anet.h              mode_s.c
              compat              net_io.c
              convert.c           net_io.h
              convert.h           public_html
              cpr.c               stats.c
              cpr.h               stats.h
              cprtests.c          tools
              crc.c               track.c
              crc.h               track.h
              debian              util.c
              demod_2400.c        util.h
              demod_2400.h        view1090.c
              After successfull download as above, carryout Step 4

              .
              Last edited by abcd567; 2019-03-22, 05:36.

              Comment


              • #8
                Originally posted by Oblivian View Post
                If you have 1.15, Port conflict with dump1090 service vs run on demand likely.

                If config has anything in the extra command field. It seems to run. Clear it and ensure set to beast-tcp:30005

                In most cases when --net is added, it will ignore the bs/raw but not always

                Sent from my EML-L09 using Tapatalk
                I think this is correct?

                FR24 Feeder Settings.jpg


                Originally posted by abcd567 View Post
                Step 3 failed to download from Github.

                [...]

                After successfull download as above, carryout Step 4

                .
                That worked!!! It did reset all my map settings as I expected it would but at least I have my map back! Yay thank you so much!!!

                I think I figured out what was happening on sudo reboot, an unexpected phenomenon, after I sudo reboot, my Pi will change the first few characters of its MAC address .... I don't know how or why but it seems to flip flop between 2 so I manually assigned the IP to both and if after a reboot I don't see it anymore I try the other IP and voila!

                Comment


                • #9
                  Originally posted by 71sbeetle View Post
                  I think this is correct?

                  [ATTACH=CONFIG]10439[/ATTACH]




                  That worked!!! It did reset all my map settings as I expected it would but at least I have my map back! Yay thank you so much!!!

                  I think I figured out what was happening on sudo reboot, an unexpected phenomenon, after I sudo reboot, my Pi will change the first few characters of its MAC address .... I don't know how or why but it seems to flip flop between 2 so I manually assigned the IP to both and if after a reboot I don't see it anymore I try the other IP and voila!
                  You may be connected to both ethernet and wlan? Try disabling wlan in raspi-config

                  Comment


                  • #10
                    To stop Wifi (or bluetooth)
                    First get the list of wireless devices with device number
                    Code:
                    $ rfkill list

                    Now block/unblock the required wireless device
                    Code:
                    $ rfkill block [device number]
                    
                    $ rfkill unblock [device number]

                    Comment

                    Working...
                    X