Announcement

Collapse
No announcement yet.

Windows feeder discontinued 7-May-19

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by Oblivian View Post
    As in data format over visual?

    BS relay on 30003, and if a BEAST is connected same beast binary out (just verified it's essentially source pass-through)
    What port is the beast output on?
    Just to make sure Stealth is providing the raw messages instead of the basestation output.

    Does planeplotter include its MLAT in the basestation output? That would be quite a source for bad data

    (The basestation format on its own is an unreliable data source and if FR24 is serious about data integrity it should probably turn off the SBS and Basestation input as they are not raw message formats, no matter which platform the feeder runs on)
    Last edited by wiedehopf; 2019-04-02, 11:55.

    Comment


    • #47
      Per prev example

      Whatever you want. And it's pass-through/relay. Untouched as with the raw out on FR24feed. So yes. MLAT works fine.

      planeplotter.jpg
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • #48
        So you would need to check the "raw" checkbox for the TCP/IP server in planeplotter correct?

        And then use beast-tcp as format for fr24feed running wherever.

        Comment


        • #49
          Originally posted by wiedehopf View Post
          So you would need to check the "raw" checkbox for the TCP/IP server in planeplotter correct?

          And then use beast-tcp as format for fr24feed running wherever.
          pp and fr.jpg
          io_screen.png

          Comment


          • #50
            I note the Windows feed software link is still available on the Share Your Data webpage...does this mean there has been a change of plan and Windows will still be supported post 1st May?

            Comment


            • #51
              Originally posted by FlyingAnt View Post
              I note the Windows feed software link is still available on the Share Your Data webpage...does this mean there has been a change of plan and Windows will still be supported post 1st May?
              Damn, I hope not after all the time that I and others have spent making changes just for them!

              Comment


              • #52
                There is no indication anywhere for a change of plans.

                Why should not removing the download option mean anything?

                Comment


                • #53
                  Originally posted by wiedehopf View Post
                  There is no indication anywhere for a change of plans.

                  Why should not removing the download option mean anything?
                  Just wishful thinking Alter Bursche

                  Comment


                  • #54
                    Hello
                    I have been a windows feeder using SBS-3 connected via network to Basestation running on Windows PC. Due to latest decision of FR24 dropping windows support, I quickly ordered Raspberry Pi B 3 Plus kit from ABOX. With some support from a friend and internet search I managed to boot the device with Pi24 image. Here I must admit there are no clear instructions and step by step guidance on FR24 site, which is not good. They expect everybody to understand Raspberry Pi. Anyway my first attempt to use Airspy SDR connected via USB to RpI didn't work system was up but there was not a single aircraft. I still have no idea why?
                    Then I chose the option in FR24 SBS3 via TCP entered IP address and port. Suddenly everything worked.
                    For those of you in a similar situation forced to switch from windows to Rpi, I wanted to confirm that SBS-3 and Rpi works. I am still observing and hope it will continue as it is.

                    Comment


                    • #55
                      Setting up the airspy is not quite trivial.
                      You need to run its own ADSB decoder and configure fr24-feed to beast-tcp and use the output of airspy_adsb.
                      (It's not rtl-sdr compatible and thus not supported directly by fr24 when you choose the DVB-T config option)

                      If you want further information about how you can setup airspy_adsb, you can check here:
                      https://github.com/wiedehopf/airspy-conf#airspy-conf
                      https://github.com/wiedehopf/airspy-...fa-and-piaware


                      The correct fr24feed configuration to go with the above guide is:
                      beast-tcp
                      host: 127.0.0.1
                      port: 30005

                      /etc/fr24feed.ini should look like this:
                      Code:
                      receiver="beast-tcp"
                      fr24key="xxxxxxxxxxxxxxxx"
                      host="127.0.0.1:30005"
                      bs="no"
                      raw="no"
                      logmode="1"
                      logpath="/var/log/fr24feed"
                      mlat="yes"
                      mlat-without-gps="yes"
                      use-http=yes
                      http-timeout=20
                      Last edited by wiedehopf; 2019-04-08, 08:22.

                      Comment


                      • #56
                        Thanks Wiedehopf!
                        Very helpful information. I will look into it and prepare myself in case current solution doesn't work on long term. Actually it is better for me to continue with SBS3 and RaPi, as the receiver is dedicated to the feed and I can continue using airspy as SDR for other things.

                        Comment


                        • #57
                          Originally posted by wiedehopf View Post

                          /etc/fr24feed.ini should look like this:

                          use-http=yes
                          http-timeout=20
                          [/code]
                          Not related to the Airspy question, but I revisited those last two settings you give in the .ini file this morning and found something odd. On restarting fr24feed the log file showed a lot of configuration and other steps that indicated it was talking to FR24 (although I don't usually see most of those lines). However, no data was being incremented on the FR 'data sharing' page although it showed I was 'online'. Subsequently it showed a 21 minute break in 'daily availability'. I hashed those two lines out, rebooted, and all is normal again. What is 'use-http' designed to achieve?

                          Comment


                          • #58
                            Originally posted by Stealth View Post
                            Not related to the Airspy question, but I revisited those last two settings you give in the .ini file this morning and found something odd. On restarting fr24feed the log file showed a lot of configuration and other steps that indicated it was talking to FR24 (although I don't usually see most of those lines). However, no data was being incremented on the FR 'data sharing' page although it showed I was 'online'. Subsequently it showed a 21 minute break in 'daily availability'. I hashed those two lines out, rebooted, and all is normal again. What is 'use-http' designed to achieve?
                            Alternate to UDP connection for ISPs that kill constant connections thinking they are torrenting or similar. Causes gaps in feeding in strange increments. Will then send via http instead.
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #59
                              Originally posted by Oblivian View Post
                              Alternate to UDP connection for ISPs that kill constant connections thinking they are torrenting or similar. Causes gaps in feeding in strange increments. Will then send via http instead.
                              Thanks. That's not a problem that I've had so far, I'll leave it hashed and stick with UDP. Although I must do some reading up to see if running under a VM might have been stopping the http feed.

                              Comment


                              • #60
                                I am NOT happy at all after being forced to change from Windows to Raspberry Pi with Pi24 image. Receiver is SBS-3 connected via TCP
                                Raspberry Pi stops randomly sometimes once a day sometimes after few days. The device stops completely and doesn't respond neither to Putty nor to ping.. Only solution is power off and restart. Being a person without any RasPI or Linux experience I have no idea what to do? On the other hand I am a frequent traveller and not at home always to restart the device manually. At least the Windows, basestation, SBS-3 worked perfectly once the automatic windows update was disabled during my travels.
                                Any ideas or little help into which log files I could have a look will be very much appreciated.

                                Comment

                                Working...
                                X