Announcement

Collapse
No announcement yet.

Brutal performance variations

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1l2p
    replied
    I did not observe slow performance drifts yet, it would require a stable analysis over a long period. I was waiting to have a longer overview before doing a feedback, because I also set up a powered USB hub (12V x 4A, with some ferrites cores on all cables). The RPi 3B+ power supply is still a 2.5A. For a week now, I no longer observe the problems of sudden variation and I did not have to disconnect the antenna once again.

    I even see improvement in average distance performance. The number of planes above 50nm is now higher than the nearest ones, and their number has greatly increased.

    I also note that the aberrant records that completely distorted the statistics have disappeared for a week. I no longer get this daily ultra-short-time data between 300 and 350nm. I don't know if it's related to the HUB and its more stable power supply, but everyone knows what I'm talking about. These bogus data should have been be filtered for a long time right? ;-)

    I am also wary of weather conditions that seem to have a significant influence (in addition to holiday-related air traffic). We have just gone from a very good weather to a big depression for a week. So let's wait a little longer before drawing definitive conclusions.

    Leave a comment:


  • fjuppe
    replied
    Mike,
    Thanks for your response, I'm now setting up a new installation on RPi 3B with the original Power Supply, running some gain optmizations and it looks pretty good so far.

    What I could not understand in the previous setup was the slow detoriation of performance, about 30 % or so over a month......

    Anyway, thanks !

    Leave a comment:


  • Anmer
    replied
    The FlightAware Pro Sticks (with on-board amp) draw more power that other SDR devices. The RPi needs a power supply rated at 5.1v 2.5 amps. Using a USB hub or cable to connect the Pro Stick to the RPi can affect performance.

    Leave a comment:


  • fjuppe
    replied
    Hi,

    I have another type of performance problem with my set up....
    Flight Aware stick on an external USB HUB with external Power Supply, latest image on RPi 3B (not plus).
    I have run this setup since January, I do weekly statistics with data from FR24 statistics web page.
    In february, i noticed a decrease of maximum distances. Initially I had around 250 nm as a weekly average with number of hits >200 nm at around 1000 per day. I have seen a slow decrease of these numbers during the month of February, last week of the month my max distance was down to 200 nm and number of hits >200 nm was almost down to zero. I have restarted RPi many times, also cold start of USB HUB but still poor performance.

    2 days ago I switched stick to my Windows PC, installed FR24 feed software and from the very start I am now back to initial performances.

    Looks that the RPi environment is giving a few problem with performance.

    Anybod else who have seen this behaviour ??

    Rgds

    Leave a comment:


  • elljay
    replied
    Originally posted by 1l2p View Post
    I have another feeder v1.15 that runs at the same time and has no problem.
    Originally posted by 1l2p View Post
    Before switching to 1.15 version, I only see two things left to test, changing the Pi itself and its power supply.
    Ah, I thought you'd already changed the Pi. In that case definitely worth changing over - maybe just the power supply first as they are known to cause issues if under powered.

    Leave a comment:


  • wiedehopf
    replied
    You can just copy the html folder somewhere, upgrade to 1.15 and then copy your own html folder back overwriting the new javascript stuff.

    So you can always try that, not too complicated

    Leave a comment:


  • 1l2p
    replied
    I totally agree with your analysis about ADS-B messages length and AGC. I think a "mysterious event" puts the system in a special state and then it stands there until I unplug the antenna. The effect is really immediate as soon I reconnect the antenna. The number of planes insight rises back from less than 80 to 250, and also does the max range from 50 to 200nm.

    I check it live via the FR24 dump1090 v1.14 pages, (my_local_ip 8754 - index html) and (my_local_ip - dump1090 - gmap html)

    My stats (running on another Pi) are providing similar and coherent data. It happens several times a day, it's too much to be a coincidence:

    nbplanes-day.png

    fr24__growing_distances-day.png


    I don't think I have an unidentified 1Ghz transmitter around me, which in addition would be perfectly synchronized with my actions on the antenna ;-)
    But perhaps if it's an external disturbance of this type, then it may take some time to again disturb or re-saturate the receiver. I should then have to disconnect the antenna every X minutes until the disturbance stops definitely. Sometimes, but rarely, the problem disappears without touching the antenna... But remember, I have another feeder v1.15 that runs at the same time and has no problem. Next time I will check with a spectrogram what's happen around 1090MHz. I can also try a band-pass filter, it will reduce the global signal level.

    Few days ago I tried to set the gain to 49.6 but I got the same behaviour. Indeed with a lower sensitivity and a reduced max range, but with the same problems.

    Before switching to 1.15 version, I only see two things left to test, changing the Pi itself and its power supply.

    The json format of version 1.15 is almost the same yes, but I modified the javascript 1.14 version and GoogleMap code to show daily max polar range and sectors.

    live_map.jpg

    Leave a comment:


  • elljay
    replied
    Forgot to add, abcd567 has summarised how to check what signals you're receiving here. Maybe you could run the script when everything's ok and when the problem is happening and see if there's a difference.

    Leave a comment:


  • elljay
    replied
    It sounds very odd! You've used completely different antennas, cabling and USB sticks and you get the same problem with them all which is only cured by unplugging and replugging the antenna?! Do you also have a 1090MHz transmitter that you happen to turn on at the time of the problem? The only common thing if you're changing everything else is the location you're in and the re-plugging of the antenna is just a coincidence to the real problem going away.

    Is the monitoring running on the same Pi as Dump1090 (maybe there's a network issue and the stats are incorrect)? Do your stats match the number of planes FR24 is reporting at those times? Do your stats match what the log files on the Pi are reporting? Are there definitely planes outside when the issue occurs?

    Leave a comment:


  • wiedehopf
    replied
    Signals that are too strong normally shouldn't affect the reception of the weaker signals.
    The 1090 MHz signals are transmitted in very short bursts.
    Normally the AGC does not even react to the short bursts and just uses the maximum gain available (which is a bit more than setting it to 49)
    If at all it mostly reacts to interfering signals. (If the problem was an interfering signal, unplugging the antenna should not help though)

    The AGC (-10) setting should be in hardware, not in software, so it should not be the source of the problem.

    You can always try a gain of 49 instead of -10 (it will probably reduce reception a bit though).
    Worth a try in any case.

    What monitoring are you talking about?
    Shouldn't 1.15 be the same json format for the json files?

    Leave a comment:


  • 1l2p
    replied
    Thanks a lot for your help.

    I will switch to version 1.15 as a last resort, because I am too lazy to adapt the monitoring tools I developed for the 1.14 ;-)
    I would also like to understand where the problem may come from.

    I tried different antennas, cables, connectors, reproducing the same problem. I also did not find anything in the log files (/var/log/fr24feed/fr24feed.log).

    Could this be like a receiver signal saturation problem when a lot of planes are too close (ADSB Signal Level > -3dBFS) ? I'm close to Paris with big peaks of air traffic just over my head.
    In version 1.14 (or in my settings) there would be a gain control problem that would prevent having a correct amplification again after a big saturation period?
    And that's why the antenna signal should be "reset" to zero or really low to resume normal operation in the receiver...

    Leave a comment:


  • elljay
    replied
    Maybe it's an antenna cable problem, given you say restarting the software has no effect and removing and replugging the antenna fixes it? Is there anything useful in any of the log files? Maybe try wiggling the cable next time rather than unplugging it?

    Leave a comment:


  • wiedehopf
    replied
    Why stick to that image? You could even change the dump1090 version on there i suppose.

    That's the next thing to try anyway.

    If it were a power supply problem i would expect the data to just stop. Very strange.

    Leave a comment:


  • 1l2p
    replied
    Thank you for your answer and suggestions.

    Direct SMA connectors are used with the RTL-SDR.com V3 DVB-T stick and I also used MCX adaptors for the other tested receivers and antennas with the same problem. However, I'm quite sure that the electric contacts are ok.

    I only unplug the connector on the receiver and then reconnect it and do not restart dump1090 service (v1.14). Weeks ago I tried to only restart dump1090 but with no success.

    Today morning the problem was very impressive, but since 3 hours everything seems to be back to normal.

    nbplanes_uploaded-day-2.png

    I also performed parallel tests with the same receivers and antennas on an Ubuntu Intel NUC with dump1090 v1.15~dev and never reproduced the problem.

    dump1090-v1.15dev.png

    (Yes, I could switch on the NUC version 1.15 but I would like to stay on the FR24 img Raspberry-pi with v1.14 ;-)

    Leave a comment:


  • wiedehopf
    replied
    Which connection do you replug?

    SMA connector at the receiver?

    Do you also switch it off and on at the same time?
    (If so it would be interesting if that alone fixes it)

    Maybe you are not screwing on the SMA connector well enough?
    Maybe a tiny drop of WD40 could help the connection not deteriorate (that would mean the connector is of bad quality)

    Leave a comment:

Working...
X