Announcement

Collapse
No announcement yet.

FR24 feed side-by-side with RTL-SDR package

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24 feed side-by-side with RTL-SDR package

    Hi all

    I have currently a good running FR24feed on my lite raspbian OS installation running on an RPI3b+.
    I would like to use a second dongle for use as an SDR server.
    When using rtl_test -t -d1 i select the second dongle (the first one is for ADSB) which works great.

    However when trying to start a server using the command rtl_tcp -a (ip of pi) -d 1 I get the error: rtl_tcp: symbol lookup error: rtl_tcp: undefined symbol: rtlsdr_set_bias_tee

    After some googling I found a forum post on github: /csete/gqrx/issues/555
    This got me thinking that perhaps the installation of fr24feed is incompatible with the rtl_sdr library and thus impossible to use them side-by-side?
    I have used this to install the SDR libraries:
    (youtube video with name How To Setup A Raspberry Pi With RTL-SDR Server)

    I have installed fr24feed on a clean raspbian lite installation using ssh and the bash command listen on the share your data page from flightradar24.
    It would be a pity as I have bought it just to get the opportunity to use two dongles. Who can help?

    Kind regards

  • #2
    if you installed a new version of the rtl-sdr library the only thing that could happen is that fr24feed/dump1090 wouldn't run anymore if they were incompatible.
    but that does not seem to be the case.

    it seems more like your rtl_tcp and the library are incompatible or something.

    maybe you are supposed to use some self-compiled version of rtl_tcp instead the one which you installed? (would normally be ./rtl_tcp)

    frankly i don't feel like checking the youtube video :/ so good luck

    Comment


    • #3
      Well I will try to get a clean install of raspbian and first install rtl-sdr before fr24feed to check if it makes any difference.

      Comment


      • #4
        I can't remember which part it is as I also do POCSAG using the USB stick, but either FR24, FA or one of the other installs does something with the SDR Libraries. Each time I installed (or uninstalled/tried to switch to a different function) my dump1090 1.15-dev would break and I needed to remove and do the manual librtlsdr-dev installs again.. or one of the other ones as part of the dev install process

        (these maybe..
        rtl-sdr
        librtlsdr-dev
        libusb-1.0-0-dev)

        It may be the ol FR24 'dvbt' option at work again if you chose that. Which nukes and puts on it's own USB/RTL package preferences and 1.14

        https://forum.flightradar24.com/thre...-15-dev-on-RPi
        Last edited by Oblivian; 2019-01-13, 10:23.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          As expected, the clean installation goes fine when first installing rtl-sdr, as soon as fr24feed is installed the rtl-sdr lib is trashed. Flightradar should take a look at it so that you can use them side-by-side without having to do crazy things. I am indeed using the dvb-t option in the feeder.

          Comment


          • #6
            Yeah don't do that It has some dumbed down blanket install rules

            If you want real control, follow the linked guide

            Install RTL libs etc
            Install Dump1090

            FR/FA can then be installed in data read mode, not direct USB. And it will leave the rest alone.
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Originally posted by keukenrol View Post
              As expected, the clean installation goes fine when first installing rtl-sdr, as soon as fr24feed is installed the rtl-sdr lib is trashed. Flightradar should take a look at it so that you can use them side-by-side without having to do crazy things. I am indeed using the dvb-t option in the feeder.
              Sorry i was not aware fr24feed even f***s up libraries besides installing dump1090.

              As oblivian mentioned if you change the configuration like this:

              receiver="beast-tcp"
              host="127.0.0.1:30005"

              It should pick up the data from another dump1090 that is installed.
              (dump1090-mutability in the dev version or dump1090-fa which displays some more data because it is basically the new version of dump1090-mutability, the optics are different though)

              Installation is described here:
              https://forum.flightradar24.com/thre...-15-dev-on-RPi

              Comment


              • #8
                Originally posted by wiedehopf View Post
                Sorry i was not aware fr24feed even f***s up libraries besides installing dump1090.

                As oblivian mentioned if you change the configuration like this:

                receiver="beast-tcp"
                host="127.0.0.1:30005"

                It should pick up the data from another dump1090 that is installed.
                (dump1090-mutability in the dev version or dump1090-fa which displays some more data because it is basically the new version of dump1090-mutability, the optics are different though)

                Installation is described here:
                https://forum.flightradar24.com/thre...-15-dev-on-RPi
                I think a forced apt-get install librtlsdr0 as part of the .sh which differs slightly to the -dev package we do in above
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  I will try this later today and will report how it goes! Thanks for the input, would be a pity if I cant get it to work properly.

                  Comment


                  • #10
                    Originally posted by keukenrol View Post
                    I will try this later today and will report how it goes! Thanks for the input, would be a pity if I cant get it to work properly.
                    Ok so it seems the commands used by Oblivian won't do an unconditional reinstall.
                    You can use this command instead. (the -dev packages are not strictly needed as they are only for compiling stuff as far as i know, but they don't hurt either)

                    apt-get install --reinstall librtlsdr0 rtl-sdr librtlsdr-dev libusb-1.0

                    Make sure to change the config of fr24feed first, because the install routine seems to be triggered whenever fr24feed is restarted and dvbt as config option is selected.

                    If the video you mentioned made you install a self compiled version of any of the libraries you might need to reinstall those instead.
                    Last edited by wiedehopf; 2019-01-13, 10:21.

                    Comment


                    • #11
                      Originally posted by wiedehopf View Post
                      Ok so it seems the commands used by Oblivian won't do an unconditional reinstall.
                      You can use this command instead. (the -dev packages are not strictly needed as they are only for compiling stuff as far as i know, but they don't hurt either)

                      apt-get install --reinstall librtlsdr0 rtl-sdr librtlsdr-dev libusb-1.0

                      Make sure to change the config of fr24feed first, because the install routine seems to be triggered whenever fr24feed is restarted and dvbt as config option is selected.

                      If the video you mentioned made you install a self compiled version of any of the libraries you might need to reinstall those instead.
                      Hey, what, not guilty

                      Was just the examples from the 1.15 install page of one of the packages that breaks when installing FR24 Didn't intend for them to be run as part of a fixit /amended
                      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                      Comment


                      • #12
                        Gents, you are the true MVP's. It works!

                        Comment

                        Working...
                        X